Outbound Campaign not dialing

Answered Question
Feb 9th, 2010

Hi,

ICM 7.5 (Progger)

CVP 7.0

CCM 7

All the Processes seems to be fine and the ports are also registered.

I have used the Dialogictest Utility also and i can dial the extensions from the ports.

The records are getting imported and it can be seen in the campaign manager process also.

The agent is logged in all the time to Outbound CTI client.

Attaching the logs from Dialer and Campaign Processes.

1) I am not able to dial the customer list (Agent Based Campaign). We don't have the PRI so in the dialing list i am putting the CallManager Extensions.

2) Is it essential to make a route point for Transfer to IVR campaign?

Regards,

Sandeep

I have this problem too.
0 votes
Correct Answer by Edward Umansky about 6 years 11 months ago

Actually disregard that for the moment. Take a look at the "M" and "T" columns in that trace you sent from the dialer. It is set to "N" and "I" respectively. You should review the outbound user guide to understand what these codes mean, but basically it is telling you that the skill group mode is not set correctly. You need to make sure your Admin script is setting the skill group mode correctly.

The most important part to understand is the regular 5 second heartbeat trace that the Dialer pumps out, You need to know what this tells you, what each of the columns mean. Let's look at the last one in the file. I have to split in half and delete some stuff on the right because this forum software is brain dead and will wrap long lines rather than give me a horizontal scroll bar.

17:43:25 Trace: Campaign   Skill ID    E M T H-RT Err  Abnd Cncl
================================================================
17:43:25 Trace: Sales_-IVR 00002 05003 N N I   0%   0%   0%   0%
17:43:25 Trace: TELEMARKET 00001 05002 N N I   0%   0%   0%   0%
17:43:25 Trace: Callback   00000 -0001 N A O   0%   0%   0%   0%

R-Idle/Used PreR PPA   SG-Ports   LogIn Av-Skl Av-Dlr Rsrve
===========================================================
    0/    0    0  1.50   0 (  0%)     5     0     0      0

    0/    0    0  1.50   0 (  0%)     0     0     0      0 
    0/    0    0  1.50   0 (  0%)     0     0     0      0 

The column under the letter E is really important. This is E for "Enabled". You can see for the "Sales -IVR" campaign that although 5 agents are logged in, nothing is going to happen because (a) the campaign is not enabled and (b) the number "Av-Skl" (Available with the Skill) is 0.

Somewhere in the documentation is a description of this heartbeat trace. Try to locate it and understand what the trace is telling you.

Often the problem is to do with the Admin script on the skill group that sets the outbound params. Do you have this and is it scheduled?

Regards,

Geoff

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Irfan Tariq Javed Tue, 02/09/2010 - 23:02

sandeep

in which mode you are running dialer ?

are you able to see Call on your routing script,

i hope you have follow the right configuration order for outbound dialer

check your query rule .

sandeep pokhriyal Tue, 02/09/2010 - 23:15

Hi Tariq,

Thanks for the reply.

I am running the campaign in Progressive mode.

I cannot see the call count increasing in the script.

The configuration looks fine i have matched it to the other setup also.

Regards

Correct Answer

The most important part to understand is the regular 5 second heartbeat trace that the Dialer pumps out, You need to know what this tells you, what each of the columns mean. Let's look at the last one in the file. I have to split in half and delete some stuff on the right because this forum software is brain dead and will wrap long lines rather than give me a horizontal scroll bar.

17:43:25 Trace: Campaign   Skill ID    E M T H-RT Err  Abnd Cncl
================================================================
17:43:25 Trace: Sales_-IVR 00002 05003 N N I   0%   0%   0%   0%
17:43:25 Trace: TELEMARKET 00001 05002 N N I   0%   0%   0%   0%
17:43:25 Trace: Callback   00000 -0001 N A O   0%   0%   0%   0%

R-Idle/Used PreR PPA   SG-Ports   LogIn Av-Skl Av-Dlr Rsrve
===========================================================
    0/    0    0  1.50   0 (  0%)     5     0     0      0

    0/    0    0  1.50   0 (  0%)     0     0     0      0 
    0/    0    0  1.50   0 (  0%)     0     0     0      0 

The column under the letter E is really important. This is E for "Enabled". You can see for the "Sales -IVR" campaign that although 5 agents are logged in, nothing is going to happen because (a) the campaign is not enabled and (b) the number "Av-Skl" (Available with the Skill) is 0.

Somewhere in the documentation is a description of this heartbeat trace. Try to locate it and understand what the trace is telling you.

Often the problem is to do with the Admin script on the skill group that sets the outbound params. Do you have this and is it scheduled?

Regards,

Geoff

sandeep pokhriyal Wed, 02/10/2010 - 05:40

Hi Geoff,

Thanks...

I logged one agent to the skill group and the av-skl is showing number of agents logged.

The 'E' field in the Heartbeat Trace has value N.

Comparing this Dialer process to the working one i see E field as same as there also we have E set to N.

The admin script is set and is running in Progressive_only mode with proper skill group.

Here is the new output:

15:58:58 Trace: ----Skill Stats----

15:58:58 Trace: Campaign   Skill ID    E M T H-RT Err  Abnd Cncl R-Idle/Used PreR PPA   SG-Ports   LogIn Av-Skl Av-Dlr Rsrve Rsrvd/Max Dial Talk Agnt %

=======================================================================================================================================

15:58:58 Trace: TELEMARKET 00004 05004 N N I   0%   0%   0%   0%     0/    0    0  1.50   0 (  0%)     1     1     1      0     0/   0    0    0 100%

15:58:58 Trace: Sales_-IVR 00002 05003 N N I   0%   0%   0%   0%     0/    0    0  1.50   0 (  0%)     5     5     5      0     0/   0    0    0 100%

15:58:58 Trace: Callback   00000 -0001 N A O   0%   0%   0%   0%     0/    0    0  1.50   0 (  0%)     0     0     0      0     0/   0    0    0 100%

15:59:00 Trace: (SGM)   Request skill stats, SG: 4, periph: 5000

15:59:00 Trace: (SGM)   Request skill stats, SG: 2, periph: 5000

15:59:00 Trace: (SGM)   Skill group stats received, SG: 4, agents - logged in: 1, available: 1

15:59:00 Trace: (SGM)   Skill group stats received, SG: 2, agents - logged in: 5, available: 5

15:59:06 Trace: Config received: personal callbacks [Enabled]

15:59:06 Trace: (FAILOVER)      SENT:HeartBeatRequest to CTI Server; InvokeId[24]

15:59:06 Trace: (CB)    Requesting callback records

15:59:06 Trace: (FAILOVER)      Received:HeartBeatConf from CTI Server; InvokeId[24]

15:59:06 Trace: (CM)    Received callback customer records, count: 0

15:59:08 Trace: ----Skill Stats----

15:59:08 Trace: Campaign   Skill ID    E M T H-RT Err  Abnd Cncl R-Idle/Used PreR PPA   SG-Ports   LogIn Av-Skl Av-Dlr Rsrve Rsrvd/Max Dial Talk Agnt %

=======================================================================================================================================

Edward Umansky Wed, 02/10/2010 - 10:27

Double check and make sure the campaign is enabled in configuration manager. Next, check the Call Target tab for the campaign in configuration manager; make sure the phone columns you are trying to dial are selected in the current time range. Also check the query rule tab for the campaign and make sure the time range isn't restricted there. If that all checks out, query the appropriate DL_xxx_yyy table and confirm that you have records in there with a status of "P" or "R". You can also get logs from the campaignmanager process and you should be able to see a reason why the campaign is disabled. For example you should see the dialer requesting records and campaignmanager responding.

Correct Answer
Edward Umansky Wed, 02/10/2010 - 10:32

Actually disregard that for the moment. Take a look at the "M" and "T" columns in that trace you sent from the dialer. It is set to "N" and "I" respectively. You should review the outbound user guide to understand what these codes mean, but basically it is telling you that the skill group mode is not set correctly. You need to make sure your Admin script is setting the skill group mode correctly.

sandeep pokhriyal Sat, 02/13/2010 - 13:24

Hi Guys,

Thanks a lot for your contribution in resolving the issue.

As you guys suggested the problem was with Admin Script. The outbound mode was in double quotes( "PROGRESSIVE_ONLY"). I removed the quotes and both the agent based and IVR campaign started working.

Though i have done this many times..i still configured this part wrong..anyway its always lot of learning with you guys..

Thanks again.

Sandeep

Actions

This Discussion