SIP dialing issue -DTMF

Unanswered Question
Feb 9th, 2010
User Badges:

Hi


I am facing some issue with my SIP trunk.

My setup is like CUCM > Router>ITSP link.

I am able to make outgoing call but when after a call i am dialing a pin from my CUCM ip phone which are SCCP phone the digit are not getting passes to the service provider.


My CUCM ver is 7.0


Plz let me know what to look for and also if any configuration example document you have plz share the same.

what all command shall i look for so that we can check what digit are getting dialed in the router.


Any help will be appreciated.


Thanks

Rupam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 02/10/2010 - 02:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ask you ITSP: do they support DTMF relay ?

rupam_chakra1983 Wed, 02/10/2010 - 04:12
User Badges:

Hi


The image that i am runnig on the router is c1841-advsecurityk9-mz.124-3g.bin.

The isp support dtmf relay.

What else can be done

paolo bevilacqua Wed, 02/10/2010 - 04:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Which type of dtmf-relay do they support ?

rupam_chakra1983 Wed, 02/10/2010 - 04:18
User Badges:

they support dtmf signalling RFC 2833.

Also the call is gettig established but it is not passing those digit.

there is no voice related config in the router.

Also i have configured the same standard RFC2833 in the sip trunk configuration and kept the media termination point enable.

paolo bevilacqua Wed, 02/10/2010 - 04:19
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Post router config.

rupam_chakra1983 Wed, 02/10/2010 - 04:36
User Badges:

Hi

find teh config i have done.this is the only config in the router


interface FastEthernet0/0
description WAN
ip address 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
no ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
no mop enabled

interface FastEthernet0/1
description Lan
ip address 255.255.248.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
no ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
no mop enabled


ip route 0.0.0.0 0.0.0.0
ip nat pool mypool   prefix-length 28
ip nat inside source list 1 pool mypool overload
ip nat inside source static CUCM_pub
ip nat inside source static CUCM_sub

access-list 1 permit

paolo bevilacqua Wed, 02/10/2010 - 04:41
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

So router is not involved in telephony.

Check CM settings.

rupam_chakra1983 Wed, 02/10/2010 - 05:02
User Badges:

Is in trunk i have enabled media termination point

CUCM has its software MTU registered

dtmf signalling method is rfc 2833 in the sip trunk config.

what else can be checked,

steigja Wed, 02/10/2010 - 10:33
User Badges:

Does the SIP trunk belong to the Media Resource Group List in which the MTP is in?

rupam_chakra1983 Wed, 02/10/2010 - 22:16
User Badges:

Yes


PFA the SDL trace for reference

In SDL trace i can see " FinjectDigitstoMTP=FsubscribetoMTP "


what does it mean


Message was edited by: rupam_chakra1983

Actions

This Discussion