What does per Wlan Band select and load balancing do ?

Unanswered Question
Feb 10th, 2010

Good morning.....We recently upgraded our controllers from 4.2.185 to 6.0.188 and have noticed many clients having connectivity issues. We have Aggressive load balancing turned off globally but have noticed that band select and load balancing are enabled on the

Wlan. Are these settings mutually exclusive or do they do the same thing ?  Does the Wlan setting override the default ? We have noticed that there is

output doing "debug dot11 load-balancing"

Thanx.....Dave

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
George Stefanick Fri, 02/12/2010 - 20:12

Hi Dave,

Great question. In fact i just had this same issue as well... Here is what I discovered ..

Aggressive Load Balancing is now under wireless->advance, instead of under controller. If you enable it here you have set it globally. The other way is to set it under each WLAN. So you can disable it globally and enable it by WLAN.

Make sense?

If this helps kindly rate the post ...

Thanks

George Stefanick Sun, 02/14/2010 - 07:22

Dave,

I spent 10 hours in the lab yestreday working on ALB. I discovered it to be hit or miss with wireless clients. What happens is when the window number is hit, 5 by default all other clients are asked to find other access points. For example, 5 clients are associated to an AP. When the 6th client sends a association request to the AP, the AP kindly responds with an association response (marked with reason code17). The ap will ONLY send 1 assocation frame marked with 17. It doesnt flood it...  Reason code 17 means that the AP is busy and the client should seek another ap, by standard. I tested 7 different wireless nic and some listened while other clients ignored the request and continued to pound the ap. I discovered the AP still let on the clients that ignored ot didnt understand reason code 17.

So, if you deploy ALB it will be hit or miss...

tdennehy Mon, 11/15/2010 - 12:45

Does anyone have any information on when it became "defaulted" as on?

We went from 5.2.178 this summer to 6.x (briefly) and then made the jump to 7.0.

I noticed that our Macintosh clients immediately had problems.  I don't recall turning ALB on, but after reading all these posts I went and checked and it is now on, along with band select.

Does anyone know if these were slipped in as defaults in version 7.x?

Thanks!

Nicolas Darchis Mon, 11/15/2010 - 23:18

Since this wasn't covered, I'll mention that Band select is a totally different feature from load balancing. Band Select, if enabled, will mean that the AP will not respond to 2.4Ghz probe requests in the beginning.

-If the client is also seen probing on 5Ghz, then the AP will reply on probe requests only on 5ghz, pushing then the client to associate to 5ghz and not 2ghz.

-If the client is never seen probing on 5ghz, it's declared as single-band client and the AP will reply to probes on the 2.4 Ghz from there on.

Band Select is a big + for data networks, pushing clients on the 5ghz but it also adds delay in the association and is recommended to be disabled for sensitive clients (PDAs, phones, ...).

Hope this clarifies.

Nicolas

===

Dont' forget to rate answers that you find useful

tdennehy Tue, 11/16/2010 - 09:26

I believe we never had load balancing turned on when running 5.2 code. We jumped from 5.2 to 6.x temporarily and then to 7.0 within a 30 day time frame this summer. We're a large university and we had very few users on WiFi during that time.

The Macintosh laptops are having nothing but trouble since school began, and I have gone over everything and found that band select is turned on as well as load balancing. Since band select didn't exist in 5.2 (I believe) I know it wasn't on. As for load balancing, I don't believe it was on, and I discovered it was turned on when recently reviewing our configs.

The Macintosh laptops have been debugged and our Mac gurus tell us they're getting a message that equates to "the AP is busy, or the AP is full". This leads me to believe that load balancing got turned on during the upgrade and we didn't notice, which caused the Macintoshes to have issues.

We don't have any VoWiFi clients so we don't have to support them, and we don't officially support smartphones, either.

I turned off load balancing and will see how it goes....

Thanks!

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode