CCX recording mode

Unanswered Question
Feb 10th, 2010

Hi, all!

I have CCX 7.0 installation and I have one small problem that I cannot find solution for. CCX recording - there are two modes of recording - "SPAN port recording" and "desktop recording". How do I tell CCX system to use "desktop recording"?

At the moment it seems that servers are trying to use "SPAN recording" and, obviously, are recording silence because SPAN is not configured in the LAN. I used NICQ utility to check if netcards in PCs are fine - they are (promiscous mode is supported, voice traffic is heard, CDP neighors detected, etc. - all tests successful). So, it seems that there is some setting I'm missing. I checked docs and couldn't find it. Any ideas? Could somebody point me to the right direction?

Thank you!

Ervins

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Mon, 02/15/2010 - 06:12

Hi

Desktop Monitoring is the default; you don't have to configure anything on the server for it to work.

I would start by enabling debugging on your CAD installs and looking there for errors.

It sounds like you've checked the NIC-related stuff OK.. I would probably also check that you are running G711 on your calls as G722 isn't supported for monitoring/recording.

Regards

Aaron

e.gailiss Mon, 02/15/2010 - 06:22

Thank you for your reply!

As you correctly guessed I already checked NICs. There everything is fine. Also, I have turned up debugging and checked the logs. I see that agent requests server to record to, gets the server and desktop initiates recording. I also checked that G.711 is used - I disabled G.722, and during the call I pressed "?" two times to get call info. All looks fine, except I get empty recorded files and monitoring supervisor does not get anything. Any ideas, what else to check?

Also, maybe you know, "monitoring" uses only desktop to send voice stream - no SPAN at all? If that is the case, then i'll concentrate to getting monitoring to work first and hope that this will solve the recording. I'll re-check codec settings, also.

Thank you!

Ervins

Aaron Harrison Mon, 02/15/2010 - 06:53

Hi

Both recording and monitoring use the same service and technology... the only difference is that for a monitor session the stream is sent back out to the sup rather than being written to disk.

How are your server NICs configured?

For a SPAN setup, you would normally set the second NIC as the sniffing NIC via postinstall.exe.

If you aren't using SPAN, I leave the second NIC disabled and bind the service to the primary NIC via postinstall.exe.

Regards

Aaron

e.gailiss Mon, 02/15/2010 - 07:10

My understanding is that monitor send voice stream to monitoring supervisor and recording send data to recording server. The question is - is it the same Ethernet frame or it gets encapsulated into another frame. My quess is - it should be encapsulated. Otherwise it would not work across LANs, where agent and supervisor are on different subnet.

My intent is to avoid using SPAN if at all possible. In my case I get recordings of correct length but only empty. This could mean 3 things -  (a) incorrect codecs, (b) agent desktop not sending data, (c) server expecting SPAN recording. Right?

Ervins

Aaron Harrison Mon, 02/15/2010 - 07:34

Hi

Yeah, it will work accross L3 boundaries no problem. I'm fairly sure the traffic flow is agent --->> server  -->> supervisor when monitoring rather than direct.

Most of the problems are at the client end, relating to the NIC setup or the handset setup - you've already checked that, so in your agent debug logs you should see the software finding the packets...

The only thing I can think of is that the media isn't being received properly at the server end. If you have the monitor service bound to the wrong NIC that may be why it's not saving the packets...

In the deployments I've done I always use desktop monitoring, and aside from checking the NIC assignments in postinstall (c:\Program Files\cisco\Desktop\bin\PostInstall.exe) as I put in my previous post there is nothing to configure on the server.

You can enable/disable it per device via this URL, but you'll see that 'Desktop Monitoring' is enabled by default.

http://ccx-ip:6293/teamadmin/login.cda

Aaron

Actions

This Discussion

Related Content