ssh connection to Pix

Unanswered Question
Feb 10th, 2010
User Badges:

Let me describe what I'm doing first and then

I'll describe the problem i've encountered.


I'm building out a Test and Dev environment.


I have a pix 535 in the front end...I wanted to be able to remote into the Pix to complete the configuration so i did the following:


1.  config'd a phys interface in the admin context

2.  turned on ssh

3.  turned on icmp

4.  created access-group to allow ip any and icmp any

5.  configured a private address 192.168.15.x /29 on the interface in the admin context

6.  configured a private address on one of my production switches with a corresponding 192.168.15.x /29 address on my router interface.

7.  configured local user/password and turned on aaa LOCAL authentication


I can SSH between the switch and the pix while i'm at the switch console, no problem...


However,  I remote into my switch from a desktop (my office), and then attempt an ssh session from the switch to the Pix and I get as far as the Pix user mode prompt.


At this point, i can go no further.  Its almost like it is locked up...I cant enter any commands...If i let it sit, it will eventually time out..


I'm stuck...


any thoughts?


Bruce

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kureli Sankar Wed, 02/10/2010 - 18:36
User Badges:
  • Cisco Employee,

ssh -l admin 10.10.10.10



Router#ssh ?
  -c    Select encryption algorithm
  -l    Log in using this user name
  -m    Select HMAC algorithm
  -o    Specify options
  -p    Connect to this port
  -v    Specify SSH Protocol Version
  WORD  IP address or hostname of a remote system




from the switch where admin is the user ID that you created in the local database of the PIX


-KS

Actions

This Discussion