OSPF cost with FastEthernet subinterfaces

Unanswered Question
Feb 10th, 2010
User Badges:

Hi,


I am currently having Metro Ethernet Connection from service provider, they have provided us primary and backup link to our branches.

they have provided us last mile copper (fast ethernet) and have two VLANS, for that i have created subinterfaces, did same on branches routers as well.

i want to use primary link (e.g fastethernet 0/0.1, ip 1.1.1.1/30) and when it is up i want all traffic go out through this interface. and incase of any problem backup link ( fastethernet 0/0.2, ip 2.2.2.1/30) will be utilized.


i set ospf cost 10 on fastethernet 0/0.2, but still receiving time outs.


please let me know that does ospf cost works with ethernet subinterfaces?


regards

Zafar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 02/11/2010 - 00:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Zafar,

OSPF cost can be set on a per vlan subinterface basis but you have set a cost = default cost


check with

sh ip ospf interface


if second subinterface needs an higher cost use something like

ip ospf cost 100


Hope to help

Giuseppe

zafar12233 Thu, 02/11/2010 - 01:16
User Badges:

Hi Giuseppe,


i have set the following


HO router

--------------


int fastethernet 0/0.1

description *** PRI LINK ***
ip address 1.1.1.1 255.255.255.252

ip ospf cost 1



int fastethernet 0/0.2

description *** PRI LINK ***
ip address 2.2.2.1 255.255.255.252

ip ospf cost 10



branch office router

-----------------------------



int fastethernet 0/0.1

description *** PRI LINK ***
ip address 1.1.1.2 255.255.255.252

ip ospf cost 1



int fastethernet 0/0.2

description *** PRI LINK ***
ip address 2.2.2.2 255.255.255.252

ip ospf cost 10


Branch router is getting routes through interface int fastethernet 0/0.1


but when we ping the host behind branch router, we receive timeouts.


please advice




Ganesh Hariharan Thu, 02/11/2010 - 01:59
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi Giuseppe,


i have set the following


HO router

--------------


int fastethernet 0/0.1

description *** PRI LINK ***
ip address 1.1.1.1 255.255.255.252

ip ospf cost 1


int fastethernet 0/0.2

description *** PRI LINK ***
ip address 2.2.2.1 255.255.255.252

ip ospf cost 10



branch office router

-----------------------------


int fastethernet 0/0.1

description *** PRI LINK ***
ip address 1.1.1.2 255.255.255.252

ip ospf cost 1



int fastethernet 0/0.2

description *** PRI LINK ***
ip address 2.2.2.2 255.255.255.252

ip ospf cost 10


Branch router is getting routes through interface int fastethernet 0/0.1


but when we ping the host behind branch router, we receive timeouts.


please advice

Hi Zafar,


What is the ospf configuration of branch router and have you configured the lan subnet under router ospf command to enter into ospf protocol.


HTH


Ganesh.H

zafar12233 Thu, 02/11/2010 - 03:41
User Badges:

Hi Ganesh,

thanks for your reply.


HO Router ospf configuration


router ospf 1

network 1.1.1.0 0.0.0.3 area 2

network 2.2.2.0 0.0.0.3 area 2

network 10.21.21.0 0.0.0.255 area 0


Branch office


router ospf 1


network 1.1.1.0 0.0.0.3 area 2

network 2.2.2.0 0.0.0.3 area 2

network 10.42.42.0 0.0.0.255 area 2

Giuseppe Larosa Thu, 02/11/2010 - 10:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Zafar,

as Ganesh has noted it is important to know if you had changed accordingly costs on the branch router (sub)interfaces or not.


OSPF processes configuration looks like fine and should allow for building OSPF adjacencies.


What are you trying to reach with your tests?

What do you mean with " I still see timeouts"?


if you have excessive traffic on primary link you may want to divert selected traffic flows to secondary path using PBR policy based routing.


It is important to describe your scenario in order to get better help


Hope to help

Giuseppe

zafar12233 Thu, 02/11/2010 - 20:59
User Badges:

Hello Giuseppe,


there is no problem with ospf adjancies I get all routes through primary link, when i try to ping the hosts behind the router, i get time outs

like 4 successfull reply and then two timeouts and then again it happens.



let me attach the diagram.




please let me know if you need more details.

Attachment: 
Giuseppe Larosa Fri, 02/12/2010 - 00:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Zafar,

as written before, are costs manipulated on branch router on subinterfaces in the same way or not?


without this information is difficult to say if your routing is fine or not.


or you can post a sh ip route of the source as seen by branch point of view.


Hope to help

Giuseppe

zafar12233 Wed, 02/17/2010 - 21:40
User Badges:

hi Giuseppe,


sorry i got busy in other tasks, one of our ASA got failed :-s and plus storage issues.


I hope you are doing well.



well the answer of your question is YES costs manipulated on branch router on subinterfaces in the same way


i have one more question regarding our ASA 5510 and its AIP SSM 10 which i have posted in "Intrusion Prevention Systems/IDS" section.



regards


zafar

Kevin Dorrell Wed, 02/17/2010 - 23:38
User Badges:
  • Green, 3000 points or more

I'm not convinced this is anything to do with link costs.  I think the main things to consider are:


  • What does the actual routing table look like in the branch?
  • What does the routing table look link in the HQ for area 2 routes?
  • What does netstat -r look like in the host you are trying to ping?
  • Is there any evidence of route flapping or other instability?
  • Is there any evidence of congestion dropos on the links?


Kevin Dorrell

Luxembourg

zafar12233 Thu, 02/18/2010 - 00:04
User Badges:

Hi Kevin Dorrell


  • What does the actual routing table look like in the branch?

         branch router receives route from that subinterface that has lowest ospf cost.


  • What does the routing table look link in the HQ for area 2 routes?

        HQ router receives route from that subinterface that has the lowest ospf cost.


  • What does netstat -r look like in the host you are trying to ping?


        default route is branch router's LAN interface that is connected with the switch.

  • Is there any evidence of route flapping or other instability?

        please guide me how to check it.

  • Is there any evidence of congestion dropos on the links?

        no congestion.

glen.grant Thu, 02/11/2010 - 09:27
User Badges:
  • Purple, 4500 points or more

  Are you saying you aren't getting ospf adjacencies for the branch routers ???   By timeouts what are you referring to ?   If pinging to branch devices verify the default gateway on the branch devices you are trying to ping.  Verify any software firewalls are shutoff on the clients you are trying to ping .

Actions

This Discussion