How to configure PPPoE authentication on the Ethernet switch of a Cisco877

Answered Question
Feb 11th, 2010
User Badges:

Hi all,



i have a cisco 877 for Internet Access.

This router should negotiate it's IP via PPPOE on one of the Ethernet interfaces.


Now to my question:

1. is it possible to configure PPPoE in one of the switching interfaces?

2. If yes, how do we configure a dialer profile to act on one of the switching interfaces fa0

3. What is wrong, if the following message occurs:


Feb 11 13:44:41.478: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:45.397: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:46.441: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:50.104: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:50.872: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:54.495: Di1 DDR: Cannot place call, no dialer string set
Feb 11 13:44:55.742: Di1 DDR: Cannot place call, no dialer string set


here the config:


interface Vlan99
description Internet Access
no ip address
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly
crypto map FESTO
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname [email protected]
ppp chap password 0 XXXXXXXXXXXXXX
ppp pap sent-username [email protected] password 0 XXXXXXXXXXX
crypto map FESTO

!

interface FastEthernet0
description Internet Access
switchport access vlan 99
pppoe enable group global
pppoe-client dial-pool-number 1

Correct Answer by Paolo Bevilacqua about 7 years 1 month ago

Will work, just get to know VPI/VCI and do a regular PPPoE config.


Worst case, will need an ADSL upggrade.


Note in most cases, where PPPoE works also PPPoA do, that lets you use the full MTU of 1500.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Thu, 02/11/2010 - 05:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What prevents you from connecting the ADSL interface instead ?

joepena2012 Thu, 02/11/2010 - 06:07
User Badges:

:-) To be honest, i don't know. I'm sitting in germany, and the 877 is in VE. The guys there assuming that the ATM would not work

Correct Answer
Paolo Bevilacqua Thu, 02/11/2010 - 06:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Will work, just get to know VPI/VCI and do a regular PPPoE config.


Worst case, will need an ADSL upggrade.


Note in most cases, where PPPoE works also PPPoA do, that lets you use the full MTU of 1500.

Actions

This Discussion