phones not syncing time properly

Unanswered Question

We are using CUCM 6.1.  We have mostly 7961's and some 7941's, all using SCCP.  I have the NTP References pointing to our PDC emulator and a backup.  The PDC syncs to an external source. I have the date/time group configured to use both NTP Refernces, and all the phones are in that date/time group.

But I cannot get the phones to sync the time properly. I've done a reset, restart, etc.  What else am I missing?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
CHRIS CHARLEBOIS Thu, 02/11/2010 - 10:20

Is it just the phones or are the CUCM servers off time also?  You can check from the server CLI by issuing a 'show status' command, which will list the time after the date.  If the server and the phones agree, perhaps NTP packets are getting blocked by a firewall or acl.

Is the time off by a whole hour amount?  By that, I mean are the phones off by exactly 1 or 2 hours?  I would assume that would be a timezone problem.

Thanks for your response.  I can't determine the time on the CUCM, because the company that deployed it here apparently set a differ

ent username and pw for the OS admin than for CCM admin, so I can't log in to run the "show status" command.

The time is only around 5-6 minutes off, so I'm pretty sure it's not an issue with the time zone.

CHRIS CHARLEBOIS Thu, 02/11/2010 - 11:55

If you can access the OS CLI, trying issuing the 'utils ntp config' command.  If that is missing, you can use the 'utils ntp server add' command to define that.  Take a look at the command reference:

If the 'utils ntp config' shows that it is corrected configured, but still not working, make sure there is communication with the ntp server IP address.  'utils network ping' to see if it is reachable.


jleehawkins Thu, 02/11/2010 - 12:51


The "Phone NTP Reference" is used only for SIP phones.  SCCP phones receive their time from the CUCM.

If you have access to the CLI run "utils ntp status".  Ensure you see that the CUCM is synchronised to your NTP server.  Ensure your NTP server service is running and has the correct time.  Ensure your CUCM has network access to the NTP server.  Access the OS admin webpage and check the Settings>NTP Servers page for the status "The NTP service is accessible."  Ensure the NTP stratum is below 9.  Ensure your PDC can act as an NTP master.

Let me know if this helps.


Thanks. I've been able to do some of what you mentioned ,but the phones are still not in sync.

the PDC is set to use

the time on the PDC does match that of official us time.

the CUCM is pointing at the PDC's IP address.

doing "show status" on the CUCM has the time still off.

Time on the phones is still off.

I can ping the PDC from the CUCM

PDC is set to be master b/c all xp clients sync to it properly.

What else could I be missing?

jleehawkins Thu, 02/11/2010 - 13:55


Is it safe to assume that since you are using the term "PDC" that you are using a windows NT domain with PDCs and BDCs?  Or is your windows domain 2000 or above?  In either case Windows boxes by default use the Win32time to sync time among systems within its domain.  Windows systems can be an NTP client but by default can not be a NTP master.  Since win32time can not act as a master NTP server the CUCM doesn't have anything to sync its time to. 

When CCM was installed on a Windows system an NTP service was installed that could act as a NTP service.  But that NTP service was something Cisco added to the Windows OS not something that came with the system.

If you run "utils ntp status" from the CUCM OS CLI I will verture to bet that the CUCM is not synced with your your PDC.  Or the NTP status from the web interface says "The NTP service is NOT accessible."

Either point the CUCM to directly or add an NTP server to the PDC.

Check this website:



This Discussion

Related Content