Static IP routing over PPPoA DSL using 7200 aggregation

Unanswered Question
Feb 11th, 2010

I am trying to setup static IP addressing using PPPoA with a 7200 router as our ATM aggregation router. As so far have been unsuccessful. Looking for tips or hints as to how to make this work. Currently using this for ADSL deployments to customers. Works great as long as its running DHCP, but cannot figure out how to statically set IP's behind modems to hand to our customers. Any tips or hints would be great. I have edited the config for some anonymity, example config below:

version 12.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname DSL1
!
boot-start-marker
boot system flash disk0:c7200-k91p-mz.122-25.S15.bin
boot system flash disk0:c7200-js-mz.123-26.bin
boot-end-marker
!
aaa new-model
aaa authentication login default enable
aaa authentication login LOCAL_AUTHEN group radius local
aaa authentication ppp default local
enable secret *******
enable password *********
!
clock timezone MST -7
clock summer-time MDT recurring
ip subnet-zero
ip cef
!
!
ip domain-name provider.local
ip name-server 2.2.2.2
ip name-server 3.3.3.3
ip dhcp excluded-address 1.1.1.49
ip dhcp excluded-address 1.1.1.193
ip dhcp excluded-address 1.1.1.225
!
ip dhcp pool CUSTOMER
   network 1.1.1.224 255.255.255.248
   default-router 1.1.1.225
   dns-server 2.2.2.2.2 3.3.3.3
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
class-map match-any voice-cls
  description "VoIP Payload"
  match ip dscp cs3
  match ip precedence 7
class-map match-any signaling-cls
  description SIP
  match ip dscp cs5
  match ip precedence 6
!
!
policy-map voip-pvc-pmap
  class voice-cls
   priority percent 33
  class signaling-cls
   priority percent 5
  class class-default
   fair-queue
policy-map voip-eth-pmap
  class voice-cls
   priority percent 33
  class signaling-cls
   priority percent 5
  class class-default
   fair-queue
!
bridge irb
!
!
interface Loopback0
no ip address
no clns route-cache
!
interface Loopback32
description "Office-Gtwy"
ip address 1.1.1.225 255.255.255.248
no clns route-cache
!
interface FastEthernet0/0
ip address 4.4.4.46 255.255.255.252
service-policy output voip-eth-pmap
duplex full
speed 100
no clns route-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface ATM1/0
no ip address
atm scrambling cell-payload
atm framing cbitplcp
atm lbo long
no atm ilmi-keepalive
no atm enable-ilmi-trap
no clns route-cache
!
interface ATM1/0.32 point-to-point
description "Office"
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/32
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.33 point-to-point
description "customer1"
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/33
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.34 point-to-point
description "customer2"
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/34
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.35 point-to-point
description "customer3"
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/35
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.36 point-to-point
description "customer4"
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/36
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.37 point-to-point
description customer5
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/37
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.38 point-to-point
description customer6
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/38
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.40 point-to-point
description customer7
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/40
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.42 point-to-point
description customer8
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/42
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM1/0.43 point-to-point
description customer9
ip unnumbered FastEthernet0/0
no atm enable-ilmi-trap
pvc 1/43
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface Virtual-Template1
description "PPPoA with Authentication"
ip unnumbered FastEthernet0/0
peer default ip address pool DSL-POOL-1
ppp authentication pap
no clns route-cache
!
interface Virtual-Template2
description "PPPoA No Authentication"
ip unnumbered FastEthernet0/0
peer default ip address pool DSL-POOL-1
no clns route-cache
!
interface Virtual-Template3
description "PPPoA with CHAP Authentication"
ip unnumbered Loopback32
no peer default ip address
ppp authentication chap
no clns route-cache
!
ip local pool DSL-POOL-1 1.1.1.193 1.1.1.223
ip classless
ip route 0.0.0.0 0.0.0.0 4.4.4.45
!
no ip http server

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion