DHCP server setup

Unanswered Question
Feb 11th, 2010

hello,

This is my first time here but i hope that i can get some help,

So here we go, I am taking the CCNA courses right now in college and we are doing a project, i have set up the DHCP service to run on R1 and have 3 subnets connected to it through diffrent interfaces ( Fa0/0 172.168.9.0/26, Fa0/1 172.168.9.64/26, Fa1/0 172.168.9.128/26 ) everything is working great, then i decided to inprove the efficiency of my router i would have a multilayer switch connect to just one interface and have all the subnets connect to that single interface, i know it can be done.

     Now this is my problem, i have searched the net and looked in all my books but i can not find how to setup a dhcp pool for multiple subnets with one interface as the default route, all i have found is that i need secondary pools or something like that. If anyone can help me i would really appreciate an explanation or even an example with the command lines showing how this is done,

Thanks for reading this and i hope you can help me

sample.png

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nqtran1979 Thu, 02/11/2010 - 10:52

Randel,

I'm assuming the pic you've attached is what you got working.

Can you draw up how where the Multilayer Switch is connected? ... is it between the router and the three switches?

Have you configured a trunk on the L3 switch towards the router (in which case you will need to setup sub-interfaces on the router interface connecting to the L3 switch, DHCP config would remain the same on the router).

If the link between the L3 switch and the router is a routed port, then i think (i need to lab it up myself to be sure) you will need to configure ip helper-helper addresses on each vlan (on the L3 switch) pointing to the router.

HTH

Reza Sharifi Thu, 02/11/2010 - 11:14

Hi Randel,

You need to create sub-interfaces with dot1Q encapsulation on your 2621XM router if you are going to be using only one interface on you router. It is also called "router on a stick"

Take a look at the config below and change the IPs to fit your design

interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 172.16.10.1 255.255.255.0
ip helper-address 172.16.1.1
no snmp trap link-status
!
interface FastEthernet0/0.2
encapsulation dot1Q 11
ip address 172.16.11.1 255.255.255.0
ip helper-address 172.16.1.1
no snmp trap link-status
!
interface FastEthernet0/0.3
encapsulation dot1Q 12
ip address 172.16.12.1 255.255.255.0
ip helper-address 172.16.1.1
no snmp trap link-status

FastEthernet0/0.1          172.16.10.1     YES manual up                    up     
FastEthernet0/0.2          172.16.11.1     YES manual up                    up     
FastEthernet0/0.3          172.16.12.1     YES manual up                    up

HTH

Reza

Actions

This Discussion