Does Direct iBGP peering needed for VPNv4 Routes to be advertised accros P routers?

Unanswered Question
Feb 11th, 2010

Hi every one.im in situation that i have 3 routers.

R1<-->R2<-->R3

R1 is R2 ibgp peer and r2 is r1 ibgp peer.also r2 is ibgp peer with r3.my under laying routing protocol is OSPF and im running MPLS between these routers.I have VPNA on R1 and also i have activated peers for extended communities to enabling MP-BGP between routers.when i do show ip bgp vpnv4 unicast all on R2 i can see VPNA routes received from R1 but when i do this show command on R3  there is nothing but if i Peer R3 to R1 using iBGP  THE VPNA routes shows on R3 too.so i have this question, Does this thing mean that for receiving vpnv4 routes on R3 I have to configure iBGP between R3 and R1, so R2 cant carry these routes to R3? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amit.bhagat Fri, 02/12/2010 - 01:36

Hi,

This sort of design is not right. MPLS VPN's biggest advantage is BGP-free core, meaning, the P-routers dont have to run BGP at all; IGP should be enabled for reachability between PE & P routers.

You can use the following config for your routers-

R1 router-

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

ip vrf CUST1

rd 1:1

route-target both 1:1

!

interface Loopback 0

ip address 1.1.1.1 255.255.255.255

ip ospf 1 area 0

!

interface fastethernet 0/0

description Connection to R2 router

ip address 10.1.1.1 255.255.255.252

ip ospf 1 area 0

!

router bgp 65100

neighbor 3.3.3.3 remote-as 65100

neighbpr 3.3.3.3 update-source Loopback 0

neighbor 3.3.3.3 description IBGP_to_R3 router

!

address-family vpnv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 send-community both

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

R2 router-

interface fastethernet 0/0

description Connection to R1 router

ip address 10.1.1.2 255.255.255.252

ip ospf 1 area 0

!

interface fastethernet 0/1

description Connection to R3 router

ip address 10.1.1.5 255.255.255.252

ip ospf 1 area 0

!

R3 router-

mpls label protocol ldp

mpls ldp router-id Loopback 0 force

!

ip vrf CUST1

rd 1:1

route-target both 1:1

!

interface Loopback 0

ip address 3.3.3.3 255.255.255.255

ip ospf 1 area 0

!

interface fastethernet 0/0

description Connection to R2 router

ip address 10.1.1.6 255.255.255.252

ip ospf 1 area 0

!

router bgp 65100

neighbor 1.1.1.1 remote-as 65100

neighbor 1.1.1.1 update-source Loopback 0

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community both

exit-address-family

!

address-family ipv4 vrf CUST1

redistribute connected

exit-address-family

!

Here, I just redistributed connected networks into the VRFs. However, you can use an PE-CE routing protocols.

As above you only need MP-iBGP peering between R1 and R3 routers.

HTH.

Regards,

Amit.

Reza Sharifi Fri, 02/12/2010 - 18:49

blackhat2020 wrote:

Hi every one.im in situation that i have 3 routers.

R1<-->R2<-->R3

R1 is R2 ibgp peer and r2 is r1 ibgp peer.also r2 is ibgp peer with r3.my under laying routing protocol is OSPF and im running MPLS between these routers.I have VPNA on R1 and also i have activated peers for extended communities to enabling MP-BGP between routers.when i do show ip bgp vpnv4 unicast all on R2 i can see VPNA routes received from R1 but when i do this show command on R3  there is nothing but if i Peer R3 to R1 using iBGP  THE VPNA routes shows on R3 too.so i have this question, Does this thing mean that for receiving vpnv4 routes on R3 I have to configure iBGP between R3 and R1, so R2 cant carry these routes to R3? Thanks.

Yes, you need to configure R3 and R1 to peer IBGP. Another word, all your routers have to peer with one another.  The other thing you could do is make R2 a router reflector and just peer R1 with R2 and R3 with R2 and that would also solve your issue.

HTH

Reza

blackhat2020 Thu, 02/18/2010 - 07:52

Thank you all guys,the trick was to make R3 route reflector client of R2 or in another word R2 be the Route Reflector for R3 but instead of in Global BGP configuration mode it must be done under address-family VPNv4 to make the R2 sends its VPNv4 routes (not Global Routing Table) to R3.

Actions

This Discussion