QoS For VOIP - Non Cisco PBX

Unanswered Question
Feb 12th, 2010
User Badges:

Greetings, im currently in the process of configuring a QoS policy between two sites connected using ADSL2 links and IPSEC/GRE tunnels.


The phone system, an NEC SV8100 is located at the head office and serves local phones it is also connected to an ISDN PRI, the branch office houses 10 IP phones which are registered with the NEC system via the GRE/IPSEC tunnel, i have been informed that the phones use SIP for call setup and teardown on port 5060,5070 and 5080.


NEC IP Address: 192.168.10.100

NEC VOIP Media Address: 192.168.10.102

Intersite Codec: G729


DSL Connection: 8000Kbps/792Kbps


Im very much aware of how i would do this with a Cisco PBX as i deploy CME all the time but could i check that the following policy is suitable for intersite voice traffic please, i intend to replicate this at the head office also on an ADSL2 circuit.


Branch Office


ip access-list extended voiceTraffic
  permit udp any any eq 5060
  permit udp any any eq 5070
  permit udp any any eq 5080
  permit ip any host 192.168.10.100
  permit ip any host 192.168.10.102

!

class-map match-any callTraffic
match access-group name voiceTraffic
!
!
policy-map callTraffic
class callTraffic
    priority 256
policy-map GLOBAL
class class-default
    shape average 792000
  service-policy callTraffic

!

interface Tunnel0
bandwidth 8000
ip address 10.255.255.14 255.255.255.252
ip mtu 1420
ip nbar protocol-discovery
qos pre-classify
tunnel source Dialer1
tunnel destination x.x.x.x
tunnel path-mtu-discovery
crypto map bhxmap

!

interface Dialer1
description WAN Interface
mtu 1492
bandwidth 792
tx-ring-limit 3
crypto map bhxmap
service-policy output GLOBAL

!

router eigrp 1
passive-interface Dialer1
passive-interface Vlan1
network 10.255.255.0 0.0.0.255
network 192.168.50.0
no auto-summary
eigrp stub connected summary

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Sat, 02/13/2010 - 05:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Do you have the ADSL interface in the router ? That would be much better.


Also, you can pretty much disregard signalling, and try using a DSCP match, maybe they are sane and use EF:

Mark Rigby Sun, 02/14/2010 - 12:13
User Badges:

I do have an ATM interface on the router, i can if needs be created a subinterface and apply the policy there, i have also since been given the DSCP settings from the PBX engineer, 40 and 48 apparently.


Regards

Actions

This Discussion