Configure incoming call in CUCM 7.1

Answered Question
Feb 14th, 2010
User Badges:

Dear all,



Could anybody tell me how to configure incoming call via E1 interface to MGCP Gateway. If i'm using H323 Gateway, i just need to add command direct-inward-dial in the outbound dial peer to make it inbound dial peer.


I'm also facing a situation, i've already configure E1 interface in CUCM but the status of E1 endpoint in CUCM is unregister. I wonder why this is happening.



Thanks.

Correct Answer by billybjo1 about 7 years 5 months ago

For the calls to be accepted, just make sure the CSS and Signficant digits are correct on the "Inbound Calls" settings on the E1 port config page. Also make sure the Device Pool & Location have the right settings.


If the E1 is unregistered, no calls will get through anyway. So you either have something incorrect in the config or the E1 has a problem (physical or Telco). A quick way of checking the E1 is just briefly temporarily set the gateway up as H323 which is independant of CUCM. If the line comes up and is functional, then you have something wrong in the MGCP config on CUCM. Some possible things to check:


IP Connectivity - Router<>CUCM should be able to communicate.

Gateway & Domain Name - Must match router exactly (very common mistake).

Module and Subunits - Make sure they match the hardware installed.

PRI Protocol Type/Protocol Side - Make sure they match the Telco specification.

Enable Status Poll - If ticked, make sure you have the channels set in Service Params Advanced.


Obviously there are many other settings, but those are often the ones that might prevent an E1 registering properly.


"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
kstyczynski Sun, 02/14/2010 - 05:51
User Badges:

Hi,

With MGCP you have to configure the actual gateway and its voice ports on the CUCM.

You also have to configure the gateway itself with commands that will point it to the CUCM as a call agent.

If you use E1 you will also have to configure the E1 controller with a "service mgcp" command.


This is a good starting point:


http://www.cisco.com/en/US/tech/tk652/tk701/tk419/tsd_technology_support_sub-protocol_home.html


For troubleshooting on the gateway the most valuable commands are:

show mgcp

show ccm-manager


Regards,

Chris

triandi_sugiharto Mon, 02/15/2010 - 05:53
User Badges:

Hi Chris,




i know the command to tell MGCP that CUCM is the MGCP call agent. In the gateway, i just need 2 command :

ccm-manager config

ccm-manager config server (ip address cucm)


I have checked the gateway registration using show mgcp. And the gateway is already registered to CUCM. But i wonder, why the E1 interface status is unregistered...



How about the incoming call to MGCP gateway? what do i need to configure in CUCM so that incoming call can be accepted?




Thanks.

Correct Answer
billybjo1 Mon, 02/15/2010 - 15:41
User Badges:

For the calls to be accepted, just make sure the CSS and Signficant digits are correct on the "Inbound Calls" settings on the E1 port config page. Also make sure the Device Pool & Location have the right settings.


If the E1 is unregistered, no calls will get through anyway. So you either have something incorrect in the config or the E1 has a problem (physical or Telco). A quick way of checking the E1 is just briefly temporarily set the gateway up as H323 which is independant of CUCM. If the line comes up and is functional, then you have something wrong in the MGCP config on CUCM. Some possible things to check:


IP Connectivity - Router<>CUCM should be able to communicate.

Gateway & Domain Name - Must match router exactly (very common mistake).

Module and Subunits - Make sure they match the hardware installed.

PRI Protocol Type/Protocol Side - Make sure they match the Telco specification.

Enable Status Poll - If ticked, make sure you have the channels set in Service Params Advanced.


Obviously there are many other settings, but those are often the ones that might prevent an E1 registering properly.


"

triandi_sugiharto Fri, 02/19/2010 - 18:11
User Badges:

Hi billybjo1,




Thanks for your advice. There is a problem with the E1 cable.

It is ok now, the E1 interface status is registered to CUCM.




Thanks.

William Bell Mon, 02/15/2010 - 16:25
User Badges:
  • Purple, 4500 points or more

If the gateway isn't registered, call won't be accepted by the system.  In addition to the global commands to configure the MGCP application you will need to configure the E1 controller so it associates its channel group to the MGCP application.  For example:


e1 controller 1/0

pri-group timeslots service mgcp


You also need to establish the backhaul communications and bind the ISDN Layer 3 to CCM manager:


interface serial 1/0:15

bind-l3 ccm-manager


To troubleshoot:


1. show mgcp endpoint


This command will list out the endpoints.  You will want to make sure that you confirm that the endpoint names reported by the gateway are the same as what you have configured in CUCM.  The most command issue is where the gateway is using the FQDN (i.e. @gateway.mycompany.com) and the CUCM is configured to just use the hostname (i.e. @gateway), or visa versa.


2. show isdn status


Check the ISDN status


3. show ccm-manager

Confirm that you are registered to a CUCM cluster node


4. show ccm-manager backhaul

Confirm your backhaul channel to the CUCM is healthy.


Hope that helps.


Regards,
Bill

Actions

This Discussion

Related Content