NATing an Xbox 360 (port forward)

Unanswered Question
Feb 14th, 2010
User Badges:

I am trying to setup my NAT for 1 Xbox 360, so when Port 3074 (UDP) is requested on my WAN IP, it will direct traffic to my Xbox 360 on UDP 3074. So basically a port forward, WAN_IP:3074UDP >> 10.10.0.51:3074UDP

This is on a 2600 series router.


xbox 360 network config:

ip address: 10.10.0.51 (static)

default gateway: 10.10.0.1


cisco ios config:

int fa0/0

ip address dhcp   <<<COMCAST CABLE

ip nat outside

no shutdown


int fa0/1

ip address 10.10.0.1 255.255.255.0   <<< LAN GATEWAY

ip nat inside

no shutdown


ip nat inside source list 1 interface FastEthernet0/0 overload  << this works fine, my internal devices all translate to my WAN address

access-list 1 permit 10.10.0.1 0.0.0.254


ip nat inside source static udp inside_local_ip 3074 inside_global_ip 3074


^^^ This is where I am running into trouble, from what I understand I set the local ip as 10.10.0.51, and the global IP would be my outside IP on fa0/0. However since I use DHCP on fa0/0 I don't want to manually enter the IP every time it changes.


Anyone able to shed some light on the best way to go about this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Jon Marshall Sun, 02/14/2010 - 09:48
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Steven


ip nat inside source static udp inside_local_ip 3074 interface fa0/0 3074


Jon

Steven Tolzmann Sun, 02/14/2010 - 12:12
User Badges:

xxxxx(config)#ip nat inside source static 10.10.0.51 3074 interface fa0/0 3074
                                                                                                        ^
% Invalid input detected at '^' marker.


It won't accept an interface

Jon Marshall Sun, 02/14/2010 - 12:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

sptmaster wrote:


xxxxx(config)#ip nat inside source static 10.10.0.51 3074 interface fa0/0 3074
                                                                                                        ^
% Invalid input detected at '^' marker.


It won't accept an interface


Steven


You missed out the "udp" bit in the statement. Could you retry with that.


If it still doesn't work which IOS are you running ? I tested with 12.4 and it worked fine.


Jon

Steven Tolzmann Sun, 02/14/2010 - 12:27
User Badges:

Woops, think i copy pasted it wrong, still didn't work though.


xxxxxxx(config)#ip nat inside source static udp 10.10.0.51 3074 interface fa0/0 3074
                                                                                                                     ^
% Invalid input detected at '^' marker.



IOS:

Version 12.2(34a)


rest of sh ver:


cisco 2621 (MPC860) processor (revision 0x600) with 61440K/4096K bytes of memory.
Processor board ID JAD053206UV (3398476904)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
2 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Reza Sharifi Sun, 02/14/2010 - 12:38
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Steven,


I tried this on 2611 router running IOS 12.2-24a and it works fine


C4#config t
Enter configuration commands, one per line.  End with CNTL/Z.
C4(config)#ip nat inside source static udp 10.10.0.51 3074 interface ethernet 0/0 3074
C4(config)#


What do you see if you do? after interface?


HTH

Reza

Steven Tolzmann Sun, 02/14/2010 - 12:45
User Badges:

I just get an error message after the command with the ^ pointing at the interface argument.


I think a possibility why this might not be working is I'm doing it on packet tracer (has same IOS as my real router though), since I'm getting my configs tested before i load them onto my real router. Although this would be rather odd since I've never had any problems with the packet tracer IOS for testing things out.


I'm going to bust out my serial cable and trial/error on the real thing I guess, I'll post again in a couple days if I don't make any progress.


Thanks for help everyone.

Actions

This Discussion