Qos on cisco 3550

Unanswered Question
Feb 15th, 2010

Hi all,

I am trying to limit the bandwidth to 10 mbps for one of my customer on 3550 switch.My configuration as follows but its not working.

mls qos

ip access-list extended upload
permit ip any any

class-map match-all INPUT
  match access-group name upload

policy-map POLICY_INPUT
  class INPUT
    police 10240000 1920000 exceed-action drop

interface fastEthernet0/5
service-policy input POLICY_INPUT

1. Queueing strategy is still in  fifo

2. HMG-2ndL3#sh mls qos interface fastEthernet 0/5
Attached policy-map for Ingress: POLICY_INPUT
trust state: not trusted
trust mode: not trusted
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
trust device: none

3. HMG-2ndL3#sh policy-map interface fa0/5     (packets are not hitting)


  service-policy input: POLICY_INPUT

    class-map: INPUT (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      match: access-group name DTDCqm_police_inform_feature: CLASS_SHOW

    class-map: class-default (match-any)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      match: any
        0 packets, 0 bytes
        30 second rate 0 bps


Hariharan k

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kevin Dorrell Mon, 02/15/2010 - 00:58

Could you do a show class-map INPUT please?

Your sh policy-map interface fa0/5 shows the access-group as "DTDC", not "upload" as I would have expected.

Kevin Dorrell


k.hariharan1 Mon, 02/15/2010 - 01:07


below is my orginal configuration in 3550. In my previous post i just manipulated the name of class-map and policiy map.

mls qos

ip access-list extended DTDC
permit ip any any

class-map match-all DTDC-INPUT
  match access-group name DTDC

policy-map POLICY_DTDC
  class DTDC-INPUT
    police 10240000 1920000 exceed-action drop

interface fastEthernet0/5
service-policy input POLICY_DTDC

HMG-2ndL3#sh class-map DTDC-INPUT
Class Map match-all DTDC-INPUT (id 1)
   Match access-group name DTDC

Kevin Dorrell Mon, 02/15/2010 - 01:17

OK, that explains the discrepency.

So the next question must be .. (... and I'm sorry it looks like a dumb question ...) ... is Fa0/5 actually up, and is there any traffic actually passing through it?

Kevin Dorrell


k.hariharan1 Mon, 02/15/2010 - 01:21

HMG-2ndL3#sh int fa0/5
FastEthernet0/5 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0012.7fab.1980 (bia 0012.7fab.1980)
  Description: DTCT - Jeet fiber
  Internet address is 203.196.144.x/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 3/255, rxload 6/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:04, output 00:00:02, output hang never
  Last clearing of "show interface" counters 2w2d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  30 second input rate 2562000 bits/sec, 570 packets/sec
  30 second output rate 1234000 bits/sec, 337 packets/sec


Hariharan k

k.hariharan1 Mon, 02/15/2010 - 02:41

can anyone help me to configure the bandwidth limt in 3550 switch in interface level , like how we will do it in cisco routers

by using rate-limit command.


Hariharan k

francisco_1 Mon, 02/15/2010 - 03:31

On Cat switch for example on the  Interface Configuration Mode on the switch port, you could apply the srr-queue bandwidth limit command. Here’s an example:

Switch(config)# interface FastEthernet 0/1
Switch(config-if)# srr-queue bandwidth limit 90

The 90 sets the outbound bandwidth limit on the port to 90 percent of the port speed. Since this is a 100-Mb port, this should limit the outbound traffic from the port to 10 Mb

Another example is  on a Cisco router when in Interface Mode, you could limit outbound bandwidth to 1 Mb using the following command:

Router(config-if)# rate-limit output 10000000 2000 2000 conform-action continue exceed-action drop
k.hariharan1 Mon, 02/15/2010 - 03:55


first thanks for your reply

rate-limit output is for the download traffic

rate-limit input is for upload traffic in serial interface

i am trying to do the bandwidth limit for my customer upload traffic.

cisco 3550 (input rate)<---------fiber link ---------->(output rate) customer device

also i check in my 3550 fastethernet interface there is no  command like

srr-queue bandwidth 
that might be due to my IOS

HMG-2ndL3(config-if)#srr-queue ?
% Unrecognized command

Is there any other alternative way to do this.


Hariharan k

Nicholas Poole Wed, 05/19/2010 - 03:30

you need to apply a policy-map which polices the traffic to the rate that you want and then apply it via the service-policy command on an interface


This Discussion

Related Content