DFM Error after Upgrade from LMS 3.1 to LMS 3.2

Unanswered Question
Feb 15th, 2010
User Badges:

Hi Cisco Community,


I have a big problem with the LMS  Application Device Fault Manager 3.2.0 after an Upgrade from LMS 3.1 to LMS 3.2

The LMS upgrade finished without error.


The Alerts and Activities Diplay encountered an error with the following message:


"An exception occured.Please check the AAD.log file for further details"


You find the "pdshow"  and "netstat" output and also the AAD.log, DeviceManagent.log, EPM.log, brstart.log and TISServer.log attached to this message


Everything else works fine.


A Cisco Daemon Manager restart doesn't fix this problem.


Any ideas to fix this problem?


Thanks for your help.


Best regards


Stephan B.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 02/15/2010 - 17:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It looks like you started Daemon Manager around 0900 local time.  The errors in the AAD.log are from 0912, so you may not have given Daemon Manager enough time to properly start all daemons.  I recommend users wait at least 30 minutes for all daemons to properly initialize.


So, if you try once again to access AAD, does the same error occur?  If so, repost the AAD.log, the pdshow output, and the DFMOGSServer.log.

stephan.brunst Thu, 05/06/2010 - 06:01
User Badges:

Hi,


sorry for the delayed response.


I waited a long time on the Device Fault Manager but the errors from AAD remains.


Now this a new installation from Windows server 2003 R2 in english with all current windows patches and the CWLMS version 3.2

The problem is the same.


I tried a local upgrade from CWLMS 3.1 to 3.2 and a remote upgrade with CWLMS 3.2

The problem is always the same.


I opened a TAC Case on last friday but the TAC can be found no solution at this time.


You can find the requested log files from the current installation attached to this message.


Thank you for your help in advance.

Joe Clarke Thu, 05/06/2010 - 22:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of the command:


NMSROOT/objects/smarts/bin/brcontrol

stephan.brunst Fri, 05/07/2010 - 03:01
User Badges:

The output of the command "brcontrol" was:


Error attaching to broker: S25B2005:9002!


I found a workaround for this error message at the release notes for the Cisco Unified Operations Manager.


The workaround is:


1.) net stop crmdmgtd


2.) Wait 15 minutes


3.) net start crmdmgtd


After completion of this workaround, I got the following output:


Broker is located at: S25B2005:9002      Started: May 07 11:08:47 2010


Domain Host Name         Port     PID State   Last Change Time
------ --------------- ------ ------- ------- --------------------
DFM    S25B2005.drv.bb  21900   18060 RUNNING May 07 11:08:55 2010
DFM1   S25B2005.drv.bb  21903   13988 RUNNING May 07 11:08:55 2010


You find this outputs attached to this message.


Unfortunately the errors in the DFM application are the same as before.


Also I get some error messages in the "Polling and Threshold" menu.

You find this error message attached to this message.



I already execute the following steps from the Cisco TAC to solve this problem.....without success.


Stop Daemons >>> net stop crmdmgtd from CLI.

Open windows explorer and go to \CSCOpx\databases\dfmFh. Delete dfmFh.log.

Go to \CSCOpx\databases\dfmFh>  from CLI and run:

dbsrv10.exe -f dfmFh.db from CLI.

Similarly open windows explorer and go to \CSCOpx\databases\dfmEpm. Delete dfmEpm.log.

dbsrv10.exe -f dfmEpm.db from CLI.

Similarly open windows explorer and go to \CSCOpx\databases\dfmInv. Delete dfmInv.log.

dbsrv10.exe -f dfmInv.db from CLI.

Note : Please check a screen will pop up each time you execute these commands.

Then, Start daemons >>> net start crmdmgtd from CLI.

Joe Clarke Fri, 05/07/2010 - 21:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Verify that S25B2005.drv.bb resolves.  Post the output of the following DOS command:


nslookup S25B2005.drv.bb

Actions

This Discussion