Problems with dial-peer

Unanswered Question

I'm having a problem with a dial peer link between two sites.  The short explanation is that when I dial the dial-peer it rings on the other side, but when the recipient picks up, it's just dead air.  Additionally, the caller does not hear the ringing tone while it's physically ringing on the other side.

Cisco 2801s on both sides with IOS 12.4(25b) on both.

My config for the dial-peer:

Site 1:

voice-port 0/0/0
timeouts call-disconnect 0
timing guard-out 1000
!

!

dial-peer voice 11 pots
destination-pattern 11
port 0/0/0
!
dial-peer voice 21 voip
destination-pattern 21
session target ipv4:192.168.11.1
dtmf-relay cisco-rtp

Site 2:

voice-port 0/0/0
  timeouts call-disconnect 0
!

mgcp behavior g729-variants static-pt

!
!
dial-peer voice 21 pots
  destination-pattern 21
  port 0/0/0
!
dial-peer voice 11 voip
  destination-pattern 11
  session target ipv4:192.168.1.254

Now, I've confirmed that this configuration used to work just like it is.  I've tried adding codecs (8000 bps to match the IP phone system) and everything else but I either get a busy signal or the same dead-air result.

Details of the network:

(site 1) IP phone > Shoretel phone system > 2801: analog port 0/0/0 > Cisco ASA > VPN (internet) > (site 2) 2801: analog port 0/0/0 > plain'ol analog phone

I've enabled debugging on both routers and watched the exchange when I make the call and it appears to be working.  I mean there's nothing to indicate that something is awry.

Any suggestions would be greatly appreciated.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Daniele Visaggio Wed, 02/24/2010 - 08:52

To fix the absence of the ringback tone you have to put under your voip dial-peers these commands:

progress_ind setup enable 3
progress_ind alert enable 8

Try also to force the use of a specific codec under the voip dial-peers with the command:

codec g711alaw (or ulaw - as you wish)

Regards

I tried both suggestions to no avail :-/

Couple questions:

Is this the correct usage of "progress_ind"?

dial-peer voice 21 voip
destination-pattern 21
progress_ind setup enable 3
progress_ind alert enable 8
session target ipv4:192.168.11.1
dtmf-relay cisco-rtp

codec g711alaw (I also tried ulaw)

Do I need to somehow specify the codec on the receiving side as well?  Or does the transmitting side specify the codec to the receiver?

The phone system I'm calling from has the option of using the following codecs:  L16/8000, PCMU/8000, G722/8000 so I tried g729r8 which just gave me dead air and g729br8 gave me a busy signal.

I could post the console output from both sides if that would help.

Actions

This Discussion