LMS 3.2 - Syslog Collector won't subscribe

Answered Question
Feb 15th, 2010
User Badges:

Hi,


The Syslog Collector won't subscribe to itself as it states "Unable to resurrect connection to a subscriber". The syslog collector status GUI is blank with no collectors listed. I have tried subscribing to the hostname however it states it is not valid.


I have restarted daemons in an attempt to recover.

Also ran the syslogconf.pl script again. No luck.


SyslogConf.log

SyslogCollector.log

SyslogAnalyzerUI.log

Collector.properties are attached.

Correct Answer by Joe Clarke about 7 years 5 months ago

SyslogCollector is failing to startup because is cannot read /var/log/syslog_info.  Check to make sure that this file is readable by casuser.  Make sure that all the directories leading up to this file (/var and /var/log) have 0755 permissions.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Mon, 02/15/2010 - 21:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

SyslogCollector is failing to startup because is cannot read /var/log/syslog_info.  Check to make sure that this file is readable by casuser.  Make sure that all the directories leading up to this file (/var and /var/log) have 0755 permissions.

eidumsigfrid Mon, 02/15/2010 - 21:30
User Badges:

Awesome. Thanks mate. Fixed.

I thought I checked that already but must have overlooked.


This was working fine in the past I suspect logrot.pl is defaulting the syslog_info file to owner of root. Is there anyway to retain ownership of the file to casuser for syslog_info ?

Joe Clarke Mon, 02/15/2010 - 21:37
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Logrot.pl will not change ownership of the file because logrot doesn't change the inode (it truncates the file in place).  If you're using logadm, on the other hand, it can change the inode unless you run it with the -c option.

mylacapanzana Wed, 07/14/2010 - 21:25
User Badges:

Hi,


How do I check that the file is readable by casuser and that all the directories leading up to this file (/var and /var/log) have 0755 permissions? How do I set 0755 permission? Sorry for my ignorance.


Thanks

Actions

This Discussion

Related Content