Problem with Cisco Bars after Database Republish ("Could not find Cisco Unified database on this server")

Unanswered Question
Feb 16th, 2010
User Badges:

OS Version: 2000.4.3a
OS Service Release: 2000.4.5bSR21
OS Upgrade: 2000.4.5a
Bars Version: 4.0.15000
CUCM Version: 4.2(3)sr4b


During the upgrade process of our CUCM 4.2(3) to version CUCM 4.2(3)sr4b the database replication between our 2 servers (1x pub, 1x sub) failed. After fixing this via dbhelper tool (everthing´s green and smiling again) service seemed to be ok.


But now Cisco Bars does not work anymore. The backup process of the publisher fails with "Error=[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user '(null)'. Reason: Not associated with a trusted SQL-Server connection." So it looks like some kind of database setting for bars  is misconfigured after the republishing process.


Yesterday I tried to reinstall BARS (now in the newest version 4.0.150000), but the same error message occured. Now I get the message "Could not find Cisco Unified database on this server" when I try to configure the Backup source within BARS.


Curiously the backup of our second CCM (sub) works as expected (but without CDR and TFTP Data). The "BackAdmin" User exists and is not locked (and wasn´t changed manually at all).


I am runnig out of ideas... :-(


Any hint or idea on how to fix this is kindly appreciated


best regards
Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
William Bell Tue, 02/16/2010 - 08:00
User Badges:
  • Purple, 4500 points or more

Mike,


I don't have anything definitive here but I am wondering if there is a discrepency between the database names.  In SQL Enterprise Manager, you can go to the Publisher and see what the current database name is.  It will be the one being replicated and will take the form of CCM0300 or CCM0301 or CCM0302.  You should see more than one.  Anyway, take note of the name.


Then on the Publisher launch regedit and go to HKLM\Software\Cisco Systems, Inc.\DBL\


Look at the values for DBConnection0 and DBConnection1.


It will be something like DSN=CiscoCallManager;Server=;DATABASE=;Trusted_Connection=yes


Does the in the DSN match what you expect?


Also, going to back to SQL Enterprise Manager, check out the permissions on the database (Right Click->Properties, go to Permissions tab).


Another thing to check if you think it is permissions related is the AdminUtility.exe (c:\program files\cisco\bin\).  This can be used to resync system account passwords.


TBH, I am just shooting in the dark here but these are things I would check.


Regards,
Bill

Michael Hamann Wed, 02/17/2010 - 00:07
User Badges:

Hi Bill,


thank you very much for your answer and your suggestions... I checked the permissions and settings you mentioned and they all look correct.DSN and DBConnection0 and DBConnection1 seem to be correct.


Yesterday afternoon I found a pretty old post on the cisco-voip mailing list which suggests to use the dns name instead of the ipaddress on the source server configuration page. So I tried this and - now comes magic - with DNS name instead of the ip adress it works as expected. Curiously I used the ip address for the last 3 years without a problem...


But anyway the backup is working again - will test a restore on a standby maschine the next days...


So for everyone with the same problem try using the dns name instead of the ip address when configuring the backup source server.


Thank you you again for your support

best regards

Michael

William Bell Wed, 02/17/2010 - 05:35
User Badges:
  • Purple, 4500 points or more

Michael,


Thanks for following up with the solution you found (+5).  You know I actually remember that issue now that you brought it up.  Good catch!


Regards,
Bill

Actions

This Discussion