Spanning Tree DHCP

Answered Question
Feb 16th, 2010

I think I'm posting in the right area since I believe its a spanning tree error. So I have a server 2003 dhcp server, the problem is it takes around 90 seconds for a client to get a dhcp address. Now from everything I read on google it's a spanning tree fastport problem. So I enabled spanning tree on all ports except the ones connected to another switch for I dont get a loop. This didn't solve the problem, and I came accross another post that said to disable spanning tree so I disabled spanning tree on all ports. Problem still not resolved, so I just erase startup-config to see if a default config would work still no go. I have two 2950 48 ports, 2960g 24 port and a linksys small business sge2000p 24 port switch (I think linksys switch is the porblem) Here is the config after I reset the switch

I have this problem too.
0 votes
Correct Answer by glen.grant about 6 years 9 months ago

  Yes the original post is incorrect .   On all "user ports "   use the interface range command to apply the following command , "switchport host" .   Then retry your test .  You have portfast turned off in your last post .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kevin Dorrell Tue, 02/16/2010 - 06:30

I would strongly advise you not to disable Spanning-Tree on any ports - it is there to protect your network from meltdown due to loops.

What you need is the command spanning-tree portfast on each of your client access ports.  This will bypass the slow startup of the access port (usually about 30 seconds), and will allow the DHCP request to get through at the first attempt.

If you still have the problem after that, post again and we can look deeper.

Kevin Dorrell

Luxembourg

CharlesMcLaine Tue, 02/16/2010 - 06:44

"What you need is the command spanning-tree portfast on each of your client access ports" Thats the first thing I did and had no luck with it. If I cant figure it out for by this weekend and I think I'll just try to get dhcp clients on a single switch and go switch by switch. When I erased the running config and reloaded the switches had no problems grabbing a dhcp address, IDK if that helps

Kevin Dorrell Tue, 02/16/2010 - 08:16

It sounds like it isn't anything to do with Spanning-Tree then.  Once you have portfast on the PC port, then Spanning Tree is no longer implicated.  In fact, if you have portfast, then the port does not even tell the Spanning Tree of the Topology change when you start the PC, so rebooting the PC does not touch the Spanning Tree any more.

I am presuming these are configured as access ports and not as trunks.  Perhaps you could post the config of a PC port, just in case there is something I have missed.

I presume also that the DHCP server is on the same VLAN as the PCs.  Can you confirm that?

Kevin Dorrell

Luxembourg

nqtran1979 Wed, 02/17/2010 - 09:38

Doesn't really sounds like a Spanning tree problem. Have you had a look at the DHCP server?

As all the guys above has mentioned, just set the port fast on all the access ports where your pc's connect to. And don't turn off spanning tree (i've read a few people suggest this on this forum ... why?).

Can you ping the DHCP server from your switch? ... how have you setup your pc's? are they configured with DHCP servers or are you setting ip helper-addresses on the switches?

Nhat

CharlesMcLaine Thu, 02/18/2010 - 10:17

"Doesn't really sounds like a Spanning tree problem. Have you had a look  at the DHCP server?"

I agree it dosnt sound like spanning tree, since this happens even when I renew ip address not just during boot, my understanding is spanning-tree fast port is when the amount of time til its linked but when I do a renew the light on the switch stays green dosnt go amber so it is staying linked but still slow.

I've looked into the DHCP server, I got a belkin 8 port switch plugged in the DHCP server and some client and they got address pretty much instenanise.(sp?)

Switches can ping dhcp server.

I also read this, http://www.macwindows.com/slow-dhcp-switch.html I have a couple macs on the network which are also slow to get dhcp address can this affect window based pc's?

I also read somehting about alot people have this problem with cisco 2960g switches can't find the article it was a couple days ago.

I think friday night I'll just have to go switch by switch to see where the problem lies.

I was looking at my 2960g web interface and it says 2 ports are trunked I'm guessing those 2 are the 2950 switches, but I also have a linksys switch plugged in there as well shouldnt it say trunked for the linksys switch as well?

Message was edited by: Charles McLaine

Jon Marshall Thu, 02/18/2010 - 13:43

Charles

If you have one vlan in the network is there a reason why you have trunk links because you don't need them ?

What is general network performance like ? Have you checked all the switch interconnect links to make sure there are no speed/duplex mismatches ?

Jon

CharlesMcLaine Thu, 02/18/2010 - 16:30

I think ita an auto detect feature on the switch. Thats what the web interface says and here is the config for the switch.

gigaswitch#show config

Using 1312 out of 65536 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname gigaswitch

!

!

no aaa new-model

system mtu routing 1998

ip subnet-zero

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface Vlan1

ip address 10.10.10.4 255.255.252.0

no ip route-cache

!

ip http server

snmp-server community public RW

!

control-plane

!

!

line con 0

line vty 0 4

password *********

login

line vty 5 15

login

!

end

Message was edited by: Charles McLaine

Jmorgan1413_2 Thu, 02/18/2010 - 16:42

As it sits now, everything is set to autonegotiate and Spanning tree is off on all your ports.  Is that because you

reverted to a default configuration?

I'd also look at the Windows box that DHCP is running on and make sure there are no Speed or Duplex mismatches.

I hate leaving any ports or NICs at auto negotiate.  It always seems to work better when everything is explicitly set for Speed and  Duplex and Portfast is on.

CharlesMcLaine Sat, 02/20/2010 - 04:38

So I unplugged the switches from each other and plugged in the DHCP server into one switch at a time and checked clients

2950 Worked FIne

Other 2950 Worked FIne

Linksys worked FIne

2960 ahhh here is the problem took like 2 min to give a dhcp address. I don't see a problem in the config, the running-config is in my previous post does anyone see a problem with it? Can it be just a bad switch?

Correct Answer
glen.grant Sat, 02/20/2010 - 05:03

  Yes the original post is incorrect .   On all "user ports "   use the interface range command to apply the following command , "switchport host" .   Then retry your test .  You have portfast turned off in your last post .

CharlesMcLaine Sat, 02/20/2010 - 05:56

That worked now my follow up questions are why did it work fine on the 2950's with out port fast? And my assumption with port fast is it has an affect when you startup a computer because it hasn't established a link, not when you say do a repair in XP? Thanks everyone for there help this is a great board.

Edit:

May of spoke prematurally, Here is a quick net setup I have all my other switches plugged into the the 2960g

Switch1 --> 2950

Switch2 --> 2950

Switch3 --> Linksys

Switch4 --> 2960g

So this fixed made dhcp faster for Switch 1,3,4 when they are all connected together. Switch 2 is still slow even though it worked fine when it was standalone. I enabled switchport host on all host ports but still didn't change the slowness of DHCP when it is plugged into the 2960g any tips? Thanks again

Actions

This Discussion