FXO/T38 Fax relay issue on a CCM-controlled MGCP gateway

Unanswered Question


I set up a Right fax server. Evry thing is working fine using a PRI link.

However, when I tried to configure FXO analog lines to accept and forward T38 faxes, I wasn't able to make things work. There is no fax tone heard when calling the analog line connected to an FXO installed on a CCM-controlled 2811 MGCP gateway.

I have added the following line to the gateway config :

no mgcp fax t38 inhibit

mgcp package-capability fxr-package

mgcp default-package fxr-package

I noted that the call succed to reach the fax server ( using the Fax Entreprise Manager ).

However thre is no fax tone detected and there is no successful fax transmission !

When I type show voice call summary during a fax call , I note

"T38" written in the CODEC column whereas it should the rate used (14400) and VSTP column contains S_CONNECT instead of S_FAX

The gateway end point and the RF gateway are also in the same Device Pool

Is there any suggestions to solve this ?

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
afmmanicke Tue, 02/16/2010 - 15:24

Here are a few snapshots from my VG224 and Cisco 2821.   Obvously I'm using FXS on the VG224...

voice service voip
fax protocol t38 ls-redundancy 2 hs-redundancy 0 fallback none

no ccm-manager fax protocol cisco

mgcp call-agent xxx.xxx.xxx.xxx 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp default-package fxr-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax rate 14400
mgcp rtp payload-type g726r16 static

Hope that gives some insite...


This Discussion