C3560 trunk configuration

Answered Question
Feb 17th, 2010

I want configure a port in a switch C3560 as trunking, with vlans 1 and 40 allowed and both tagging. I´ve have this configuration but I guess is not allowing comunication on vlan 40.

interface FastEthernet0/10
description testnewAP
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport trunk allowed vlan 1,40
switchport mode trunk
end
xxxxxx-new#sh int f0/10 switchport
Name: Fa0/10
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 11 (Usuarios)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1,40
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Juan Cruz.

I have this problem too.
0 votes
Correct Answer by Ganesh Hariharan about 6 years 11 months ago

Hi Juan,

Configuration for trunk is seems to be ok how you are checking that it is not working !!

Ganesh.H

Correct Answer by Jon Marshall about 6 years 11 months ago

adminedensa wrote:

I want configure a port in a switch C3560 as trunking, with vlans 1 and 40 allowed and both tagging. I´ve have this configuration but I guess is not allowing comunication on vlan 40.

interface FastEthernet0/10
description testnewAP
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport trunk allowed vlan 1,40
switchport mode trunk
end
xxxxxx-new#sh int f0/10 switchport
Name: Fa0/10

Trunking VLANs Enabled: 1,40

Juan Cruz.

Juan

Why do you think it is not allowing vlan 40 as the output above clearly shows it is ?

Have you configured the other end of the trunk link to allow the same vlans ?

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Jon Marshall Wed, 02/17/2010 - 09:15

adminedensa wrote:

I want configure a port in a switch C3560 as trunking, with vlans 1 and 40 allowed and both tagging. I´ve have this configuration but I guess is not allowing comunication on vlan 40.

interface FastEthernet0/10
description testnewAP
switchport trunk encapsulation dot1q
switchport trunk native vlan 11
switchport trunk allowed vlan 1,40
switchport mode trunk
end
xxxxxx-new#sh int f0/10 switchport
Name: Fa0/10

Trunking VLANs Enabled: 1,40

Juan Cruz.

Juan

Why do you think it is not allowing vlan 40 as the output above clearly shows it is ?

Have you configured the other end of the trunk link to allow the same vlans ?

Jon

Correct Answer
Ganesh Hariharan Wed, 02/17/2010 - 09:18

Hi Juan,

Configuration for trunk is seems to be ok how you are checking that it is not working !!

Ganesh.H

adminedensa Wed, 02/17/2010 - 09:34

In this port, I´m connecting an Access Point configured with 2 SSID in 2 different vlans.

In vlan 1 I´ve connectivity but in vlan 40 not.

I´ve tested this architecture in another site with another switch (3com) and it works fine.

I thought, it can be a configuration problem in the switch but with your opinion I´m discarding this possibility.

Thanks,

Juan Cruz.-

Ganesh Hariharan Wed, 02/17/2010 - 09:46

In this port, I´m connecting an Access Point configured with 2 SSID in 2 different vlans.

In vlan 1 I´ve connectivity but in vlan 40 not.

I´ve tested this architecture in another site with another switch (3com) and it works fine.

I thought, it can be a configuration problem in the switch but with your opinion I´m discarding this possibility.

Thanks,

Juan Cruz.-

Juan,

I think Cisco WLCs always connect to 802.1Q trunks, Cisco lightweight APs do not understand VLAN tagging and should only be connected to the access ports of the switch.

So for testing purpose just try the port with access port and then check it is working or not .

Hope to help

Ganesh.H

nqtran1979 Wed, 02/17/2010 - 09:48

Hi,

You should double check what vlans are running over the trunk with the "sh int fa0/10 trunk" command.

anyways, from what you've posted, it looks like yes the vlan 40 is allowed  BUT its been pruned:

Pruning VLANs Enabled: 2-1001

i would guess, vlan 40 doesn't exist on the other switch that connects to this trunk.

HTH

Nhat

adminedensa Wed, 02/17/2010 - 10:14

...but vtp is in transparent mode...

edenocbas01-new#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 13
VTP Operating Mode              : Transparent
VTP Domain Name                 : eden
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xCB 0xF2 0x8B 0xD9 0x3D 0x1F 0x83 0xA2
Configuration last modified by 10.100.251.1 at 0-0-00 00:00:00

Is the switch prunning vlan 40 in my port?

Juan Cruz.

Actions

This Discussion

Related Content