Mutual Redistribution

Unanswered Question
Feb 17th, 2010

Hi:

I have 3 routers...

R1--------R2-------R3

R1 runs OSPF

R2 runs OSPF and EIGRP

R3 runs EIGRP

R2 performs mutual redis....O into E and E into O

Question...

Will the E routes redistributed into O by R2 and adveretised to R1 be redistributed back into E by R2 and sent back to R3?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Kevin Dorrell Wed, 02/17/2010 - 10:59

No, because by that time they would (hypothetically) have an AD of 170, being external.  So the original routes at AD 90 would take preference.

In fact, as far as R2 is concerned, the EIGRP native routes would have precedence.

Kevin Dorrell

Luxembourg

lamav Wed, 02/17/2010 - 11:20

Thanks, Kevin:

OK, lets add something to the scenario.

Imagine that on top of the redis, I am also summarizing.

So, R3 (the E router) has 4 subnets of 192.168.3.0 hanging off of it.

R2 summarizes the E routes into a 192.168.3.0/25 and redistributes them into O as a type 5 LSA. Will R2 redistribute the summary back into E and will R3 receive it and place it in its routing table?

Thanks

Edison Ortiz Wed, 02/17/2010 - 11:53

R2 summarizes the E routes into a 192.168.3.0/25 and redistributes them into O as a type 5 LSA. Will R2 redistribute the summary back into E and will R3 receive it and place it in its routing table?

No, R3 will receive the summary from R2 as an internal EIGRP route.

In my lab, R1 is the ASBR instead of R2

R1 (ASBR):

interface FastEthernet0/1
description R3
ip address 192.168.13.1 255.255.255.0
ip summary-address eigrp 1 192.168.3.0 255.255.255.128 5

router eigrp 1
redistribute ospf 1 metric 1 1 1 1 1
network 192.168.13.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 1 subnets
network 192.168.12.1 0.0.0.0 area 0

R1#sh ip route ei
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
D       192.168.3.11/32
           [90/156160] via 192.168.13.3, 00:04:39, FastEthernet0/1
D       192.168.3.10/32
           [90/156160] via 192.168.13.3, 00:04:39, FastEthernet0/1
D       192.168.3.12/32
           [90/156160] via 192.168.13.3, 00:04:39, FastEthernet0/1
D       192.168.3.0/25 is a summary, 00:04:39, Null0

R2 (OSPF Router):

R2#sh ip route os
O E2 192.168.13.0/24 [110/20] via 192.168.12.1, 00:00:01, FastEthernet0/0
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
O E2    192.168.3.11/32 [110/20] via 192.168.12.1, 00:00:01, FastEthernet0/0
O E2    192.168.3.10/32 [110/20] via 192.168.12.1, 00:00:01, FastEthernet0/0
O E2    192.168.3.12/32 [110/20] via 192.168.12.1, 00:00:01, FastEthernet0/0
O E2    192.168.3.0/25 [110/20] via 192.168.12.1, 00:00:01, FastEthernet0/0

R3 (EIGRP Router):

R3#sh ip route ei
D EX 192.168.12.0/24
           [170/2560002816] via 192.168.13.1, 00:00:26, FastEthernet0/1
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
D       192.168.3.0/25 [90/158720] via 192.168.13.1, 00:01:26, FastEthernet0/1

lamav Wed, 02/17/2010 - 14:08

Hi, Edison:

Im not sure you understood me. I am not summarizing routes and advertising them to the E router...

I am summarizing E routes at the OSPF ASBR (point of mutual redis) and I am advertising that summary address of the E subnets into the OSPF domain.So, I am doing E into O AND summarizing the E routes into the O domain.

Thanks

Edison Ortiz Wed, 02/17/2010 - 15:50

Ok, I saved the previous lab so I could do the recreate real quick.

The summary-address gets advertised back into R3 as external EIGRP:

R1 (ASBR):

router eigrp 1
redistribute ospf 1 metric 1 1 1 1 1
network 192.168.13.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
summary-address 192.168.3.0 255.255.255.128
redistribute eigrp 1 subnets
network 192.168.12.1 0.0.0.0 area 0

R1#sh ip route ei
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
D       192.168.3.10/32
           [90/156160] via 192.168.13.3, 00:01:58, FastEthernet0/1
D       192.168.3.30/32
           [90/156160] via 192.168.13.3, 00:01:58, FastEthernet0/1
D       192.168.3.20/32
           [90/156160] via 192.168.13.3, 00:01:58, FastEthernet0/1
R1#sh ip route os
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
O       192.168.3.0/25 is a summary, 00:02:00, Null0
R1#

R2 (OSPF):

R2#sh ip route os
O E2 192.168.13.0/24 [110/20] via 192.168.12.1, 00:03:18, FastEthernet0/0
     192.168.3.0/25 is subnetted, 1 subnets
O E2    192.168.3.0 [110/20] via 192.168.12.1, 00:02:19, FastEthernet0/0
R2#

R3 (EIGRP):

R3#sh ip route eig
D EX 192.168.12.0/24
           [170/2560002816] via 192.168.13.1, 00:01:27, FastEthernet0/1
     192.168.3.0/24 is variably subnetted, 4 subnets, 2 masks
D EX    192.168.3.0/25
           [170/2560002816] via 192.168.13.1, 00:00:22, FastEthernet0/1
R3#

lamav Wed, 02/17/2010 - 18:20

Right....this is what I assumed would happen.

Drilling a little deeper, I imagine that what is happening is that R2 is the culprit. R2 is configured to advertise a summary address into OSPF, so it creates an external LSA, advertises it to the OSPF router, and finally adds a null0 route to its own routing table for that summary as a loop prevention mechanism.

Two observations/comments:

1.) I would think that the redistribution mechanism of R2 would have had the built-in intelligence to not redistribute its own summary route back into the domain from which it emanated.

2.) In the absence of summarization, I am wondering if the same behavior will be exhibited for each individual E subnet redistributed into O.

So, if an individual E subnet of 192.168.3.4/30 is redistributed into O WITHOUT summarization, then that route should be redistributed back into E by R2, as it did for the summary route. So, in the EIGRP topology table of the E router (R3 in my lab), an entry for 192.168.3.4/30 should be present with a next hop pointing to R2. Correct?

This EIGRP route would be an external E route with an AD of 170, so it will only be placed in R3's route table if R3's primary route to the 192.168.3.4/30 subnet has an AD of 170 and a higher EIGRP metric than what gets advertised back to it by R2. Correct?

Thanks

Victor

Edison Ortiz Thu, 02/18/2010 - 14:08

lamav wrote:

Edison?

Bueller? Bueller? Bueller?

.. But you are holding my feet on the fire to respond to you right away?

lamav Thu, 02/18/2010 - 16:49

Senor Ortiz, I would never hold your feet to the fire...maybe your head, but never your feet. lol

Edison Ortiz Thu, 02/18/2010 - 14:06

1.) I would think that the redistribution mechanism of R2 would have had the built-in intelligence to not redistribute its own summary route back into the domain from which it emanated.

It is redistributing what's on the RIB. Per my output, the RIB has a OSPF summary route on the ASBR and the redistribution is calling for all OSPF routes to enter the EIGRP domain. If you want to block a subnet, there is an option to use a route-map.

2.) In the absence of summarization, I am wondering if the same behavior will be exhibited for each individual E subnet redistributed into O.

No, because those subnets aren't shown in the RIB as OSPF subnets. They are shown as EIGRP subnets.

Performing 'show ip route eigrp' and 'show ip route ospf' on the ASBR will provide all the answers you are looking for.

lamav Thu, 02/18/2010 - 16:52

You totally lost me with your answer to the second question...

I agree with you. I would have loved to set this up in my lab, but it is temporarily being held hostage by an angry girlfriend...lol...

But more than that, I like to bounce ideas off of seasoned intelligent individuals...but since you're the only one available, I asked you...LOLOL

Thanks, papi chulo

Edison Ortiz Wed, 02/17/2010 - 15:34

I did exactly as you said. I even quoted what you said to make sure you didn't change it afterwards.

R2 summarizes the E routes into a 192.168.3.0/25 and redistributes them
into O

You should've said, redistribute them into OSPF and the perform a summary-range within the OSPF process - can't read mind - ya know.

lamav Wed, 02/17/2010 - 18:24

Edison, easy papi....

Its no big deal; its not like Im holding your feet to the fire for misunderstanding me...

But since you mention it, I said "R2 summarizes the E routes into a 192.168.3.0/25 and redistributes them into O as a type 5 LSA."

So, its clear that the OSPF router is the recipient of the summary address of the E routes being generated by R2.

Anyway, no biggie...

Actions

This Discussion