Basic Multicast

Unanswered Question
Feb 18th, 2010
User Badges:

I have a Cisco 2811.


fa 0/0 is on 192.168.1.1

fa 0/1 is on 192.168.2.1


My VLC server is on 192.168.1.4 multicasting on 238.255.12.42


My VLC reciever is on 192.168.2.5.


I cannot get multicast working


Can any one advise me on the config please.


I have enable ip multicast routing in global mode.


Thanks in advance.


Martin.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Thu, 02/18/2010 - 08:08
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

martinbuffleo wrote:


I have a Cisco 2811.


fa 0/0 is on 192.168.1.1

fa 0/1 is on 192.168.2.1


My VLC server is on 192.168.1.4 multicasting on 238.255.12.42


My VLC reciever is on 192.168.2.5.


I cannot get multicast working


Can any one advise me on the config please.


I have enable ip multicast routing in global mode.


Thanks in advance.


Martin.


Martin


1) check that you have set the TTL in VLC to > 1


2) under each interface -


   int fa0/0

   ip pim dense-mode


   int fa0/1

   ip pim dense-mode



If that works you may want to switch to use pim sparse-mode but first lets see if the above works.


Jon

martinbuffleo Thu, 02/18/2010 - 08:20
User Badges:

Have added the

ip pim sparse-mode


Also tried dense mode with no joy


command to both interfaces still no joy


I'll read the guide you linked to.



Jon Marshall Thu, 02/18/2010 - 08:23
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

martinbuffleo wrote:


Have added the

ip pim sparse-mode


command to both interfaces still no joy


I'll read the guide you linked to.





deleted - a bit fast off the mark


Could you post -


1) "sh ip mroute"

2) "sh ip igmp groups"


also did you check the TTL setting in VLC ?


Jon

martinbuffleo Thu, 02/18/2010 - 08:35
User Badges:

Thanks for your help on this Jon


VLC TTL is set to 30.


Router#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 00:01:59/00:02:02, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Dense, 00:01:59/00:01:58
    FastEthernet0/0, Forward/Dense, 00:01:59/00:00:00

(*, 238.255.12.42), 00:01:55/00:01:59, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Dense, 00:01:56/00:01:58
    FastEthernet0/0, Forward/Dense, 00:01:56/00:00:00

(*, 239.255.12.44), 00:01:59/00:02:57, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Dense, 00:01:59/00:02:03
    FastEthernet0/0, Forward/Dense, 00:01:59/00:00:00

(*, 224.0.1.40), 01:04:28/00:02:55, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Dense, 01:04:28/00:00:00

Router#show ip igmp groups
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
239.255.255.250  FastEthernet0/1          01:04:27  00:02:50  192.168.1.5
239.255.255.250  FastEthernet0/0          01:04:36  00:02:51  192.168.2.4
238.255.12.42    FastEthernet0/0          00:52:00  00:02:53  192.168.2.4
238.255.12.42    FastEthernet0/1          00:52:40  00:02:52  192.168.1.5
239.255.12.44    FastEthernet0/0          01:02:04  00:02:47  192.168.2.4
239.255.12.44    FastEthernet0/1          01:04:28  00:02:54  192.168.1.5
224.0.1.40       FastEthernet0/0          01:04:36  00:02:47  192.168.2.1
Router#
Router#show run
Building configuration...

Current configuration : 1224 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/0
logging message-counter syslog
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
!
ip multicast-routing
no ipv6 cef
multilink bundle-name authenticated
!
voice-card 0
!
archive
log config
  hidekeys
!

interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip pim dense-mode
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
!

control-plane
!

voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
gatekeeper
shutdown
!
line con 0
line aux 0
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Jon Marshall Thu, 02/18/2010 - 11:38
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Martin


How are you determining it is not working - have you started up the vlc app on the client machine and tried to connect to the multicast stream ?


Jon

Edison Ortiz Thu, 02/18/2010 - 12:45
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

From the mroute output, I don't see the source listed in the table (S,G) and from the IGMP output you have 2 receivers that joined that group


238.255.12.42    FastEthernet0/0          00:52:00  00:02:53  192.168.2.4
238.255.12.42    FastEthernet0/1          00:52:40  00:02:52  192.168.1.5


Can you verify the server is actually sending packets toward the router?


What type of switch is the source attached to?


Can you verify pinging both ways?

martinbuffleo Fri, 02/19/2010 - 00:58
User Badges:

I am testing it by run VLC client on the reciever.


I'm also running VLC client on the sender to confirm that VLC sender is running correctly.


Ping connectivity between the two laptop is good.



VLC sender(192.168.1.5) -------------- 2811-------------------VLC receiver(192.168.2.4)

                                       CAT5                CAT5



No other hardware involved.

Edison Ortiz Fri, 02/19/2010 - 06:08
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I'm not familiar with VLC but if you are running the 'client app' not the 'server app' - you won't see any (S,G) in the mroute output.


You need to run a server application somewhere so clients can receive the stream.

martinbuffleo Fri, 02/19/2010 - 06:11
User Badges:

It's the same up.


But one is sent to send the multicast stream and one is set to receive.



Do you have any scripts I can use to test. Rather than rely on Multicast?

Lei Tian Fri, 02/19/2010 - 06:27
User Badges:
  • Cisco Employee,

Some VLC version has problem on the TTL setting; have to modify the setting to make it work. The one I know working fine is "VLC media player 0.8.6i", download that version and test it.


HTH,


Lei Tian

francisco_1 Fri, 02/19/2010 - 06:56
User Badges:
  • Gold, 750 points or more

Martin,

I have tried your config in a lab to prove to your config is fine.

A single router with multiple interfaces

R1
eth0/0 1.1.1.1 - Sender behind this interface 1.1.1.2
eth0/1 2.2.2.1 - Receiver behind this interface 2.2.2.2

Used MulticastUDP App to test it. Used low TTL



Config
########

ip cef
!
!
ip multicast-routing!

interface Ethernet0/0
ip address 1.1.1.1 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0/1
ip address 2.2.2.1 255.255.255.0
ip pim sparse-dense-mode





Results - Multicast Address is 239.1.1.10
######

R1#sh ip mroute 239.1.1.10

(*, 239.1.1.10), 00:00:12/stopped, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/1, Forward/Sparse-Dense, 00:00:08/00:00:00

(1.1.1.2, 239.1.1.10), 00:00:12/00:02:47, flags: T
  Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/1, Forward/Sparse-Dense, 00:00:08/00:00:00



R1#
R1#sh ip igmp groups 239.1.1.10
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
239.1.1.10       Ethernet0/1              00:00:37  00:02:51  2.2.2.2
R1#

martinbuffleo Fri, 02/19/2010 - 07:24
User Badges:

Stream received across a single router.


Thanks for the heads up on the issue with VLC. Bloody ****,**** F&*! of rubbish


Edison Ortiz Fri, 02/19/2010 - 07:06
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Thanks Francisco,


This is what we are looking for


(1.1.1.2, 239.1.1.10), 00:00:12/00:02:47, flags: T


S,G - that's the server sending to the mcast group. The OP is missing the S,G

Actions

This Discussion