Flash upgrade on UC520

Unanswered Question
Feb 18th, 2010
User Badges:

I have a UC520 which I use for demo and lab purposes.  The new 8.0 code is 250MB zipped, and I only have 128MB of flash space.  Has anyone upgraded the flash in their UC520?  Is it as easy as a regular ISR?


Re,
Bob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hornstein Thu, 02/18/2010 - 20:28
User Badges:
  • Gold, 750 points or more

Hi Bob


Personally, i think it's a very easy machine to upgrade.

Cisco Configuration Assistant (CCA) 2.2.1 or better  takes care of  deleting old files, creating directory structure and dumping files in the appropriate directory..

You hopefully can,  sit back and relax  whilst CCA completes the upgrade.  That's the theory.


The ZIP file contains software for  both upgrading Call Manager express (CME)  and Cisco unity express (CUE).

What you don't see  is another flash card inside the UC520 to store software for CUE.


Also the zip contains just about every driver for just about every phone at Cisco, do you need every driver for every phone in flash....nope.


So part of the upgrade process that was incorporated into CCA version 2.2.1 was the ability to add or delete phones loads...see the picture below.


With this option, i end up with about 60 Meg of free Compact Flash.


So,  select the ZIP file as the source of  the upgrade, tick the option of  auto disk cleanup to clean out the Compact flash card and  select your phone loads, if it's not selected already.  Rememeber to click upgrade again..you'll figure it out.


Next step is grab a cup of coffee, if you drink coffee, and wait up to about 50 minutes for the upgrade to hopefully complete successfully..


Give it a go, with CCA 2.2.1 or better  is a real easy process.


Bob,  there is great search capabilities at this community site, this question has been answered in a variety of ways before ;).  Check out the this site, there is a lot of 'how to" video's and  "How to" documents at this community site.


regards Dave


111.JPG

Bob Bagheri Fri, 02/19/2010 - 05:06
User Badges:

Thanks Dave, I'll give it another try today.  Ironically, I didn't see the options to pick the individual phone loads, that part of the screen stayed blank.



The install fails because of another ftp/tftp service running.  I ran netstat and made sure no other applications were listening on these ports.  Then, I disabled my software firewall and all extra NIC's on my laptop.  After the upgrade failed, I thought it might be the flash capacity.


I'll let you know how the 3rd attempt goes today.


Thanks for you help.


Bob

Steven DiStefano Fri, 02/19/2010 - 07:42
User Badges:
  • Blue, 1500 points or more

Bob,

Yes, there was/is a bug with the PLM not popping open with anything to select and yes, that will cause a TFTP server error (because all the phone loads wont fit on a UC520;on a UC540/UC560, they all will fit).   Also keep in mind PLM only supports directory structured FLASH (which CCA creates if you chack that box during an upgrade (auto clean up flash)).


The issue was if CCA found any phones without the 'type'

CSCte30084 - During software upgrade phone loads are not shown


Workaround can be done with CCA....

You basically are adding the phone type as shown in CLI below:



You can launch CCA and go to Telephony-->Voice and in the  User extensions tab you can provide the phone type and it might ask you to  provide extra information as well.




Ex:
ephone  1
device-security-mode none
mac-address  001B.53FF.30A3
button  1:11
Please addthis to the above
type 7975 (or any valid phone type)

Steve


jmbonsack Fri, 02/19/2010 - 08:52
User Badges:

I added all the types on my ephone entries, and still get a blank phone load screen which leads to the tftp error described above.  I do have one ephone entry with no type, but that shouldn't have one:


ephone  11
device-security-mode none


However, does this trigger the bug?  Short of figuring out how to get a bigger flash configured for the UC520, I'm stuck!


-mark

Bob Bagheri Fri, 02/19/2010 - 13:05
User Badges:

Steve,


My UC520 is running "The Office" demo and already has the phone types listed.


I guess its back to more research or wait for CCA2.2 to be released.


Re,
Bob

jmbonsack Wed, 03/10/2010 - 12:21
User Badges:

Not for me.  I still get a blank PLM screen when attempting to use CCA to upgrade to 8.0.0.   I also get the "Removing settings for phones firmware not in flash and saving configuration" popup each time I run CCA.  In fact, the whole thing still feels like 2.2.1 except for the about screen saying it's 2.2.2...


-mark

Steven DiStefano Wed, 03/10/2010 - 14:05
User Badges:
  • Blue, 1500 points or more

Heavens to Murgatroy (said best by Snagglepuss)!


I was feeling good about this.  I upgraded 5 different UC520s and it poped open each time......


Can you open a case on this with SBSC and we will have them collect your config to see what may be gumming this up?


Steve

Steven DiStefano Wed, 03/10/2010 - 14:12
User Badges:
  • Blue, 1500 points or more

Marc,

The SBSC will need the CCA application log and running config of the device, so please collect that ASAP.

Thanks for your help.

Steven DiStefano Thu, 03/11/2010 - 11:40
User Badges:
  • Blue, 1500 points or more

I can get you resolution on this if you post your config and application log (remove passwords please from show run).

Steven DiStefano Tue, 03/30/2010 - 07:27
User Badges:
  • Blue, 1500 points or more

OK, Problem solved by the Partner.   Mark reports that he rebuilt the zip file to remove some phone loads since he knew they wouldnt all fit on flash on his UC520, as it has only 128M IOS flash card.    He made a small mistake which didnt indluce the phone loads in the proper place in the zip and CCA couldnt read it, hence showed no phone loads.


He reported using 8-0-2 and worked like it should as well.


Case closed.  Phone Load Manager Works!!!



Steve

Actions

This Discussion

Related Content