OSPF:I can get neighbor OK, but I don't see ospf routes

Answered Question
Feb 19th, 2010
User Badges:

Hi,  this is a lab exercise on OSPF.

If I do 'show ip ospf neig' on the respective routers involved, I do see neighbors OK for all routers involved. However, if I do 'show ip route ospf' I see very limited number of routes learned by OSPF.


For example, on router Rack26R2 I was expecting to see over 10 OSPF routes. I see only one.

On Rack26R1 and I see no OSPF routes, although neighbor info is OK.


I checked my OSPF advertisements on all routers involved and I could not locate any problem there.

Please find attached show run from routers #1 - 6 involved and also a diagram.


Thanks for your help on this.

Correct Answer by Edison Ortiz about 7 years 1 month ago

OK, so the lesson learned here is that on the NBMA I will always need to make sure that my hub router (R5) is the DR.


That's what I said 2 posts ago


Make sure to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Fri, 02/19/2010 - 11:10
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You are missing the broadcast keyword in your frame-relay map commands.


On R1 for instance:


interface Serial0/0
ip address 155.26.0.1 255.255.255.0
encapsulation frame-relay
ip ospf 1 area 0
frame-relay map ip 155.26.0.2 105
frame-relay map ip 155.26.0.3 105
frame-relay map ip 155.26.0.4 105
frame-relay map ip 155.26.0.5 105
no frame-relay inverse-arp


Should be:


interface Serial0/0
ip address 155.26.0.1 255.255.255.0
encapsulation frame-relay
ip ospf 1 area 0
frame-relay map ip 155.26.0.2 105
frame-relay map ip 155.26.0.3 105
frame-relay map ip 155.26.0.4 105
frame-relay map ip 155.26.0.5 105 broadcast
no frame-relay inverse-arp


Only one broadcast is needed per DLCI on this case towards the hub. Do the same on the rest.

news2010a Fri, 02/19/2010 - 11:30
User Badges:

I did as you recommended from Router #1 - 4. Behavior is the same. Any ideas?

!
interface Serial0/0
ip address 155.26.0.2 255.255.255.0
encapsulation frame-relay
ip ospf 1 area 0
frame-relay map ip 155.26.0.1 205
frame-relay map ip 155.26.0.3 205
frame-relay map ip 155.26.0.4 205
frame-relay map ip 155.26.0.5 205 broadcast
no frame-relay inverse-arp
!
interface Serial0/1
ip address 155.26.23.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!

Rack26R2#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.5.5        1   FULL/DR         00:01:51    155.26.0.5      Serial0/0
192.10.26.254     1   FULL/DR         00:00:30    192.10.26.254   FastEthernet0/0
Rack26R2#show ip route ospf
     51.0.0.0/32 is subnetted, 1 subnets
O E2    51.51.51.51 [110/20] via 192.10.26.254, 01:26:17, FastEthernet0/0 <== I should  see over 10 routes via OSPF.
Rack26R2#

Edison Ortiz Fri, 02/19/2010 - 11:55
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Did you add the broadcast keyword on R5 for every single DLCI?


Let's see the 'show ip ospf neighbor' from all routers.


You have to make sure R5 is the DR for all routers on that frame-relay hub-and-spoke or you can use point-to-multipoint.

news2010a Fri, 02/19/2010 - 12:07
User Badges:

I did it now. Unfortunately no improvement.


Rack26R5#show run int s0/0/0
Building configuration...

Current configuration : 319 bytes
!
interface Serial0/0/0
ip address 155.26.0.5 255.255.255.0
encapsulation frame-relay
ip ospf 1 area 0
frame-relay map ip 155.26.0.1 501 broadcast
frame-relay map ip 155.26.0.2 502 broadcast
frame-relay map ip 155.26.0.3 503 broadcast
frame-relay map ip 155.26.0.4 504 broadcast
no frame-relay inverse-arp
end

Rack26R5#show ip int ospf ?
% Unrecognized command
Rack26R5#show int ospf brief
                  ^
% Invalid input detected at '^' marker.

Rack26R5#sh ip ospf int brief
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Se0/0/0      1     0               155.26.0.5/24      64    BDR   4/4
Fa0/1        1     3               155.26.5.5/24      1     DR    0/0
Fa0/0        1     3               155.26.58.5/24     1     DR    1/1
Rack26R5#
RSRack7AS>2
[Resuming connection 2 to R2 ... ]

Rack26R2#show ip route ospf
     51.0.0.0/32 is subnetted, 1 subnets
O E2    51.51.51.51 [110/20] via 192.10.26.254, 02:08:40, FastEthernet0/0
Rack26R2#

news2010a Fri, 02/19/2010 - 12:57
User Badges:

Update:Ding. Under the interface s0/0/0 on R4 (the one connecting to R5), I did 'ip ospf priority 0' and now R5 is a DR from R4 perspective. Then from there R2 is learning more OSPF routes now. OK, so the lesson learned here is that on the NBMA I will always need to make sure that my hub router (R5) is the DR.


==========================

I see that  for R4, R5 is a BDR, not a DR.



[Resuming connection 1 to R1 ... ]

Rack26R1#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.5.5        1   FULL/DR         00:01:56    155.26.0.5      Serial0/0
150.26.6.6        1   FULL/BDR        00:00:37    155.26.146.6    FastEthernet0/0
223.255.255.255   1   FULL/DR         00:00:34    155.26.146.4    FastEthernet0/0
Rack26R1#
RSRack7AS>2
[Resuming connection 2 to R2 ... ]

Rack26R2#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.5.5        1   FULL/DR         00:01:44    155.26.0.5      Serial0/0
192.10.26.254     1   FULL/DR         00:00:39    192.10.26.254   FastEthernet0/0
Rack26R2#
RSRack7AS>3
[Resuming connection 3 to R3 ... ]

Rack26R3#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.5.5        1   FULL/DR         00:01:33    155.26.0.5      Serial1/0
150.26.7.7        1   FULL/DR         00:00:34    155.26.37.7     FastEthernet0/0
Rack26R3#
RSRack7AS>4
[Resuming connection 4 to R4 ... ]

Rack26R4#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.5.5        1   FULL/BDR        00:01:48    155.26.0.5      Serial0/0/0
150.26.1.1        1   FULL/DROTHER    00:00:38    155.26.146.1    FastEthernet0/1
150.26.6.6        1   FULL/BDR        00:00:31    155.26.146.6    FastEthernet0/1
Rack26R4#
RSRack7AS>5
[Resuming connection 5 to R5 ... ]

Rack26R5#
RSRack7AS>show ip ospf neig
                 ^
% Invalid input detected at '^' marker.

RSRack7AS>5
[Resuming connection 5 to R5 ... ]

Rack26R5#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.1.1        1   FULL/DROTHER    00:01:37    155.26.0.1      Serial0/0/0
150.26.2.2        1   FULL/DROTHER    00:01:37    155.26.0.2      Serial0/0/0
150.26.3.3        1   FULL/DROTHER    00:01:54    155.26.0.3      Serial0/0/0
223.255.255.255   1   FULL/DR         00:01:39    155.26.0.4      Serial0/0/0
150.26.8.8        1   FULL/BDR        00:00:31    155.26.58.8     FastEthernet0/0
Rack26R5#
RSRack7AS>6
[Resuming connection 6 to R6 ... ]

Rack26R6#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.1.1        1   FULL/DROTHER    00:00:30    155.26.146.1    FastEthernet0/0.146
223.255.255.255   1   FULL/DR         00:00:37    155.26.146.4    FastEthernet0/0.146
150.26.7.7        1   FULL/BDR        00:00:35    155.26.67.7     FastEthernet0/0.67
Rack26R6#
RSRack7AS>7
[Resuming connection 7 to SW1 ... ]

Rack26SW1#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.3.3        1   FULL/BDR        00:00:36    155.26.37.3     FastEthernet0/3
150.26.9.9        1   FULL/DR         00:00:37    155.26.79.9     Vlan79
150.26.6.6        1   FULL/DR         00:00:36    155.26.67.6     Vlan67
Rack26SW1#
RSRack7AS>8
[Resuming connection 8 to SW2 ... ]

Rack26SW2#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
223.255.255.255   1   FULL/DR         00:00:31    155.26.108.10   Port-channel1
150.26.5.5        1   FULL/DR         00:00:37    155.26.58.5     Vlan58
Rack26SW2#
RSRack7AS>9
[Resuming connection 9 to SW3 ... ]

Rack26SW3#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.7.7        1   FULL/BDR        00:00:37    155.26.79.7     Vlan79
Rack26SW3#
RSRack7AS>10
[Resuming connection 10 to SW4 ... ]

Rack26SW4#show ip ospf neifg
                          ^
% Invalid input detected at '^' marker.

Rack26SW4#show ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
150.26.8.8        1   FULL/BDR        00:00:33    155.26.108.8    Port-channel1
Rack26SW4#

Correct Answer
Edison Ortiz Fri, 02/19/2010 - 13:59
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

OK, so the lesson learned here is that on the NBMA I will always need to make sure that my hub router (R5) is the DR.


That's what I said 2 posts ago


Make sure to rate helpful posts.

Actions

This Discussion