7912 IP PLUS QOS

Unanswered Question
Feb 19th, 2010

Hi Pros,

             We have a remote site with a bunch of  7912 and one 7940, as it is a remote site. We only have one cable drop at each cubicle, so the PCs are connected via the biuld in switch of the 7912. Every now and then, customer keep complainding about voice breaks up. There is the default switch port set up for the phone. We have 2 different vlans, one vlan for the phone and one vlan for data. My question is when the PC connected to the phone is doing some web streaming won't this affect the phone? How the phones will set qos for the calls?

1. Current config

interface FastEthernet0/2
switchport mode trunk
switchport voice vlan 2
spanning-tree portfast
!

2. Config will be changed to ( the fix)

interface FastEthernet0/2
switchport mode access
switchport voice vlan 2
mls qos trust cos
spanning-tree portfast
!

Any ideas will be greatly appreciate.

Jean Paul.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hailey Fri, 02/19/2010 - 21:44

Questions for you before I can really provide much aside from mere speculation:

1) How much bandwidth does the remote site have>

2) What constitutes a "bunch" of phones - regarless of type?

3) Have you gathered call data for these complaints - i.e., are the callers on calls to cellular phones?

4) You have different options for trust vs. non-trust boundaries.  If you are using a data vs. voice VLAN to segregate traffic as you imply then what the PC is doing is insignificant to what the "phone" is doing in terms of call behavior as the traffic is logically separated between VLAN's.  However, if Phone A (remote site) is downloading tons of MP3's via the WAN and the user is also on a call traversing the same WAN link then yes, the overall bandwidth associated with the WAN link would be degraded.

If you can, provide a quick diagram (basic is fine) of your setup and details on switch platform(s) used and bandwidth available to each site.  Additionally, traffic profiling during complaints is critical info as well - i.e., IP to Cellular via PSTN - too many variables there to go into quickly here but IP to PSTN via WAN or IP to IP via WAN is a different story.

William Bell Sat, 02/20/2010 - 07:06

Jean Paul,

In regards to your question on how the phone will operate and handle network traffic from the attached PC.  Generically speaking, you can think of the IP phone as a 3-port switch with a limited address table.   The three ports are:

1. The PC connection:  Which has a physical interface on the back of the phone

2. The phone connection:  This is an internal "interface"

3. The network or switch connection:  This is the interface that connects to the network switch

Connection #3 is essentially a trunk to the network switch.  Which means that if you were to look at traffic between the phone and the switch (i.e. traversing connection #3) you would find that traffic from the phone (connection #2) and the PC (connection #1) are clearly marked so that the network switch knows what's what.

The phone itself will give priority to traffic coming from connection #2 versus traffic coming from connection #1.  So, you don't have to worry about that.  What you do have to manage is what happens when the packets leave the phone and enter your network.

Remember QoS is only good if you apply it throughout the entire network.  Let's start with the switch port commands you are trying to use.  You can configure the switch port to "trust" as you are trying to do.  Trust basically tells the port to accept the QoS values that the sending device has specified.  Without the "trust" command the port (by default) will remark all QoS values down to 0 or "Best Effort".  Clearly, this is not what you want to do in a voice environment.  There are other ways outside of port level qos trust commands to actually mark QoS but that is a deep, deep topic. So, let's stick with trust.

So, you can tell a port to trust "cos" (Class of Service), "ip-precedence" (IP Precedence), or dscp (Differentiated Services Code Point).  I won't go into all of the differences here.  We will stick with your preference of trusting cos.

A likely config could be:

interface FastEthernet0/2

  switchport mode access

  switchport access vlan 10

  swtichport voice vlan 2

  spanning-tree portfast

  mls qos trust cos

  mls qos trust device cisco-phone

So, what do we know about this particular port?

1. It is an access port and we are enabling portfast

2. The data VLAN is 10.  This is the vlan that the PC attached to the phone (Connection #1) will use

3. The voice VLAN is 2.  This is the vlan that the Phone connection (Connection #2) will use

4. The switch port will trust COS values.  For the phone the signaling (i.e. SCCP) will have COS 3 and the media (i.e. RTP) will have COS 5

5. We also tell the port to only apply this trust to the traffic coming from the phone (Connection #2).  This is key because you don't want the OS or application on the PC to specify a COS that doesn't fit into your overall design.

With this configuration once the packets from the PC/Phone enter the switch port the Phone traffic is marked for preferential treatment while the PC traffic is marked for best effort.  Unfortunately, your job is not complete because that traffic is going to traverse your network.  It will pass through one or more devices on its way to the final destination and you need to ensure that every network device that is handling the packets/frames will preserve your QoS settings.  You also need to ensure that network devices have proper configurations in place to enforce your traffic QoS settings.  This is a deep topic.  If you are unfamiliar with QoS then I suggest that you consider looking at a few documents and do some research.  Your platform really dictates how you implement QoS.

Start with this document.  It is beefy, but it is one of the best Cisco SRNDs I have read:

http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/QoS-SRND-Book.html

If you aren't comfortable with QoS then you may want to look into using auto-qos for devices that support it.  Basically, auto-qos is a batch command you can run on devices that automatically configures your ports for not only trusting but for queuing and scheduling.  This is key.  Since I don't know what platforms you are using, here is an example on how to configure auto-qos.  Each platform is different, so make sure that if you plan to use auto-qos that you use the configuration guide for the platform and version that applies:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_46_se/configuration/guide/swqos.html#wp1231112

HTH.

Regards,

Bill

Please remember to rate helpful posts.

Jean Paul Enerst Sat, 02/20/2010 - 09:22

Thank you guys. There is more details. The phones are connected to a basic 2950 switch and this switch is connected to a 2801 router. The WAN link is wireless satellite Link where the remote can burst up to a t1 bandwidth. The provider modem at the remote(DCE) has rsvp of 100K set for 4 concurrent calls(25k each call); however, the remote has 5 IP phones plus  2 IP faxes.

One thing that I haven't ingestigate yet is whether the voice breaks up start whenever there is more than 4 for calls.

Thanks,

Jean Paul

Actions

This Discussion