CUCiMOC LDAP disconnected issue

Unanswered Question
Feb 21st, 2010

Hi,


I am doong a new deployment for a customer with CCM7.1.3-2000-2, OCSR2 client. Everything works okay, except that CUCiMOC keeps showing LDAP disconnected. I can login, use deskphone and softphone but it wont bind to LDAP.


I used wireshark to trace ldap bind request and response and I can see a successful ldap bind request, but when CUCiMOC attempts to do a search in the search base it returns 0 results.  This search base is the same used for CCM ldap directory configuration and users were succesfully imported into CCM.


Under server health exceptions, There is no indication of any error..Still LDAP remain disconnected. I have tried on boith windows vista and windows 7.


Any ideas please??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
htluo Sun, 02/21/2010 - 15:09

Did you populate the registry correctly?  If you used .adm file to push group policy, the .adm file Cisco provided didn't have all values populated.


If you look at the Wirshark, you'll notice that the search filter was incorrect.  For example, you'll see a filter "=johndoe" (while the correct one should be "sAMaccountID=johndoe".


I would recommend you open the .bat file Cisco provided and modify your .adm file.


Michael

http://htluo.blogspot.com

Ayodeji Okanlawon Mon, 02/22/2010 - 05:55

Michael,


Thanks a lot. Yes you are right, the .adm file is what I used. Before pushing the policy to all users,I did make relevant changes to the .adm file including the LDAP_AttributeName_userAccountNmae=sAMAccountName However I didnt set 2  particular attribrutes:


LDAP_AttributeName_objectclassValue=objectclass

LDAP_AttributeName_objectclassKey=person.


After making these changes, it worked. Many thanks.

Actions

This Discussion