Dial Back up Config Assistance

Unanswered Question
Feb 21st, 2010
User Badges:

I'm in need of a little assistance in configuring an Async interface on a Cisco 1811 router. My customer has a requirement to have two pop numbers in case the first one answers, no problem. The issue I've run into is this - each pop number takes a separate set of credentials, from what I can see, only one set of credentials can be configured on the interface. Both sets will use PAP authentication.


Here is the config I have for the interface. 819-454-6638 must one use one set, the 1-800 number must use a second set. Any assistance would be appreciated.


interface Async1
description DIAL BACKUP INTERFACE
ip address negotiated
ip access-group EXTERNAL-INTERNET-IN in
ip access-group EXTERNAL-INTERNET-OUT out
no ip unreachables
ip nat outside
ip inspect FW_Inspect out
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
ip tcp header-compression
ip tcp adjust-mss 1300
dialer in-band
dialer idle-timeout 300
dialer wait-for-carrier-time 10
dialer string 819-454-6638

dialer string 1-800-670-7489
dialer-group 2
async mode dedicated
no peer default ip address
ppp pap sent-username username-popA password 7 username-popA
ppp timeout idle 300
crypto ipsec client ezvpn backup_profile
end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 02/22/2010 - 00:17
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jpecarski,


you need an extra level of abstraction:


interface async1 is your physical interface.

You should use two dialer interfaces that can use the resource Async1


int Async1

no ip address

dialer pool-member 1

enc ppp


int dialer 1

dial pool 1

! all parameters of first POP here


int dialer 2

dial pool 1

! all parameters of second POP here


ip route 0.0.0.0 0.0.0.0 dialer1 100

ip route 0.0.0.0 0.0.0.0 dialer 2 110



Hope to help

Giuseppe

jpecarski Mon, 02/22/2010 - 05:28
User Badges:

Thanks for the reply.


One question.... with two dialers, how will the router know to dial the 2nd dialer if the first dialer fails? Is it simply by the routing table or do I need to specify a failover interface for the 1st dialer?

Giuseppe Larosa Tue, 02/23/2010 - 09:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jpercaski,

this is a good note, because dialer interfaces may be spoofed up.


A possible help may come from reliable routing with object tracking


see


http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html


the idea is to track first default route so that it is removed from IP table if the tracked object/ IP SLA fails


Hope to help

Giuseppe

Actions

This Discussion