SIP Invalid Host Error

Unanswered Question
Feb 22nd, 2010

Dear All,

I am getting a SIP invalid host on sip calls coming in to the UC540

This config normally works however in this instance it is not.It is the IP address from my ADSL router outside intewrface in the invites instead of the internal IP address.

000587: Feb 22 09:14:58.217: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
ACK sip:[email protected]:58275 SIP/2.0 ----> should be (the uc500) instead of outside IP
Via: SIP/2.0/UDP;branch=z9hG4bK61a70ed6;rport
From: "08454130833" <sip:[email protected]>;tag=as7bc34c9b
To: <sip:[email protected]:58275>;tag=2488024-130D  ---> This should be (the UC500) instead of outside IP
Contact: <sip:[email protected]>
Call-ID: [email protected]
CSeq: 102 ACK
User-Agent: VoiceFlex
Max-Forwards: 70
Content-Length: 0

Can anyone shed some light?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vcappucc Mon, 02/22/2010 - 01:42

Hello Robert,

I had a similar case the other day and the solution was to bridge the ADSL Modem and let the UC500 get the Public IP via PPPoE, since the Modem that we where working on, did not support SIP-ALG.

Please find a link where a Cisco SR500 provided asymmetric digital subscriber line (ADSL) or FastEthernet WAN termination and advanced security features for a Cisco Smart Business Communications System (SBCS) network,  as an example on how to configure this via CCA.

Hope this help as a reference point


Maulik Shah Mon, 02/22/2010 - 17:25

The UC500 by default will only accept SIP responses that are addressed to its own IP address (any of the interfaces) - not any other IP address. Hence you see the error message. Victor is correct - this is an issue with the NAT ALG on your ADSL modem that does not correctly replace the IP addresses in the SIP message. You are better off putting the modem in bridge mode and letting the UC500 get a public IP (make sure you do not disable the firewall on the UC500).

One potential option to try via CLI (this may not work) is to add the below CLI:

UC520#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC520(config-sip-ua)#permit hostname

This may or may not work as the CLI is usually for a domain name not an IP address but give it a shot.

ROBERT THOMPSON Fri, 02/26/2010 - 10:08


I replaced the Cisco 857 with a Cisco SR520-ADSL-K9 and it worked

Thanks for the help

Kind regards


I'm having the same issue with a ASA in front of the UC5x0, there are known SIP issues that were suppose to be fixed in the version we have but I assume they are not. The issue is the ASA SIP proxy is not translating the address inbound.

I tried the permit host dns:public NAT's IP but no luck.

I have a case open with TAC, but that's not working too well.



This Discussion