High utlization problem in 6509 with s72033_rp-ADVENTERPRISEK9_WAN-VM version12.2

Answered Question

Dear all

i am getting the high cpu utilization in my 6509 with the  s72033_rp-ADVENTERPRISEK9_WAN-VM version 12.2

i have checked for the broadcast not much of them are there.

it keeps hovering around 65% belo is the output of the show process cpu.

CPU utilization for five seconds: 58%/22%; one minute: 64%; five minutes: 67%
PID       5Sec    1Min     5Min Process
1         0.0%    0.2%     0.3% kernel
3         0.0%    0.0%     0.0% devc-pty
4         0.0%    0.0%     0.0% devc-mistral.proc
5         0.0%    0.0%     0.0% pipe
4102      0.0%    0.0%     0.0% dumper.proc
4103      0.0%    0.0%     0.0% pcmcia_driver.proc
4104      0.0%    0.0%     0.0% bflash_driver.proc
12297     0.0%    0.0%     0.0% mqueue
12298     0.0%    0.0%     0.0% flashfs_hes.proc
12299     0.0%    0.0%     0.0% dfs_bootdisk.proc
12300     0.0%    0.0%     0.0% ldcache.proc
12301     0.0%    0.0%     0.0% watchdog.proc
12302     0.0%    0.0%     0.0% syslogd.proc
12303     0.0%    0.0%     0.0% name_svr.proc
12304     0.0%    0.0%     0.0% wdsysmon.proc
12305     0.0%    0.0%     0.0% sysmgr.proc
16386     0.0%    0.0%     0.0% chkptd.proc
16402     0.0%    0.0%     0.0% sysmgr.proc
16403     0.0%    0.0%     0.0% syslog_dev.proc
16404     0.0%    0.0%     0.0% itrace_exec.proc
16405     0.0%    0.0%     0.0% packet.proc
16406     0.0%    0.0%     0.0% installer.proc
16407    29.0%   31.5%    33.3% ios-base
16408     0.0%    0.0%     0.0% fh_fd_rf.proc
16409     0.0%    0.0%     0.0% fh_fd_rpc.proc
16410     0.0%    0.0%     0.0% fh_fd_oir.proc
16411     0.0%    0.0%     0.0% fh_fd_env.proc
16412     0.0%    0.0%     0.0% fh_fd_cli.proc
16413     0.0%    0.0%     0.0% fh_metric_dir.proc
16414     0.0%    0.0%     0.0% fh_fd_test.proc
16415     0.0%    0.0%     0.0% fh_fd_snmp.proc
16416     0.0%    0.0%     0.0% fh_fd_none.proc
16417     0.0%    0.0%     0.0% fh_fd_intf.proc
16418     0.0%    0.0%     0.0% fh_fd_gold.proc
16419     0.0%    0.0%     0.0% fh_fd_track.proc
16420     0.0%    0.0%     0.0% fh_fd_timer.proc
16421     0.0%    0.0%     0.0% fh_fd_ioswd.proc
16422     0.0%    0.0%     0.0% fh_fd_counter.proc
16423     0.0%    0.0%     0.0% fh_server.proc
16424     0.0%    0.0%     0.0% fh_policy_dir.proc
16425     0.0%    0.0%     0.0% call_home.proc
16426     0.0%    0.0%     0.0% ipfs_daemon.proc
16427     0.0%    0.0%     0.0% fh_fd_config.proc
16428     0.1%    0.0%     0.0% raw_ip.proc
16429     0.0%    0.0%     0.0% inetd.proc
16430    30.7%   33.0%    33.8% tcp.proc
16431     0.2%    0.2%     0.2% udp.proc
16432     1.1%    1.1%     1.1% iprouting.iosproc
16433     0.4%    0.4%     0.4% cdp2.iosproc

Wainting for you responses

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 9 months ago

Hello Mohit,

high cpu on ios-base process or tcp.proc has been reported for C6500 using modular IOS this should be caused by some bug or on the way modular IOS is used on your system (installation or not)

see

https://supportforums.cisco.com/message/632330#632330

if you look for high cpu on modular IOS in the forums you can find some threads

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
KARUPPUCHAMY MA... Mon, 02/22/2010 - 01:38

Hi,

are you running any VPN tunnels in this switch.because only two process is taking too much cpu(ios.base and tcp.proc)

can you paste the output of the below commans

#sh mod

Thanks & Regards

Karuppu

HI,

I am not runing any VPN tunnels through this..

please find the requireed output

UWL-DR-IT-COR-SW1#show mod
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  1    8  CEF720 8 port 10GE with DFC            WS-X6708-10GE      SAL1334X23K
  2    8  CEF720 8 port 10GE with DFC            WS-X6708-10GE      SAL1334X21X
  3   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX     SAL1334WQ5A
  4   48  CEF720 48 port 1000mb SFP              WS-X6748-SFP       SAL1332VWQ0
  5    2  Supervisor Engine 720 (Active)         WS-SUP720-3B       SAL1334WRG5
  6    2  Supervisor Engine 720 (Hot)            WS-SUP720-3B       SAL1333WB1Z

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  1  0025.84f0.abb0 to 0025.84f0.abb7   2.1   12.2(18r)S1  12.2(33)SXI1 Ok
  2  0025.84f0.ac00 to 0025.84f0.ac07   2.1   12.2(18r)S1  12.2(33)SXI1 Ok
  3  0026.cb0b.d2e0 to 0026.cb0b.d30f   3.2   12.2(18r)S1  12.2(33)SXI1 Ok
  4  0023.eb73.4f44 to 0023.eb73.4f73   2.2   12.2(18r)S1  12.2(33)SXI1 Ok
  5  0024.1499.6544 to 0024.1499.6547   5.9   8.5(3)       12.2(33)SXI1 Ok
  6  0024.1499.6230 to 0024.1499.6233   5.9   8.5(3)       12.2(33)SXI1 Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  1  Distributed Forwarding Card WS-F6700-DFC3C     SAL1334X32Q  1.4    Ok
  2  Distributed Forwarding Card WS-F6700-DFC3C     SAL1334X33F  1.4    Ok
  3  Distributed Forwarding Card WS-F6700-DFC3B     SAL1334WW9Q  4.8    Ok
  4  Centralized Forwarding Card WS-F6700-CFC       SAL1334WYLF  4.1    Ok
  5  Policy Feature Card 3       WS-F6K-PFC3B       SAL1333WNGE  2.6    Ok
  5  MSFC3 Daughterboard         WS-SUP720          SAL1333WEGQ  4.0    Ok
  6  Policy Feature Card 3       WS-F6K-PFC3B       SAL1334WT7E  2.6    Ok
  6  MSFC3 Daughterboard         WS-SUP720          SAL1334WUNT  4.0    Ok

Mod  Online Diag Status
---- -------------------
  1  Pass
  2  Pass
  3  Pass
  4  Pass
  5  Pass
  6  Pass

However in the mean while i was looking around this forum only for the sollution waht i found some one saying it can be because of the hung tcp sesions i have found some seseion in the time wait sesion that is with my tacas server. however i thik this is normal becasue when i seeing the output of the same command in the another switch same kind of tcp sesions are coming and utilization of that switch is normal only

Thanks for your response.....

Correct Answer
Giuseppe Larosa Mon, 02/22/2010 - 03:26

Hello Mohit,

high cpu on ios-base process or tcp.proc has been reported for C6500 using modular IOS this should be caused by some bug or on the way modular IOS is used on your system (installation or not)

see

https://supportforums.cisco.com/message/632330#632330

if you look for high cpu on modular IOS in the forums you can find some threads

Hope to help

Giuseppe

Actions

This Discussion