Outside calls to AA forwards to CUE, but DTMF tones do not work after reaching the CUE

Unanswered Question
Feb 22nd, 2010

Calls from outside cannot press “0” in a users voicemail and get to the AA. When I call the AA from an inside extension and got to  someone's Voicemail, ie: 214 the call transfers and I can "0" out to the AA. I have all the voicemail set to forward back to the AA when zero is pressed. It works from inside, but not from outside. Callers also can't retrieve voicemail by calling the AA from outside. The cue does not hear the dtmf tones. I have employees with voicemail setup to call a separate number which goes directly to the voicemail retrieval system. I had an open TAC support case some months ago, but no solution was working and I put it on the back burner for awhile. Now I need to solve this issue.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Mon, 02/22/2010 - 11:26

What version of CUE are you running?  What type of trunk is this, SIP, PRI, FXO?  What version of IOS are you running as well?  Would you mind posting your config?

Barry Hunsinger Tue, 02/23/2010 - 06:59

I’ve attached the configs for the uc520 and the SR520. The uc520 sits behind a SR520. All calls are SIP from NexVortex.com. The problem as I have learned is that incoming calls from SIP are getting to the AA and DTMF tones work, when a call is transferred to the CUE (such as a voice mailbox) the CUE launches another call leg via a private ipaddress and loses the inbound audio portion of the call, therefore it can’t hear the DTMF tones being sent.

Cisco Unity Express Version 7.0

Attachment: 
Steven Smith Tue, 02/23/2010 - 12:05

Could you get the following debugs?

debug ccsip messages

debug voip rtp session dtmf-relay

debug voip rtp session named-event

debug voip rtp session named-event 101

Could you get this for a good call (calls to AA where DTMF works) and for bad calls to?

Barry Hunsinger Tue, 02/23/2010 - 15:02

Here are the logs, hope they lead to something good. I made an outside call from 908-265-2006 to 908-753-0800 (sip) line and transferred to extension 225, when I was voicemail for 225 answered I pressed zero and it could not hear me. I then called inside from extension 225 to ext. 205 when voicemail answered i pressed zero and was transferred to the AA.

Message was edited by: barryhunsinger

Steven Smith Tue, 02/23/2010 - 15:54

The first part of the first call was cut off.  Can you do this again only for a bad call?

Barry Hunsinger Wed, 02/24/2010 - 06:40

I will do that ASAP. Are you sure it was cutoff or a hangup?  When you transfer an outside call from the AA to voicemail and then presss "0" it does not hear the tone so you have to hangup or leave a message...

Steven Smith Wed, 02/24/2010 - 07:37

Ok, lets try doing this outside of CCA.  The first part of the first call is still not in the logs.  I actually got less of it than the first time.

So, can you do the same scenario, but do it this way.

config t

no logging monitor

no logging console

logging buffered 7

logging buffered 2000000

exit

debug ccsip messages

debug voip rtp session dtmf-relay

debug voip rtp session named-event

debug voip rtp session named-event 101

clear logging

term len 0

undebug all

show logging

Attach that file.

Barry Hunsinger Wed, 02/24/2010 - 09:03

OK I did it the way you wanted. Just so you know the system is live and there were other calls coming in. Also the extension for the AA I was using is 300 and the voicemail extension is 200. I made the same call in the same way as last time with the same results. (isn't that the definition of insanity)

Attachment: 
Steven Smith Wed, 02/24/2010 - 10:09

Expecting a different result would be insanity.  Let me look at this and get back to you.

Barry Hunsinger Tue, 03/09/2010 - 15:51

Hi, have you looked at the logs? It's been awhile and i was hoping to have a solution.

JOHN NIKOLATOS Sat, 03/13/2010 - 18:41

I Had a similar issue when I had a stand alone UC500 using POTS AA worked fine... then I had expanded the system to a internet based site to site and each end would dial each other just by 3 digit extension and when using the dial-peer that would initiate the site to site....  Autoattendant would not accept DTMF buttons and if you dialed the AA would not "hear" the buttons...

Try this....  (change your DTMF-RELAY commands in all dial-peers that deal with your ISP and AA).

dial-peer voice 2001 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 498
b2bua
session protocol sipv2
session target ipv4:10.2.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad

IN CUE change this..

ccn subsystem sip
gateway address "10.2.10.2" (I changed this IP  for my install - dont change IP - just the dtmf-relay commands)
dtmf-relay rtp-nte
end subsystem

Tell me if this helps.

Actions

This Discussion