Intermittent keypad operation during calls on 7936 connected to UC520

Answered Question
Feb 23rd, 2010

Seems to work sometimes with no problem at all. I have tried a different 7936, but has the same effect. Keypad always works fine for dialing numbers to make calls, but fails to work during calls when requested for number entry. Could it be the network connection, the PoE box or the UC520 config?

I have this problem too.
0 votes
Correct Answer by Marcos Hernandez about 6 years 8 months ago

What is the Smartport role setting on the UC500?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
kevin0neill Tue, 02/23/2010 - 08:47

Seems to be more reliable now since manually changing the network setting to 10Mps half duplex. Will there be any other issues running at this setting or can I put the 7936 phone back in to service with the users?

kevin0neill Sun, 02/28/2010 - 15:34

All ports are currently "IP Phone + Desktop". I will try "IP Phone" only.on Tuesday when I'm next in the office. Thanks

kevin0neill Thu, 03/04/2010 - 07:46

There isn't an "IP Phone only" smartport setting. I tried setting the smartport role to "switch" but the 7936 then found an IP on the data vlan and still had the same fault. I have also tried the "none" role setting. This also pulls an IP from the data vlan, but the phone now seems to work. It has worked ocassionally before, so I'll try it again every couple of hours.

kevin0neill Thu, 03/04/2010 - 10:40

No. Still faulty. The keypad has stopped working again during calls. It seems odd that it is so intermittent. The 7936 has been changed once already. It's either the UC520 or the small PoE switch unit that comes with the 7936.

Marcos Hernandez Sat, 03/20/2010 - 07:33

That would be the latest :-(

Please open a TAC case if you haven't already done so.


Darren DeCroock Sat, 03/20/2010 - 08:00

You may be experiencing a known DTMF issue...  What version of software pack do you have loaded???

There is an issue with DTMF tones that has been fixed in software pack 8.0.1.   You may want to open a TAC case to confirm this is the problem you are experiencing before upgrading your UC520.

Thank you,


kevin0neill Sun, 03/21/2010 - 13:05

As it happens, it is only the 7936 that has a problem on my UC520. The last package install was rev 8. Is there a smaller upgrade I can do, rather than another whole package?

JOHN NIKOLATOS Sun, 03/21/2010 - 14:08

Are you sure you have a CAT5E cable or better for the Patch cord or cable in the walls?  It also sounds to me like you have a DTMF issue..  Is there a case where you can recreate this issue everytime?  Like when calling someone Voicemail?  Or when testing AA or something else?

IF you move the phone does the issue follow?  How about if you use a different model phone in the same location?

kevin0neill Mon, 03/22/2010 - 08:58

Is there a known DTMF issue with the 7936 running on a UC520? I am using the AA to reproduce the fault. I have direct connected the 7936 to the UC520 and it still has the fault. Occasionally the fault disappears, mostly after a phone reboot. For example, I have just downgraded the phone load to cmterm_7936.3-3-16-0.bin and the first few attempts to enter my ID followed by hash worked fine, then it all stopped working again. The only 2 pieces of kit I have not changed are the 7936 PoE adapter and the long screened network cable between the adapter and the station. I could try another cable between the adapter and the station, but it clearly states this voids the warranty. Any other suggestions anybody? Is there a known DTMF issue with the 7936 running on a UC520?

Marcos Hernandez Sun, 03/28/2010 - 08:11


At this point, please go ahead and file a case with TAC. I could not find an existing bug for this problem, so they will probably create one for you.




This Discussion

Related Content