Cisco ASA - IGMP Stub and multicast forwarding

Unanswered Question
Feb 23rd, 2010
User Badges:


I am trying to set up a configuration using an ASA 5510 ( V 8.2(1) ) in routing mode to

- act as an IGMP stub in one way

- transparently forward multicast stream in the other way

I used 2 commands (the "multicast-routing" is enabled)

- igmp forward interface (for the IGMP proxy)

- igmp static-group (to forward defined multicast streams) (by the way, it's a shame I cannot use the " igmp static-group * " command like on a C3750)

The following schematic will help you understand:


On my LAN, the user is subscribing to the remote Cam 2 multicast stream ( And on the same LAN, the Cam 1 is sending multicast stream ( that has to be transparently forwarded to the WAN for distant subscribers.

BUT, the thing is that I cannot use both commands at the same time. In this configuration, the ASA is blocking the Cam 1 stream. Only the incoming stream is forwarded to the LAN. If I disable the IGMP stub function, the Cam 1 stream is going through the firewall! It seems that the first command is suppressing the second command.

So I've found a solution (not THE solution): I use a double physical interface to the WAN from the ASA:


But this is a very "strange" solution...

So do you know why the two commands seems to be incompatible?

(I have one constraint: I cannot enable the PIM protocol on the ASA, It MUST transparently)

Thank you!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
kennethwebber Fri, 04/02/2010 - 07:16
User Badges:

I can see this is an old post but I was working with a similar issue with Cisco support. They had me put the static join on both LAN and WAN interfaces.

jacques_henry696 Wed, 04/07/2010 - 01:58
User Badges:

Thanks for the reply! I was thinking I was the only one in this situation.

I didn't think to put the command on both interfaces but I've found an alternative solution (with the mroute command if I remember correctly).


This Discussion