Problem with LACP layer 3 port-channel

Unanswered Question
Feb 23rd, 2010

Hi all:

I'm facing a problem with an layer 3 etherchannel with LACP. This is the scenario (real scenario):

Site A: Switch 3750 with 12.2(52)SE IPSERVICES IOS. It's a stack of 6 members, the ports for the port-channel are 6/0/25 and 1/0/49

Site B: VSS 6509 with Version 12.2(33)SXI2a ADVENTERPRISEK9 IOS. The ports are 1/1/36 and 2/1/36.

The port-channel on VSS is included on a VRF, see the config:

interface Port-channel44
no switchport
ip vrf forwarding users
ip address 10.2.254.57 255.255.255.248

And the config of one of the port(the other one is identical):

interface GigabitEthernet1/1/36
no switchport
no ip address

channel-protocol lacp
channel-group 44 mode active

The config on the 3750 (Site A) is almost identical (no VRF):

interface Port-channel44
no switchport
ip address 10.2.254.58 255.255.255.248

And the port configuration:

interface GigabitEthernet6/0/25
no switchport
no ip address

channel-protocol lacp
channel-group 44 mode passive

The problem is that on VSS side always appear the same error on log and I don't understand why:

%EC-SW1_SP-5-L3DONTBNDL2: Gi1/1/36 suspended: LACP currently not enabled on the remote port.
%EC-SW1_SP-5-L3DONTBNDL2: Gi2/1/36 suspended: LACP currently not enabled on the remote port.

The ports on VSS side remain on Suspended state, the port-channel is down/down and the physical ports in up/down state. On side A, the ports and port-channel are on down/down.

Thanks a lot,

Francisco

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 02/23/2010 - 12:35

Hello Francisco,

have you already tried to use mode active also on the C3750 stack side?

I think it could help, the VSS may be "too fast" in deciding no one is on the other side.

Also, if possible to test, if the bundle is placed in global routing table (no vrf) do you see any change?

Hope to help

Giuseppe

Francisco Del Cura Wed, 02/24/2010 - 00:23

Thanks for the reply Giuseppe.

Yes, I also configure active on both ports on 3750 switch, the same error. At the moment is very difficult place the bundle out of VRF, until then, any other idea?.

Thanks,

Francisco

Francisco Del Cura Wed, 02/24/2010 - 05:36

I just tested the scenario with another stack switches that are not on production and the LACP works properly. This new stack has the 12.2(25r)SEE4 ADVIPSERVICESK9-M IOS, maybe the IOS is the problem?.

I already checked out the IOS of the stack on production and it supports LACP.

Thanks,

Francisco

Giuseppe Larosa Wed, 02/24/2010 - 06:25

Hello Francisco,

if the other switch stack is seen as an LACP speaker on the same VSS, that would point to a problem on the first switch stack.

It is important to replicate the production scenario in all details including the VRF.

If you did so you probably have found the solution to your issue, and you just need to ask for a maintanance window to perfom the IOS upgrade on the production stack.

Hope to help

Giuseppe

Francisco Del Cura Thu, 02/25/2010 - 04:10

Hi:

I tried the scenario with the IOS used on production IPSERVICES and it also works properly . I don't understand why in the lab scenario it works and with the production one it didn't.

If someone knows what could be the problem I'd very grateful.

Regards,

Francisco

Actions

This Discussion