Inside hosts cannot ping external hosts

Answered Question
Feb 23rd, 2010
User Badges:

Hello,


I've configured an ASA5520 and setup a single host on the inside to test connectivity.  I can ping external/Internet addresses fine from the firewall (i.e. I can ping google from the firewall), however, I cannot ping external IPs from the host inside/behind the firewall.  I can ping the firewall fine from the host... so this looks to be a NAT issue.  You'll see in the config below that I've setup a static NAT for the internal host... so shouldn't that work?  As soon as I enabled 'nat-control' I was able to get out.  However, if I disable nat-control, I cannot.  Without enabling nat-control, what can I change in the config below?


ASA Version 7.0(8)
!
hostname fw1
enable password *********** encrypted
passwd ********** encrypted
names
dns-guard
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 172.16.10.252 255.255.255.128
!
interface GigabitEthernet0/1
speed 1000
duplex full
nameif vlan201
security-level 80
ip address 10.5.10.254 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 10.10.1.3 255.255.255.0
management-only
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00

access-list outside_access_in extended permit tcp any host 172.16.10.211 eq http

pager lines 24
logging asdm informational
mtu outside 1500
mtu management 1500
mtu vlan201 1500
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
static (vlan201,outside) 172.16.10.211 10.5.10.211 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 172.16.10.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.10.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 15
ssh version 2
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 50
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global

Correct Answer by Jon Marshall about 7 years 4 months ago

lssc_cisco wrote:


Hi Jon,


Yes, I've changed the public facing IPs... so the 172.16.10.252 would indeed need a device between it and the Internet to get out -- I figured that would be assumed (as you mentioned) since I could ping google.com from the firewall.  The big issue was that I could not do the same from an internal (behind the firewall) host.


I suppose that I've misunderstood the purpose of the nat-control command.  I am using non-routable IPs internally on the vlan201 interface.  There will also be other interfaces brought up which will also utilize non-routable addresses.  So...  do I need to use nat-control.   Would you only NOT use nat-control when the global IP is the same as the internal IP (i.e.  if I had a host with an Internet facing IP of 209.208.207.6 and its IP behind the firewall was also 209.208.207.6) ??


no nat-control disables NAT but if you are using private IPs then you can't disable NAT if you want to NAT private IP address to the outside interface of your firewall.


If your internal hosts were assigned public IPs then you would not need NAT. To be honest turning off NAT is far more relevant when you use the firewall for internal firewalling ie. in a data centre or a campus LAN and on both sides of the firewall are private addresses.


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Tue, 02/23/2010 - 12:56
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

lssc_cisco wrote:


Hello,


I've configured an ASA5520 and setup a single host on the inside to test connectivity.  I can ping external/Internet addresses fine from the firewall (i.e. I can ping google from the firewall), however, I cannot ping external IPs from the host inside/behind the firewall.  I can ping the firewall fine from the host... so this looks to be a NAT issue.  You'll see in the config below that I've setup a static NAT for the internal host... so shouldn't that work?  As soon as I enabled 'nat-control' I was able to get out.  However, if I disable nat-control, I cannot.  Without enabling nat-control, what can I change in the config below?



interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 172.16.10.252 255.255.255.128
!
interface GigabitEthernet0/1
speed 1000
duplex full
nameif vlan201
security-level 80
ip address 10.5.10.254 255.255.255.0
!

!
i
!
f
static (vlan201,outside) 172.16.10.211 10.5.10.211 netmask 255.255.255.255
access-group outside_access_in in interface outside


I am a little confused by the addressing. Neither the outside or inside interfaces are using addressing that is routable on the internet. Have you changed the outside address for security reasons in this post. If not does a device further upstream NAT the packets.


As for the inside, if it really is using 10.5.10.x address then you can't disable nat-control unless a device further upstream is set to NAT all packets to a public IP address. 10.5.10.x is a private address so somewhere it has to be natted.


Jon

lssc_cisco Tue, 02/23/2010 - 13:12
User Badges:

Hi Jon,


Yes, I've changed the public facing IPs... so the 172.16.10.252 would indeed need a device between it and the Internet to get out -- I figured that would be assumed (as you mentioned) since I could ping google.com from the firewall.  The big issue was that I could not do the same from an internal (behind the firewall) host.


I suppose that I've misunderstood the purpose of the nat-control command.  I am using non-routable IPs internally on the vlan201 interface.  There will also be other interfaces brought up which will also utilize non-routable addresses.  So...  do I need to use nat-control.   Would you only NOT use nat-control when the global IP is the same as the internal IP (i.e.  if I had a host with an Internet facing IP of 209.208.207.6 and its IP behind the firewall was also 209.208.207.6) ??

Correct Answer
Jon Marshall Tue, 02/23/2010 - 13:42
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

lssc_cisco wrote:


Hi Jon,


Yes, I've changed the public facing IPs... so the 172.16.10.252 would indeed need a device between it and the Internet to get out -- I figured that would be assumed (as you mentioned) since I could ping google.com from the firewall.  The big issue was that I could not do the same from an internal (behind the firewall) host.


I suppose that I've misunderstood the purpose of the nat-control command.  I am using non-routable IPs internally on the vlan201 interface.  There will also be other interfaces brought up which will also utilize non-routable addresses.  So...  do I need to use nat-control.   Would you only NOT use nat-control when the global IP is the same as the internal IP (i.e.  if I had a host with an Internet facing IP of 209.208.207.6 and its IP behind the firewall was also 209.208.207.6) ??


no nat-control disables NAT but if you are using private IPs then you can't disable NAT if you want to NAT private IP address to the outside interface of your firewall.


If your internal hosts were assigned public IPs then you would not need NAT. To be honest turning off NAT is far more relevant when you use the firewall for internal firewalling ie. in a data centre or a campus LAN and on both sides of the firewall are private addresses.


Jon

Actions

This Discussion