IOS XR Interface up/down trap

Answered Question
Feb 23rd, 2010

For interface up/down trap

In IOS it used to be:

Generic: 2; Specific: 0; Enterprise: .1.3.6.1.6.3.1.1.5;

Variables:

[1] mgmt.mib-2.interfaces.ifTable.ifEntry.ifIndex.34 (Integer): 34

[2] mgmt.mib-2.interfaces.ifTable.ifEntry.ifDescr.34 (OctetString): POS2/1/0

[3] mgmt.mib-2.interfaces.ifTable.ifEntry.ifType.34 (Integer): 171

[4] private.enterprises.cisco.local.linterfaces.lifTable.lifEntry.locIfReason.34 (OctetString): Keepalive failed

Annotations:

In IOS XR we are missing ifDescr

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 11 months ago

Try doing:

no snmp-server trap link ietf
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Joe Clarke Wed, 02/24/2010 - 20:21

IOS is using a custom linkDown trap which includes ifDescr.  The IETF linkUp/linkDown traps do not include this varbind.  I do not have an IOS-XR device with which to test, but from what I've seen IOS-XR can send the same traps that IOS sends.  What version of XR do you have?  What does your config look like?

Atif Siddiqui Wed, 02/24/2010 - 20:31

Here is the config:

IOS XR version 3.6.1

snmp-server trap link ietf  ---> I see this is ietf and no other choice
snmp-server host 10.10.10.40 traps admin

snmp-server host 10.11.10.40 traps admin
snmp-server view N ip included
snmp-server view N ifMIB included
snmp-server view N system included
snmp-server view N cpwVcMIB included
snmp-server view N entityMIB included
snmp-server view N interfaces included
snmp-server view N cpwVcMplsMIB included
snmp-server view N ciscoCBQosMIB included
snmp-server view N ciscoPingEntry included
snmp-server view N ciscoProcessMIB included
snmp-server view N ciscoMemoryPoolEntry included
snmp-server view N ciscoEnhancedMemPoolMIB included
snmp-server community admin RO N-SNMP-ACL
snmp-server traps snmp
snmp-server traps config
snmp-server traps entity
snmp-server location X
snmp-server trap-source MgmtEth0/8/CPU0/0

Atif Siddiqui Thu, 02/25/2010 - 08:13

Thanks Joe.

This solves the problem.

One more question. we do not see LDP traps coming from the XR router.

here is the config; when i enable LDP traps it just does not show up in the config:

snmp-server host 10.10.141.253 traps ovadmin
snmp-server view N ip included
snmp-server view N system included
snmp-server view N cpwVcMIB included
snmp-server view N entityMIB included
snmp-server view N interfaces included
snmp-server view N cpwVcMplsMIB included
snmp-server view N mplsTeStdMIB included
snmp-server view N ciscoCBQosMIB included
snmp-server view N ciscoPingEntry included
snmp-server view N ciscoProcessMIB included
snmp-server view N ciscoMemoryPoolEntry included
snmp-server view N ciscoEnhancedMemPoolMIB included
snmp-server community admin RO
snmp-server community admirw RW
snmp-server traps snmp
snmp-server traps config
snmp-server traps entity
snmp-server location Y

snmp-server trap-source MgmtEth0/8/CPU0/0

Tried to enable it:

RP/0/8/CPU0:P1(config)#snmp-server traps mpls ?
  frr          Enable MPLS FRR traps
  l3vpn        Enable MPLS L3VPN traps
  ldp          Enable MPLS LDP traps
  traffic-eng  Enable MPLS TE traps
RP/0/8/CPU0:P1(config)#snmp-server traps mpls ldp ?
  down       Enable MPLS LDP session down traps
  threshold  Enable MPLS LDP threshold traps
  up         Enable MPLS LDP session up traps
RP/0/8/CPU0:P1(config)#snmp-server traps mpls ldp ?
  down       Enable MPLS LDP session down traps
  threshold  Enable MPLS LDP threshold traps
  up         Enable MPLS LDP session up traps
RP/0/8/CPU0:P1(config)#snmp-server traps mpls ldp down ?
   
RP/0/8/CPU0:P1(config)#snmp-server traps mpls ldp down
RP/0/8/CPU0:P1(config)#snmp-server traps mpls ldp up  
RP/0/8/CPU0:P1(config)#commit
RP/0/8/CPU0:P1(config)#end

does not show up in the config.

Joe Clarke Thu, 02/25/2010 - 13:41

I do not think this thread is applicable since you appear to be seeing other traps, and you are specifying what is probably the correct trap source interface.  I don't see any known bugs affecting LDP traps, and as I said before, I am unable to test locally.  I can say your config (at least SNMP-wise) does look correct.

Actions

This Discussion