Problem with config archive on C6500 dual sup

Unanswered Question
Feb 24th, 2010

Hi,

I've configured our switches to archive the config using the archive command, but I'm receiving following error:

switch#wr
Building configuration...

%Error deleting slavesup-bootdisk:archived-configFeb-23-14-33-08.161-GMT+1-13 (File in use in an incompatible mode)[OK]
switch#

in the logging I get:

Feb 24 13:56:28.351 GMT+1: %PFINIT-SP-5-CONFIG_SYNC: Sync'ing the startup configuration to the standby Router.
Feb 24 13:56:35.255 GMT+1: %ARCHIVE_CONFIG-6-ARCHIVE_DELETE_FAILED_STANDBY: Delete of a previously saved archive of the router configuration could not be completed on the standby RP.

when I try to delete manually the archived file I get:

switch#dir slavesup-bootdisk:
Directory of slavesup-bootdisk:/

    1  -rw-   101534052  Dec 13 2009 22:42:54 +01:00  s72033-advipservicesk9_wan-mz.122-33.SXI2a.bin
    2  -rw-    33554432  Dec 13 2009 22:38:12 +01:00  sea_console.dat
    3  -rw-    33554432  Dec 14 2009 09:50:46 +01:00  sea_log.dat
    4  -rw-   101601124  Feb 23 2010 09:40:54 +01:00  s72033-advipservicesk9_wan-mz.122-33.SXI3.bin
    5  -rw-       27423  Feb 23 2010 13:50:02 +01:00  archived-configFeb-23-13-50-00.471-GMT+1-6
    6  -rw-       27545  Feb 23 2010 14:33:10 +01:00  archived-configFeb-23-14-33-08.161-GMT+1-13
    7  -rw-       27405  Feb 23 2010 10:35:00 +01:00  archived-configFeb-23-10-34-58.343-GMT+1-2
    8  -rw-       27414  Feb 23 2010 10:35:34 +01:00  archived-configFeb-23-10-35-33.115-GMT+1-3
    9  -rw-       27443  Feb 23 2010 10:44:38 +01:00  archived-configFeb-23-10-44-36.679-GMT+1-4
   10  -rw-       27368  Feb 23 2010 12:23:50 +01:00  archived-configFeb-23-12-23-48.059-GMT+1-5
   11  -rw-       27545  Feb 24 2010 09:34:56 +01:00  archived-configFeb-24-09-34-55.475-GMT+1-14
   12  -rw-       27545  Feb 24 2010 09:40:56 +01:00  archived-configFeb-24-09-40-54.484-GMT+1-15
   13  -rw-       27545  Feb 24 2010 10:37:28 +01:00  archived-configFeb-24-10-37-27.985-GMT+1-16
   14  -rw-       27521  Feb 24 2010 10:48:46 +01:00  archived-configFeb-24-10-48-46.813-GMT+1-17
   15  -rw-       25880  Feb 24 2010 13:56:34 +01:00  archived-configFeb-24-13-56-32.111-GMT+1-18

1024557056 bytes total (753926144 bytes free)
switch#

switch#delete slavesup-bootdisk:archived-configFeb-23-14-33-08.161-GMT+1-13
Delete filename [archived-configFeb-23-14-33-08.161-GMT+1-13]?
Delete slavesup-bootdisk:/archived-configFeb-23-14-33-08.161-GMT+1-13? [confirm]
%Error deleting slavesup-bootdisk:/archived-configFeb-23-14-33-08.161-GMT+1-13 (File in use in an incompatible mode)
switch#

This is my config:

archive
path sup-bootdisk:archived-config
maximum 5
write-memory
time-period 1440

Anyone seen this and knows how to fix it?

Thanks in advance,

Dario

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 03/01/2010 - 13:46

Hello Dario,

what is the output of show redundancy?

Is the standby supervisor in the expected state?

if so the problem is confined to this feature

Hope to help

Giuseppe

dario.didio Tue, 03/02/2010 - 01:47

Hi,

Yes, the show redundancy gives the correct states for both supervisors (active - standby hot).

It seems that a supervisor switchover or failover causes this.

Thanks anyway.

Br,

Dario

DEAN WETHERALD Fri, 05/25/2012 - 02:31

Dario - Did you resolve this? I'm getting the same error messages but the 'show archive' looks ok.

Regards,

Dean

Pronoy Dasgupta Sun, 03/21/2010 - 10:05

Hey Dario,

could you put up the output of the "show archive" command here?

thanks

Pronoy

Actions

This Discussion