Devices steel in learning mode in DFM

Answered Question
Feb 24th, 2010

Windows 2003 R2

LMS 3.2

DFM 3.2.0

CM 5.2.1

RME 4.3.1


Hello,

All my device steel in learning mode.


Also I have this error on the page DFM - Device Management - Device Import - Auto Allocation


Error in getting instance of TreeGenerator class
com.cisco.nm.trx.kdm.utils.DcrGroupSelectorTreeGenerator
Root Cause:com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "ogs_server_urn" : Not found !!




Correct Answer by Joe Clarke about 6 years 11 months ago

Is the fully-qualified hostname, 5VA-VAL-A5TR503.valcartier.mil.ca resolvable on this server?  That is, what output do you get for:


NMSROOT/bin/perl NMSROOT/bin/resolver.pl 5VA-VAL-A5TR503.valcartier.mil.ca
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Mon, 03/01/2010 - 00:06

First, try rebooting the server.  This will rule out a process state issue.  If the problem persists, post the output of the pdshow command.

Joe Clarke Mon, 03/01/2010 - 09:23

Did you do the reboot?  Is the problem persisting after the reboot?

Joe Clarke Mon, 03/01/2010 - 12:47

Post the NMSROOT/objects/smarts/local/logs/DFM.log and DFM1.log as well as any error messages you see in the Windows Event Viewer.

ocaron Tue, 03/02/2010 - 03:59

This the posts


Thanks


Also I noticed for a while, in my CM windows.  I have no jobs in the completed job.

But in CS and RME jobs are presents.


May be my problem is upstream of DFM ?

Attachment: 
Joe Clarke Tue, 03/02/2010 - 12:00

Post the DFMOGSServer.log, and the output of the command:


NMSROOT/objects/smarts/bin/brcontrol
Correct Answer
Joe Clarke Mon, 03/08/2010 - 11:16

Is the fully-qualified hostname, 5VA-VAL-A5TR503.valcartier.mil.ca resolvable on this server?  That is, what output do you get for:


NMSROOT/bin/perl NMSROOT/bin/resolver.pl 5VA-VAL-A5TR503.valcartier.mil.ca
ocaron Tue, 03/09/2010 - 05:51

Your the man.


Thanks alot.


The problem came because this server is not in the same domain of the main network.

Michel Hegeraat Mon, 03/01/2010 - 00:41

I got exactly the same error message.


It went away when I could use a static IP address for the LMS server.


My devices however did move to the 'known' state.


If they remain learning at 10% it often means that there is an SNMP connectivity issue.


Cheers,


Michel

ocaron Mon, 03/01/2010 - 04:36

May be the problem is during the process of CM.  I don't know.


It's seem that the process between RME and CM is OK.  But from CM to DFM ....


I post the pdshow and I will wait from the answer of mister Clarke.

ocaron Mon, 03/01/2010 - 06:16

To helping you to understand the problem.


I try to change the poling configuration in DFM and I received this message.


Could not retrieve current data since the PTMServer process is down.

Please restart the process and perform this operation again.


But the PTMServer is running

Peter_Setaffy Mon, 03/15/2010 - 05:06

Hallo

I have also the problem.

This is my version LMS:


LMS 2.5


CiscoWorks Common Services 3.0.3
Campus Manager 4.0.3
CiscoView 6.1.2
Device Fault Manager 2.0.3
Integration Utility 1.6.0
Resource Manager Essentials 4.0.3


Can someone help me?

thanks

Peter_Setaffy Mon, 03/15/2010 - 07:02

Check the files.


Could not retrieve current data since the PTMServer process is down.

Please restart the process and perform this operation again.

Attachment: 

Actions

This Discussion

Related Content