Etherchannel between 2 2960's not working

Unanswered Question
Feb 24th, 2010

Hello,

I am trying to configure an etherchannel between 2 2960's.  They are not in production yet, but I have configured the 2 switches with the etherchannel, and I have put 2 PC's ether side and they can ping each other.  If I shut down one of the port for the trunk the PC's can no longer ping each other, I want the other trunk port to take over for redundancy, well not take of as they should be load balancing.  The PC's are in Interface fe 0/1 on eaach switch.

Switch 1:

hostname Switch1
!
!
!
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/2
!
(removed)
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface GigabitEthernet1/2
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
ip address 192.168.50.251 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login

Switch 2:

hostname Switch2
!
!
!
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/2
!
(Removed)
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface GigabitEthernet1/2
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
ip address 192.168.50.252 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login

hope you can see what I'm doing wrong, the trunks go to each switches gigabitethernet ports.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Wed, 02/24/2010 - 15:58

    Sounds like you only have 1 port working in the etherchannel .   Bring both ports up at the same time using the port channel SVI .  Verify channel operation with show etherc summary and verify both ports show working in the channel  .   Also instead of forcing them on you could try "channel-group x mode desirable non-silent"

Andy White Thu, 02/25/2010 - 01:02

Hi, I'm not familiar with the port channel SVI, where do I enter this?

KARUPPUCHAMY MA... Thu, 02/25/2010 - 01:28

Hi,

Need to do the below steps.

1.shutdown both the physical ports

2.do no shut of the both interfaces and check the status of both interfaces. it should be up and both the interface speed,configurations should be match.

3.Now check the status of the port-channel interface.

regards

karuppu

Ganesh Hariharan Thu, 02/25/2010 - 01:25

Hello,

I am trying to configure an etherchannel between 2 2960's.  They are not in production yet, but I have configured the 2 switches with the etherchannel, and I have put 2 PC's ether side and they can ping each other.  If I shut down one of the port for the trunk the PC's can no longer ping each other, I want the other trunk port to take over for redundancy, well not take of as they should be load balancing.  The PC's are in Interface fe 0/1 on eaach switch.

Switch 1:

hostname Switch1
!
!
!
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/2
!
(removed)
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface GigabitEthernet1/2
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
ip address 192.168.50.251 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login

Switch 2:

hostname Switch2
!
!
!
interface FastEthernet0/1
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/2
!
(Removed)
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface GigabitEthernet1/2
switchport trunk native vlan 99
channel-group 1 mode on
switchport mode trunk
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
ip address 192.168.50.252 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login

hope you can see what I'm doing wrong, the trunks go to each switches gigabitethernet ports.

Hi Andy,

I agree with Glen's point it seems that in etherchannel only one port is working just check out the below things as you are trying this in testing environment for configuring etherchannel.

If you configure an EtherChannel from trunk ports, verify that the trunking mode (ISL or IEEE 802.1Q) is the same on all the trunks. Inconsistent trunk modes on EtherChannel ports can have unexpected results.

An EtherChannel supports the same allowed range of VLANs on all the ports in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the ports do not form an EtherChannel even when PAgP is set to the auto or desirable mode.

Ports with different spanning-tree path costs can form an EtherChannel if they are otherwise compatibly configured. Setting different spanning-tree path costs does not, by itself, make ports incompatible for the formation of an EtherChannel.

Configure all ports in an EtherChannel to operate at the same speeds and duplex modes.


Assign all ports in the EtherChannel to the same VLAN, or configure them as trunks. Ports with different native VLANs cannot form an EtherChannel.

Hope to Help !!

Ganesh.H

glen.grant Thu, 02/25/2010 - 02:21

  Port channel-channel SVI is just another way of saying  "interface port-channel x"  .  

Actions

This Discussion