2950G log shows Internal POWER supply is FAULTY

Answered Question
Feb 25th, 2010
User Badges:

Hi Everyone, I've a 2950G that from time to time logs the Internal POWER supply is FAULTY message. The switch is operating normally, it's not rebooting and isn't connected to an RPS. The IOS  version is .121-22.EA8a. Has anyone any idea whether this is a genuine hardware problem or is it software related?


best wishes, Mike

Correct Answer by Sergei Vasilenko about 7 years 2 months ago

Hi Mike,


If 'show env all" does not presents any PS failures, then it could be some cosmetic issue.

For example, could be due to the not fully correct changes in the code

done under CSCsb73608 "2950 does not generate error message when power supply fails",

which in turn were corrected in 12.1(22)EA9 under CSCse84332.

Thanks,

Sergey

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Sergei Vasilenko Thu, 02/25/2010 - 02:51
User Badges:
  • Cisco Employee,

Hi Mike,


If 'show env all" does not presents any PS failures, then it could be some cosmetic issue.

For example, could be due to the not fully correct changes in the code

done under CSCsb73608 "2950 does not generate error message when power supply fails",

which in turn were corrected in 12.1(22)EA9 under CSCse84332.

Thanks,

Sergey

mike.purdon Thu, 02/25/2010 - 02:58
User Badges:

Thanks for your answer Sergey, I'll try the code upgrade


best wishes, Mike

fpanarelli Wed, 06/09/2010 - 08:27
User Badges:

Hi,

have you news about this problem ?

I have the same error after upgrade.....last IOS 12.1(22)EA13


thank's for a feedback


regards

mike.purdon Wed, 06/09/2010 - 23:58
User Badges:

Hi, the code upgrade didn't fix the problem, the switch has continued to work  but the CLI showed psu fault. We plan to replace the switch just in case the psu suddenly dies, best wishes, Mike

Actions

This Discussion