LMS 3.2 DFM questioned devices

Unanswered Question
Feb 25th, 2010
User Badges:

Hey experts,


I have a problem with questioned devices in LMS 3.2 DFM.


I changed the name of some Devices ( on Device and on DNS ) after the next Device Discovery they updated correctly their names in DCR.


DFM Import is set to "auto".


Now, the devices are in DCR with the new name and in DFM with the old name and marked as questioned.

If I select all devices wich are questioned and say re-discover, then they won´t rediscovered with the new name and still keeps in status questioned.



I could set up DFM Import to "manual", delete the  affected devices and re-add them manually. I think this will work and they will have status "known" again.


But this isn´t a solution for my opinion.



Is there a official Bug for this Problem? Devices change to status questioned after changeing their Names  / DCR Names ?



Thx,

Patrick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Joe Clarke Thu, 02/25/2010 - 17:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What properties have you filled in for these devices in DCR?

patrick.peuten_2 Thu, 02/25/2010 - 23:34
User Badges:

Hey,


Discovery Settings are:


Preferred DCR Display Name:  Host Name 
Preferred Management IP:  Resolve By SysName 
Update DCR Display Name:  Yes 
Select a Default Credential Set:  Default


Device properties which are filled:


Device Type

Display Name

Host Name

Domain Name

IP Address



The other fields are empty. I attatched a screenshot ( I have to xxxx all filled fields, sry )



Btw. We had the same problem with cisco 2948G Models. We changed the name of ~ 150 Devices and after that, all of those where questioned in DFM. I deleted them and re-add  them. Then they where in status "known" again. But as I said in the first post, that isn´t a solution in my opinion.

patrick.peuten_2 Mon, 03/01/2010 - 02:11
User Badges:

Hey,


could it be that CiscoWorks DFM tries to connect to the Switches trough the old name instead of the IP Address?


Why is the DisplayName not updated in DFM?


With kind regards,

Patrick

Michel Hegeraat Mon, 03/01/2010 - 03:07
User Badges:
  • Gold, 750 points or more

I'm not 100% sure what it does but this is what I think happens.


DFM still does it own DNS lookups despite the DisplayName being set


I doesn't update anything when somethings changes in the DCR


It does change things when the rediscovery schedule causes a rediscovery


I've "solved" this type of situation by creating a local hostfile containing the names I want displayed in theDCR and in DFM


Cheers,


Michel

Joe Clarke Mon, 03/01/2010 - 09:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

DFM does not respect Display Name.  It tries to determine the hostname of the device via a lookup of the management IP address.  When you changed the hostnames, did you restart LMS?  Java processes can cache name lookups, and it could be using an incorrect hostname.

Joe Clarke Mon, 03/01/2010 - 13:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I did some verification, and if DFM is currently managing a device by hostname (i.e. you see a hostname for the device in the DFM device selectors), then you will need to delete and re-add the device (in DFM only) to change the hostname.  If you do not, and the old hostname is no longer resolvable, DFM will mark the device as Questioned with the error "SNMP Timeout".

patrick.peuten_2 Tue, 03/02/2010 - 00:03
User Badges:

Hey,


so its like I supposed in my first post.

I hope the developer put this behavior on their ToDo list for next release/update .


There are more than a handful of people who will run in this bug, I think.


Thx for all suggestions and support.



Bye,

Patrick

Actions

This Discussion

Related Content