Port Channel config. between Foundry FastIron and Cisco 6500

Unanswered Question
Feb 25th, 2010
User Badges:
  • Bronze, 100 points or more

Dear Experts ,


I'm just trying to configure port-channel between foundry fastiron and Cisco 6500 . The portchannel showing up , but the VLAN traffic seems to be not passing through the trunk ....any clues ?


On Cisco 6500


interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
switchport nonegotiate

!
interface GigabitEthernet3/16
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan all
channel-group 1 mode active
!
interface GigabitEthernet3/37
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan all
channel-group 1 mode active


On Foundry FastIron


interface ethernet 0/1/21
link-aggregate configure key 10000
link-aggregate active
!
interface ethernet 0/1/22
link-aggregate configure key 10000
link-aggregate active



Regads

Haris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
KARUPPUCHAMY MA... Thu, 02/25/2010 - 07:47
User Badges:
  • Silver, 250 points or more

Hi,


can you paste the outpout of the below command in your cisco switch


sh etherchannel summary


regards

karuppu

Haris P Thu, 02/25/2010 - 07:54
User Badges:
  • Bronze, 100 points or more

500-test#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator


        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators:           1


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------


1      Po1(SU)         LACP      Gi3/16(P)  Gi3/37(P)


************************************************************************

Foundry-fastiron#sh link-aggregate
System ID: 0012.f289.d340
Long  timeout: 90, default: 90
Short timeout: 3, default: 3
Port   [Sys P] [Port P] [ Key ] [Act][Tio][Agg][Syn][Col][Dis][Def][Exp][Ope]
0/1/21      1        1       1   Yes   L   Agg  Syn  Col  Dis  No   No   Ope
0/1/22      1        1       1   Yes   L   Agg  Syn  Col  Dis  No   No   Ope

************************************************************************************

Foundry-fastiron#sh trunk


Configured trunks:


Trunk ID: 21
Hw Trunk ID: 1
Ports_Configured: 2
Primary Port Monitored: Jointly


Ports         0/1/21  0/1/22
Port Names    none    none
Port_Status   enable  enable
Monitor       off     off
Rx Mirr Port  N/A     N/A
Tx Mirr Port  N/A     N/A
Monitor Dir   N/A     N/A


Operational trunks:


Trunk ID: 21
Hw Trunk ID: 1
Duplex: Full
Speed: 1G
Tag: No
Priority: level0
Active Ports: 2


Ports         0/1/21  0/1/22
Link_Status   active  active
LACP_Status   ready   ready

**********************************************************


6500-test#sh interfaces trunk


Port          Mode         Encapsulation  Status        Native vlan
Po1           on           802.1q         trunking      1


Port          Vlans allowed on trunk
Po1           10-500


Port          Vlans allowed and active in management domain
Po1           10,100-101


Port          Vlans in spanning tree forwarding state and not pruned
Po1           10,100-101


Regards

Haris

KARUPPUCHAMY MA... Thu, 02/25/2010 - 08:04
User Badges:
  • Silver, 250 points or more

Hi,


The port-channel and the trunk configuration is ok in both end switches.


As far as my concern that , there might be issue with VLAN configuration.


Check VLAN,VTP and spanning tree configuration in Fastlron Switch



regards

karuppu

jfraasch Thu, 02/25/2010 - 10:17
User Badges:

What VLAN are you trying to get through?


The Cisco shows a range of VLANs being allowed but certainly not all of them.


James

Haris P Thu, 02/25/2010 - 14:05
User Badges:
  • Bronze, 100 points or more

I'm trying to pass all VLANS through the link .Is it not possible ?

.

Jon Marshall Thu, 02/25/2010 - 14:13
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

chatwithharis wrote:


I'm trying to pass all VLANS through the link .Is it not possible ?

.


Yes it is possible but at the moment your trunk is forwarding vlans 10, 100 & 101. Is this one of the vlans you are trying to use ?


Jon

Haris P Thu, 02/25/2010 - 22:25
User Badges:
  • Bronze, 100 points or more

Dear Marshal,


Thanks for the reply , but I only configured  vlans 10, 100 & 101 on my 6500 switch . That's why it's showing that this are the only VLANs allowed and active in management domain ....I also tried changing the system priority to low(higher value) in foundry side ..but nothing helped me


The following is my 6500 vlan config



vlan 10,100-101


interface Vlan10
ip address 172.16.27.17 255.255.255.248


interface Vlan100
ip address 172.16.27.1 255.255.255.248

ip route-cache flow


interface Vlan101
ip address 172.16.27.9 255.255.255.248
ip route-cache flow



Regards,

Haris

Haris P Thu, 03/04/2010 - 13:03
User Badges:
  • Bronze, 100 points or more

Dears ,


The problem has been fixed .The Issue was on Foundry side. On Foundry trunk port I need to tagg with All VLANS to pass the traffic



vlan 2 by port
tagged ethe 0/1/23 to 0/1/24
!
vlan 10 by port
tagged ethe 0/1/23 to 0/1/24


vlan 100 by port
tagged ethe 0/1/23 to 0/1/24


vlan 101 by port
tagged ethe 0/1/23 to 0/1/24


Regards

haris

Actions

This Discussion