Call Transfer between SIP and SCCP on CME

Answered Question
Feb 25th, 2010

Hi,

I am configuring a CME 7.1 system to which both SCCP and SIP phones are registered - the SIP phones are DECT cordess phones but are seen as 7960 phones as CME.

When I make a call from a SIP phone to an SCCP phone the call works but when I then try to transfer the call to another SIP phone I get reorder tone.

Is there anything I need to do to enable these types of transfer?

I have this problem too.
0 votes
Correct Answer by Jaime Valencia about 6 years 9 months ago

Have you already configured the appropriate transfer-pattern to allow the calls between SCCP and SIP?

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
felipe.teofilo@... Wed, 11/23/2011 - 09:48

Hello,

I have the same scenario and the same issue. I can´t transfer calls from my SIP phone to my SCCP phones. I´ve already configured the correct transfer-patter under telephony-service. What else do I need to do?

regards,

Felipe

Youssef Aoufi Thu, 08/09/2012 - 08:47

Hi Felipe,

have you found a solution to this problem?

i am facing the same problem. Call transfers from sip to sccp phones fail.

Thenk you in advance

felipe.teofilo@... Tue, 08/14/2012 - 11:58

Hello,

Yes, I´ve found a solution. I could not found a way to attach my configuration, so please check bellow.

RT_Matriz

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.08.14 15:51:12 =~=~=~=~=~=~=~=~=~=~=~=
show run
Building configuration...


Current configuration : 7466 bytes
!
! Last configuration change at 11:46:20 GMT-3 Tue Aug 14 2012 by cisco
!
version 15.1
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
no service password-encryption
!
hostname RT_Matriz
!
boot-start-marker
boot system flash0 flash0:c2900-universalk9-mz.SPA.151-3.T3.bin
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization console
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
clock timezone GMT-3 -3 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 10.10.10.1 10.10.10.20
ip dhcp excluded-address 10.10.10.254
ip dhcp excluded-address 10.10.20.254
ip dhcp excluded-address 10.10.20.1 10.10.20.10
ip dhcp excluded-address 10.10.30.254
ip dhcp excluded-address 10.10.30.1 10.10.30.10
!
ip dhcp pool LABLYNC
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.254
   domain-name lanlink.com.br
   dns-server 10.10.10.1
!
ip dhcp pool LABLYNC-vlan20
   network 10.10.20.0 255.255.255.0
   default-router 10.10.20.254
   domain-name lanlink.com.br
   dns-server 10.10.10.1
!
ip dhcp pool LABLYNC-vlan30
   network 10.10.30.0 255.255.255.0
   default-router 10.10.30.254
   domain-name lanlink.com.br
   dns-server 10.10.10.1
!
!
no ip domain lookup
ip domain name lanlink.com.br
ip name-server 10.10.10.1
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
  bind control source-interface GigabitEthernet0/2
  bind media source-interface GigabitEthernet0/2
  registrar server expires max 36000 min 600
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
!
voice class h323 1
  h225 timeout tcp establish 0
!
!
voice register global
mode cme
source-address 10.10.10.254 port 5060
max-dn 10
max-pool 10
timezone 17
time-format 24
hold-alert
tftp-path flash:
create profile sync 0003325632230674
!
voice register dn  1
number 9156
name Felipe
label Felipe
!
voice register dn  2
number 9111
name Lucas
label Lucas
!
voice register dn  3
number 9123
name David
label David
!
voice register template  1
!
voice register pool  1
id mac 0026.9EB7.4192
number 1 dn 1
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 9156 password cisco
!
voice register pool  2
id mac 3C4A.924B.0A80
number 1 dn 2
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 9111 password cisco
!
voice register pool  3
id mac 0026.2DFA.16C7
number 1 dn 3
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 9123 password cisco
!
!
!
voice translation-rule 1000
rule 1 /^71../ /687393255/
rule 2 /^72../ /687393255/
!
voice translation-rule 2000
rule 1 /^04000..../ /687393255/
!
voice translation-rule 4000
rule 1 /\(^80..\)/ /+3466\1/
!
voice translation-rule 4001
rule 1 /\(^73..\)/ /+4000\1/
!
!
voice translation-profile LYNC_FILIAL
translate called 4001
!
voice translation-profile LYNC_MATRIZ
translate called 4000
!
voice translation-profile LYNC_MATRIZ_REROUTE
translate called 2000
!
voice translation-profile PSTN
translate called 1000
!
!
license udi pid CISCO2921/K9 sn FTX1615AL86
hw-module pvdm 0/0
!
!
!
username cisco privilege 15 password 0 cisco
!
redundancy
!
!
ip ftp username anonymous
ip ftp password [email protected]
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 200.200.200.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 10.10.10.254 255.255.255.0
duplex auto
speed auto
!
!
router eigrp 10
network 10.10.10.0 0.0.0.255
network 200.200.200.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 10.10.20.0 255.255.255.0 10.10.10.253
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory answer dualtone
soft-offhook
cptone BR
timeouts initial 1
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 9056
description celular 085-8893-1099
station-id name Interface Celular Matriz
station-id number 8588931099
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/2
sccp ccm 10.10.10.254 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/2
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode 
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
maximum sessions 2
associate application SCCP
!
dial-peer voice 100 voip
destination-pattern 71..
session target ipv4:10.71.1.254
voice-class h323 1
!
dial-peer voice 101 voip
destination-pattern 72..
session target ipv4:10.71.1.254
voice-class h323 1
!
dial-peer voice 300 pots
destination-pattern 6[789].......
port 0/0/0
forward-digits 8
!
dial-peer voice 200 pots
translation-profile outgoing PSTN
preference 1
destination-pattern 71..
port 0/0/0
!
dial-peer voice 201 pots
translation-profile outgoing PSTN
preference 1
destination-pattern 72..
port 0/0/0
!
dial-peer voice 408 voip
translation-profile outgoing LYNC_MATRIZ
destination-pattern 80..
session protocol sipv2
session target ipv4:10.10.10.5:5068
session transport tcp
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
dial-peer voice 409 voip
translation-profile outgoing LYNC_FILIAL
destination-pattern 73..
session protocol sipv2
session target ipv4:10.71.1.10:5068
session transport tcp
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
dial-peer voice 301 pots
destination-pattern 0[34].......
port 0/0/0
forward-digits 8
!
dial-peer voice 302 pots
destination-pattern 00800.......
port 0/0/0
forward-digits 11
!
dial-peer voice 407 voip
translation-profile incoming LYNC_MATRIZ_REROUTE
session protocol sipv2
session transport tcp
incoming called-number 04000....
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
shutdown
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 2
sdspfarm tag 1 CME-TRANSC
no auto-reg-ephone
em logout 0:0 0:0 0:0
max-ephones 10
max-dn 10
ip source-address 10.10.10.254 port 2000
time-zone 17
time-format 24
date-format dd-mm-yy
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Aug 14 2012 09:00:45
!
!
ephone-dn  1
number 9056
label Felipe
name Felipe
!
!
ephone-dn  2
number 9011
label Lucas
name Lucas
!
!
ephone-dn  3
number 9023
label David
name David
!
!
ephone  1
mac-address 0026.9EB7.4192
button  1:1
!
!
!
ephone  2
mac-address 3C4A.924B.0A80
button  1:2
!
!
!
ephone  3
mac-address 0026.2DFA.16C7
button  1:3
!
!
!
banner login ^C
*********************************
***      Roteador Matriz      ***
*********************************
^C
!
line con 0
line aux 0
line vty 0 1
exec-timeout 1440 0
transport input all
line vty 2 4
transport input all
!
scheduler allocate 20000 1000
ntp server 200.200.200.1
end

RT_Matriz#exit

RT_Filial

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.08.14 15:52:06 =~=~=~=~=~=~=~=~=~=~=~=
show run
RT_Filial#show running-config
Building configuration...


Current configuration : 6474 bytes
!
! Last configuration change at 11:14:19 GMT-3 Tue Aug 14 2012 by cisco
! NVRAM config last updated at 11:14:21 GMT-3 Tue Aug 14 2012 by cisco
!
version 15.1
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
service password-encryption
!
hostname RT_Filial
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.151-3.T3.bin
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization console
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
clock timezone GMT-3 -3 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 10.71.1.254
!
ip dhcp pool LABLYNC
   network 10.71.1.0 255.255.255.0
   default-router 10.71.1.254
   domain-name lanlink.com.br
   dns-server 10.71.1.10
!
!
no ip domain lookup
ip domain name lanlink.com.br
ip name-server 10.10.10.1
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
  bind control source-interface GigabitEthernet0/2
  bind media source-interface GigabitEthernet0/2
  registrar server expires max 36000 min 600
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
!
voice class h323 1
  h225 timeout tcp establish 2
!
!
voice register global
mode cme
source-address 10.71.1.254 port 5060
max-dn 10
max-pool 10
timezone 17
time-format 24
hold-alert
tftp-path flash:
create profile sync 0003743326498813
!
voice register dn  1
number 7256
name Felipe-SSA
label Felipe-SSA
!
voice register dn  2
number 7211
name Lucas-SSA
label Lucas-SSA
!
voice register dn  3
number 7223
name David-SSA
label David
!
voice register template  1
!
voice register pool  1
id mac 0026.9EB7.4192
number 1 dn 1
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 7256 password cisco
!
voice register pool  2
id mac 3C4A.924B.0A80
number 1 dn 2
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 7211 password cisco
!
voice register pool  3
id mac 0026.2DFA.16C7
number 1 dn 3
template 1
dtmf-relay rtp-nte sip-notify
voice-class codec 1
username 7223 password cisco
!
!
!
voice translation-rule 2000
rule 1 /^03466..../ /688931099/
!
voice translation-rule 4000
rule 1 /\(^80..\)/ /+3466\1/
!
voice translation-rule 4001
rule 1 /\(^73..\)/ /+4000\1/
!
!
voice translation-profile LYNC_FILIAL
translate called 4001
!
voice translation-profile LYNC_FILIAL_REROUTE
translate called 2000
!
voice translation-profile LYNC_MATRIZ
translate called 4000
!
!
license udi pid CISCO2921/K9 sn FTX1615AL8H
hw-module pvdm 0/0
!
!
!
username cisco privilege 15 password 7 01100F175804
!
redundancy
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 200.200.200.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 10.71.1.254 255.255.255.0
duplex auto
speed auto
!
!
router eigrp 10
network 10.71.1.0 0.0.0.255
network 200.200.200.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory answer dualtone
soft-offhook
cptone BR
timeouts initial 1
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 7156
description celular 085-8739-3255
station-id name Interface Celular Filial
station-id number 8587393255
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/2
sccp ccm 10.71.1.254 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/2
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode 
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
maximum sessions 2
associate application SCCP
!
dial-peer voice 100 voip
destination-pattern 90..
session target ipv4:10.10.10.254
!
dial-peer voice 101 voip
destination-pattern 91..
session target ipv4:10.10.10.254
!
dial-peer voice 409 voip
translation-profile outgoing LYNC_FILIAL
destination-pattern 73..
session protocol sipv2
session target ipv4:10.71.1.10:5068
session transport tcp
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 408 voip
translation-profile outgoing LYNC_MATRIZ
destination-pattern 80..
session protocol sipv2
session target ipv4:10.10.10.5:5068
session transport tcp
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
dial-peer voice 300 pots
destination-pattern 6[789].......
port 0/0/0
forward-digits 8
!
dial-peer voice 301 pots
destination-pattern 0[34].......
port 0/0/0
forward-digits 8
!
dial-peer voice 302 pots
destination-pattern 00800.......
port 0/0/0
forward-digits 11
!
dial-peer voice 407 voip
translation-profile incoming LYNC_FILIAL_REROUTE
session protocol sipv2
session transport tcp
incoming called-number 03466....
dtmf-relay rtp-nte sip-notify
codec g711ulaw
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 2
sdspfarm tag 1 CME-TRANSC
no auto-reg-ephone
em logout 0:0 0:0 0:0
max-ephones 10
max-dn 10
ip source-address 10.71.1.254 port 2000
time-zone 17
time-format 24
date-format dd-mm-yy
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Aug 14 2012 09:00:10
!
!
ephone-dn  1
number 7156
label Felipe-SSA
name Felipe-SSA
!
!
ephone-dn  2
number 7111
label Lucas-SSA
name Lucas-SSA
!
!
ephone-dn  3
number 7123
label David
name David-SSA
!
!
ephone  1
mac-address 0026.9EB7.4192
button  1:1
!
!
!
ephone  2
mac-address 3C4A.924B.0A80
button  1:2
!
!
!
ephone  3
mac-address 0026.2DFA.16C7
button  1:3
!
!
!
banner login ^C
*********************************
***      Roteador Filial
*********************************
^C
!
line con 0
line aux 0
line vty 0 1
exec-timeout 1440 0
transport input all
line vty 2 4
transport input all
!
scheduler allocate 20000 1000
ntp server 200.20.186.76
end

RT_Filial#exit

omni.moreno Thu, 06/13/2013 - 09:15

Hi Felipe,

What exactly have you done to resolve the issue with the call transfer? I've looked at the Show Run output but could't find any changes..

Thanks,

Omni

zeeshan iqbal Wed, 08/21/2013 - 03:09

Hi,

I just want to make sure regarding transfer-patterns .

- having SIP trunks terminating on CME 8.6

- my SCCP extention is 311

- and SIP extension is 411

I can call from SIP to SCCP and vice versa as well. but the issue is if someone called in and SCCP answer the call, it then cannot transfer to SIP user.

Current configuration is:

   transfer-system full-consult

   transfer-pattern .T

what could be the issue.

Thank you.

Zeeshan

zeeshan iqbal Wed, 08/21/2013 - 05:44

Hi,

Thank you for your reply.

Current situation:

RAM: 786 MB

Cisco router C2811: 15.1(4) M5    (C2800NM-ADVIPSERVICESK9-M)

CME Version 8.6

Are you suggesting to upgrade router IOS only or CME verison as well?

cheers

zeeshan

Paolo Bevilacqua Wed, 08/21/2013 - 05:46

Probably it would not change anything.

Take "debug ccsip message" with "term mon" for a failed call transfer.

zeeshan iqbal Wed, 08/21/2013 - 08:22

Hi Yousaf,

Thank you for your suggestion and it really helped me in resolving the issue.

For SIP Trunks terminating on CME, the above given command is essiential to disable the default behavior of referin to SIP proxy and now i can transfer incoming calls from SCCP to SIP clients.

really appreciate you guys.

regards,

Zeeshan

Actions

This Discussion