Unable to form OSPF adjacency on tunnel interface.

Unanswered Question
Feb 25th, 2010

I'm using this product called REX which requires to create gre tunnels in every
OSPF area and form OSPF adjacency to establish routing report.

I have successfully created several gre tunnels but now I'm stuck on this Cisco 6509 running
hybrid mode (12.2.18SXF4), and not able to form OSPF neighbor. My tunnel comes up (interface is up and up)
I can ping or .14 from anywhere in the network but not from the router. I have tried lowering/increasing the mtu to no avail.

Any help would be appreciated.


interface tunnel12
description tunnel for OSPF-12
ip add
ip ospf message-digest-key 1 md5
tunnel source loopback1

ip mtu 1476
tunnel destination

router ospf 1

network area 12

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Sergei Vasilenko Mon, 03/01/2010 - 00:21


Could well be the issue with MTU mismatch on interfaces of both sides.
By default you need to have them equal on both sides in order for OSPF adj to form.
Did you tried "ip ospf mtu-ignore" under interface tunnel12?
This MTU issue and other possible OSPF problems/tips are described at CCO "Troubleshooting OSPF" doc:

In particular - Troubleshoot OSPF MTU:



This Discussion