cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2449
Views
0
Helpful
2
Replies

ASA Site-to-Site VPN

mramirez
Level 1
Level 1

I recently setup a Site-to-Site VPN using a Cisco ASA 5505 to a Cisco 2691 and is working great but internet stops working for clients behind the ASA. I know how to get them back online but it disconnects them from the VPN. Can someone please advice to see what I have done wrong or am missing? I know that acl 110 is blocking them but am breaking my head in trying different things.

Thanks in advance,

ASA# sh run
: Saved
:
ASA Version 8.0(4)
!
domain-name XXXX
enable password XXXXX encrypted
passwd XXXXXX encrypted
names
!
interface Vlan1
nameif Inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XXXXXX.173 255.255.254.0
!
interface Ethernet0/0
description Link to Comcast Router
switchport access vlan 2
!
interface Ethernet0/1
description LINK to Linksys SR2024
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name xxx.com
same-security-traffic permit intra-interface
access-list 110 extended permit tcp any host XXX eq 3389
access-list 110 extended permit tcp any host XXX eq www
access-list 110 extended permit tcp any host XXX eq smtp
access-list 110 extended permit tcp any host XXX eq domain
access-list 110 extended permit tcp any host XXX eq https
access-list 110 extended permit tcp any host XXX eq ftp
access-list 110 extended permit icmp any any
access-list 110 extended permit tcp any host XXX eq 3389
access-list 110 extended permit tcp any host XXX eq www
access-list 110 extended permit tcp any host XXX eq smtp
access-list 110 extended permit tcp any host XXX eq domain
access-list 110 extended permit tcp any host XXX eq https
access-list 110 extended permit tcp any host XXX eq ftp
access-list 110 extended permit tcp any host XXX eq 3389
access-list 110 extended permit tcp any host XXX eq www
access-list 110 extended permit tcp any host XXX eq domain
access-list 110 extended permit tcp any host XXX eq https
access-list 110 extended permit tcp any host XXX eq pptp
access-list 110 extended permit gre any host XXX
access-list 110 extended permit udp any host XXX eq 1701
access-list 110 extended permit esp any host XXX
access-list 110 extended permit ah any host XXX1
access-list Inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 any
access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
mtu Inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
global (outside) 5 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 5 0.0.0.0 0.0.0.0
static (Inside,outside) xxx.169 192.168.0.14 netmask 255.255.255.255
static (Inside,outside) xxx.171 192.168.0.17 netmask 255.255.255.255
static (Inside,outside) xxx.172 192.168.0.12 netmask 255.255.255.255
access-group 110 in interface outside
route outside 0.0.0.0 0.0.0.0 XXX.174 1
timeout xlate 3:00:00
timeout conn 10:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer xxx
crypto map outside_map 1 set transform-set ESP-DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 10
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 10
console timeout 0
dhcpd dns 192.168.0.14 68.87.72.130
dhcpd wins 192.168.0.14
dhcpd domain xxxxx
!
dhcpd address 192.168.0.50-192.168.0.81 Inside
dhcpd enable Inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group xxx type ipsec-l2l
tunnel-group xxx ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!            
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny 
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip 
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:a075331231f1242d1101745d15d84afa
: end       

1 Accepted Solution

Accepted Solutions

stuart
Level 1
Level 1

Hi,

I am assuming a couple of things here:

First is your ASA is directly connected to the internet, and that the VPN goes via the internet.

And also that your users trying to access the internet are in the following subnet 192.168.0.0 255.255.255.0.

If these are both true, then it looks like the issue is with your encryption domain/proxy acls.

Your crypto match acl has an any destination in it, which is bad practice when using site to site vpns.

access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 any

This is basically saying take anything going from 192.168.0.0/24 to any destination and encrypt it across the vpn.

So that includes your internet traffic. Make sure that your are using specific src and dst networks int these acls.

i.e. access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0

Where 192.168.1.0/24 is the remote network on the 2691. This acl should then be reversed, an exact mirror on the opposite (2961) peer.


You will also need to match this acl with your no nat acl, to ensure that your traffic to the internet is natted but the vpn traffic is not.

The acl wont be blocking the traffic either, as you dont have an acl on the inside interface all traffic will be allowed from inside to outside by default.

HTH let me know if there are any issues.

Stu

View solution in original post

2 Replies 2

stuart
Level 1
Level 1

Hi,

I am assuming a couple of things here:

First is your ASA is directly connected to the internet, and that the VPN goes via the internet.

And also that your users trying to access the internet are in the following subnet 192.168.0.0 255.255.255.0.

If these are both true, then it looks like the issue is with your encryption domain/proxy acls.

Your crypto match acl has an any destination in it, which is bad practice when using site to site vpns.

access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 any

This is basically saying take anything going from 192.168.0.0/24 to any destination and encrypt it across the vpn.

So that includes your internet traffic. Make sure that your are using specific src and dst networks int these acls.

i.e. access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0

Where 192.168.1.0/24 is the remote network on the 2691. This acl should then be reversed, an exact mirror on the opposite (2961) peer.


You will also need to match this acl with your no nat acl, to ensure that your traffic to the internet is natted but the vpn traffic is not.

The acl wont be blocking the traffic either, as you dont have an acl on the inside interface all traffic will be allowed from inside to outside by default.

HTH let me know if there are any issues.

Stu

H Stu,

Thanks for your help. By defining the acl to the correct network did the trick and am able to get the VPN and access the internet.

Thanks again.

i.e. access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: