Cannot Find ADSL Firmware 4.0.0.18 for Cisco 1801

Answered Question
Feb 26th, 2010

I have a number of Cisco 1801 routers connected to BT UK’s ADSL2+ Annex-A Wholesale Broadband Connect [WBC] services. The routers are experiencing connectivity issues. There is a cisco product bulletin that defines v4.0.0.18 as the version of ADSL Firmware required on the Cisco 1801 when connecting to this BT service.

I would like to upgrade the ADSL Firmware for these routers but I  cannot find v4.0.0.18 for the Cisco 1801 on CCO. All the 4.0.0.18 downloads appear to  be for various flavours of 800. The Cisco product bulletin shows the 1801 as having the same chipset as the 857,867,877 and 887. Can I use the Firmware from one these 800 models? The MD5 Hash for the code suggests all of the these 800 model use the same code?

Has anybody seen this problem with the Cisco 1801 or upgraded the Firmware to 4.0.0.18.

Any help appreciated.

Regards

Paul

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 6 years 9 months ago

Yes, the 1801 use same HW and FW as the 800 and the HWIC-1ADSL.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Fri, 02/26/2010 - 08:51

Can you link the PB for others to benefit ?

Thank you for the nice rating and good luck!

p.hesketh Fri, 02/26/2010 - 10:14

This may sound a bit daft but I don’t understand what you mean. This is the first time I have really used netpro. If you can explain what I need to do I will be more than happy to sort it out.

Thanks again for your help.

Regards

Paul

p.hesketh Fri, 02/26/2010 - 14:27

Product bulletin

I haven't got a url for the doc and cannot cut and paste the doc into the forum. I get an error message about illegal content i will send you the doc hopefully you will be able to post.

Leo Laohoo Fri, 02/26/2010 - 16:42

ADSL firmware release 4.0.18 is the recommended firmware release to use on CPEs connecting to BT's network for ADSL2/2+ service. It should only be used to resolve ADSL2/2+ interop issues while connecting to the BT network. This release solves issues described in the following DDTS: CSCta54059, CSCta54040, and CSCtb31105.

ADSL firmware version 4.0.17 for UK annex M support only. Compatible with Huawei MA5300 DSLAM, EADB linecard.
Paolo Bevilacqua Sat, 02/27/2010 - 02:18

Thanks Leo.

It should only be used to resolve ADSL2/2+ interop issues  while connecting to the BT network.

In reality it is known that there are other situations where the new FW is necessary to connect. I know of US, Italy, and Spain.

Cisco should really improve their handling of the situation.

damianbell Mon, 07/11/2011 - 07:14

Hi,

I'm seemingly having problems in connecting to the BT network in that I am receiving multiple issues with CRC/Header errors. I'd like to know if FW 4.0.1.18 is still applicable to the issues on BT's 21CN network with the DSLAM's outlined below, and if not why it is that that firmware has been pulled from the CCO? I can't find it anywhere on cisco.com

Cheers,

Damian

Actions

This Discussion

Related Content