SA520W WAN State DOWN

Unanswered Question
Feb 26th, 2010

SA520W... Everything was working until the WAN State suddenly became down and will not return.  I have tried turning off the PPPOE and making it a static or DHCP connection to no avail.  It has literally taken me 2 months to get this configured correctly and once I do it only works for a week.  What can I try?  The WAN LED is not on, the Link State is UP but the WAN State is down, it does not matter if I have PPPOE, Static or DHCP enabled.

I am using the latest firmware, 1.1.21

James

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stone.james Fri, 02/26/2010 - 13:44

Steven,

Here is my configuration, I really hope we can figure this out.

thanks,

James

Steven Smith Fri, 02/26/2010 - 14:19

Hi James,

The LEDs on the WAN port behave a bit differently.  We are looking at adjusting this behavior.

Currently, the LED on the WAN ports show layer 3 connectivity, meaning it has an IP address.  It does not correspond to Layer 2 connectivity, which is confusing.  The box takes a few minutes to boot up completely, so it might mean that you aren't waiting long enough after the reboot for the light to come on.

If the connection is dropping after a few weeks, we are not familiar with that happening.  Could you check your PM?  I am interested in working with you on this and learning about the problems you had over the past few months.

Thanks

Steven

stone.james Fri, 02/26/2010 - 14:42

Steven I have attached the log files and once I figure out how to post in PM I will move to there.

Basically I had a ton of issues until I upgraded to Firmware 1.1.21 which corrected all my issues and allowed for an easy setup, everything was working great since last week (when I got it setup).  Today around 10AM internet went down (still worked with old router and new modem which SA520W connects to).

The setup at this point was for the SA520W to connect via PPPoE (which was working)

I rebooted the router and let it sit for over 20 minutes, WAN LED stayed off and WAN State was DOWN.

I changed the configuration to have the modem initialize PPPoE and the SA520W would be set to DHCP, did not work

Modem had connectivity with IP Address of 75.9.15.6, set SA520W to have Static IP, did not work

Ideally the SA520W would initialize the PPPoE because we have an IP block.

I don't know why it would work for a week and then stop, very frustrating to have to roll back DNS and IP changes across my network.  I had to switch to old setup as we are a web company and rely on the internet.

Hope this help clarify the situation.

James

Message was edited by: stone.james --  emailed files to you.

Paul Luijnenburg Thu, 03/25/2010 - 09:14

Steven,

I have simular problems like James. After some time the connection to the WAN get lost. First time it happend I accused the modem / ADSL connection. My provider uses DHCP so what I did at last is making the WAN adres static. When you force the WAN port to get a new IP adres, sometimes there is succes, in most cases the result is an empty IP adres, resulting in losing the connection. Because you can not influence or discover any logic in the periods that the SA500 sends out DHCP request. The result is random failure. Static works for a few days now but I have little confidence that it will stay that way.

My suggestion is that the DHCP mechanism in the SA520W to the WAN port is just not stable, nor should it directly replace a valid IP adress for an empty adres when for some reason the DHCP server does not give a new valid one.

If there is any progress on this issue let me know. I have more problems with the SA520W. One of them is the new IPS feature, I will post this separately. You mention also the boot time, from my own experience I know that you will have to wait at least 10-15 minutes before all is in place. You can see this quite easily on the CPU status. Today I waited 3 hours and many page refreshes before CPU load dropped to < 10%, something that you would expect from a box with no connections.

Regards,

Paul

Steven Smith Thu, 03/25/2010 - 12:23

The WAN issue that James had is with PPPoE.  We do have a bug written against it.  It is resolved in an upcoming release.  I am not aware of any DHCP bugs, but I can ask about it.

Let me forward this along to the development team to see if they have anything. 

Paul Luijnenburg Thu, 03/25/2010 - 12:45

Steven,

Tnx. I have a PPPoe implementation coming up soon, when will the patch be available ? Processor load still is high 4% for device with no users. Compared to the other device (1%). Could it be possible that I have defective hardware ?

Paul.

Steven Smith Thu, 03/25/2010 - 13:00

Are both SA boxes wireless?  Is the wireless one with the extra cpu?  If so, trying disabling the wireless to see if the CPU drops.  I am sure that wireless traffic could cause a few extra CPU cycles.

Paul Luijnenburg Thu, 03/25/2010 - 15:32

Steven,

Both are wireless. I will try to disable the wireless to see if it drops. What do you mean with the extra CPU ? Is this a model type  and how can I see that ?

Regards,

Paul

Steven Smith Fri, 03/26/2010 - 07:01

I meant extra cpu cycles.  No hardware differences.  I was just stating that wireless traffic could be causing extra cpu cycles and giving the SA 520W a higher cpu usage.

The SA 520 and SA 520W use the same CPU.  The SA 540 uses a different CPU.

Actions

This Discussion

Related Content