Connecting 2821 to 3750

Unanswered Question

Hello, I have not been able to connected my 3750 to my 2821 through the Gi0/1 fixed interface on the 2821.  The 2821 has 1 serial interface, 2 fixed Gigabit Ethernet Interfaces and a card with 9 Fastethernet interfaces.  The serial is used to connect to my WAN.  I can connected the 3750 to any one of the ports of the 9 FastEthernet card when i configure it as a trunk.  I set up the Gi0/1 port on the 2821 the same way, the router doesn't see the switch.  I can get the router's mac-address from the switch however.  The 2821 has VLANs on it.  The 3750 has similar VLANs on it.  How do i configure the Gi0/1 for it to see the switch?


here is the current config for desired port:


(2821)

interface GigabitEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no mop enabled


Here is the config for the working port

(2821)

interface FastEthernet0/1/3
switchport mode trunk
switchport voice vlan 6
spanning-tree portfast



I did try putting switchport mode trunk on int Gi0/1 but had no joy doing that.

I tried to give that port an ip address but would get overlap errors with VLAN1.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Fri, 02/26/2010 - 13:49
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


Gi0/1 is routed port and not a switch port.  If you want trunk it with multiple vlans, you need to create a sub-interface for each vlan.

for example

int gi0/1.1

int gi0/1.2

and so on.

Then add the IP address to the sub-interface and use encapsulation dot1Q and the vlan id


HTH

Reza

Hello,


I did create the sub-interface.  I wasn't able to assign an IP address to it.


2821-1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
2821-1(config)#int gi0/1.1
2821-1(config-subif)#ip address 10.x.x.6 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN
.

Reza Sharifi Sat, 02/27/2010 - 06:41
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


You need to add 802.1q trunk before you can assign your IP


HTH

Reza

Thanks everyone for your assistance


Still no joy.  Not able to add an IP address on to the interface.  I want the VLAN1 traffic to pass back and forth through this interface and to the connected switch.



2821-1#sho run int gi0/1.1
Building configuration...

Current configuration : 109 bytes
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 1 native
no snmp trap link-status
no cdp enable
end


2821-1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
DET-MDF-2821-1(config)#int gi0/1.1
DET-MDF-2821-1(config-subif)#ip address 10.x.x.6 255.255.255.0
% 10.7.0.0 overlaps with Vlan1

Leo Laohoo Fri, 02/26/2010 - 14:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

G0/1 and G0/2 is a routed port so you need to configure "router-on-a-stick" but your 6-port card is a chop-down version of a 2950 or a 3750, so it's a switch.


Configuring InterVLAN Routing and ISL/802.1Q Trunking on a Catalyst 2900XL/3500XL/2950 Switch Using an External Router
http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml

andrewswanson Sat, 02/27/2010 - 04:10
User Badges:
  • Silver, 250 points or more

did you get the error "Command rejected: [interface] not a switching port" when you applied the trunk config to gi0/1? To change a L3 interface to a L2 switching port, use the command switchport e.g.


interface GigabitEthernet0/1
switchport

switchport mode trunk


hth

More Information:


Vlan Config on 2821


interface Vlan1
ip address 10.x.x.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no autostate


Port config on 3750


interface GigabitEthernet1/0/47
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Vlan1
ip address 10.x.x.5 255.255.255.0
ip helper-address 10.x.x.24

KARUPPUCHAMY MA... Mon, 03/01/2010 - 18:45
User Badges:
  • Silver, 250 points or more

Hi,


As per your configuration which you have pasted here, already you have configured vlan 1 as L3 vlan with ip segment 10.x.x.0/24 and the same segment of ip range you trying to assign into fast ethernet sub-interface.


So, As you know,It is not possible to assign same segment of IP range into two different L3 interfaces.


your configuration in the router should be like this


no int vlan 1


int gi0/0

no ip address


int gi0/0.1

encapsulation dot1q 1 native

ip address 10.x.x.1 255.255.255.0 // As per your network range //


Finally you need to remove the ip address in vlan 1. You cannot make the router as switch 100 %. But we can configure router-on-stick method to simulate switch functinality to router.


For more information have a look into this URL, which will clarify more.


http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a00800949fd.shtml


regards

Karuppu

Hello,


We were using the 2821 with the 9 port ethernet switch card as the branch office router and switch.  We had a need for more ports and aquired a 3750.  On the 2821 we have multiple VLANS set up.  Throughout our domain, the switches all have the same VLANS configured.  When I get this first one configured I will be creating more interfaces and putting VLANS on those interfaces. 


To clarify I need to remove the VLAN1 from the L3.  Do I assign the current IP address of the router to the Gi0/1.1 interface or a different one? Because the  rest of the network is looking for that router (and LAN segment) at the 10.x.x.1 address. 


A question I have here would be would the Gi0/1.1 have the full gigabit bandwidth or will it be reduced by the number of subinterfaces I configure?


Thanks.

KARUPPUCHAMY MA... Tue, 03/02/2010 - 04:35
User Badges:
  • Silver, 250 points or more

Hi,


Do I assign the current IP address of the router to the Gi0/1.1 interface or a different one? -- Yes. you can assign the vlan 1 ip address into gi0/1.1


And if you want to permit more vlan over this physical interface, create the required number of interfaces and assign those sub-interfaces into the respective vlan.


A question I have here would be would the Gi0/1.1 have the full gigabit bandwidth or will it be reduced by the number of subinterfaces I configure?


Even if you are creating the 10 sub-interfaces in a single gi0/1, the maximum throughput will be 1Gbps. it will be shared into the multiple sub-interfaces.


Hope this clarified to your question. If you need more info, raise your questions.


regards

karuppu

Actions

This Discussion