Router acting as VPN client

Unanswered Question
Feb 26th, 2010

I want to have my Cisco 1841 open a VPN connection to a remote site using IPsec with a shared secret and a username/password, and route only certaintraffic through this virtual connection. From an IP standpoint, I want the router to act as a client, i.e. it gets a dynamic IP address and provides a connection to the remote site in that direction only.

I want to replace the need to run a VPN client on my desktops to connect to a VPN server, but rather have this built in to the router, but only for certain network ranges.

The problem I'm having is knowing what this setup is called so I can google  a solution. I need pointing in the right direction here

thanks,

Simon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stevjarbeck Mon, 03/01/2010 - 12:14

We do this here with our Cisco 2821 as our EZVPN server, here is the client configuration that we have on our branches 871w's and 881w's.

crypto ipsec client ezvpn VPN
group {Group Name Here} key 0 {Group Key}
username {Username} password 0 {Username Password}
peer {EZVPN Server IP Address}
exit
interface Virtual-Template1 type tunnel
exit
crypto ipsec client ezvpn VPN
virtual-interface 1
exit
interface FastEthernet4
crypto ipsec client ezvpn VPN outside
exit
default interface Virtual-Template1
interface Virtual-Template1 type tunnel
no shutdown
tunnel mode ipsec ipv4
exit
interface BVI1
crypto ipsec client ezvpn VPN inside
exit
no ip route 0.0.0.0 0.0.0.0 {Gateway IP Address} 1
ip route 0.0.0.0 0.0.0.0 {Gateway IP Address} 2

simonwynn Mon, 03/01/2010 - 17:09

Thanks - that totally makes sens when Cisco equipemtn is at the other end, however I'm trying to configure this when connecting to a L2TP VPN server. (other choices are OpenVPN and PPTP). Is that possible?

Simon

Actions

This Discussion